Page 1 of 2 12 LastLast
Results 1 to 20 of 24

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: ZiPhone + 1.1.4 = Crazy Error

  1. #1
    Default ZiPhone + 1.1.4 = Crazy Error
    OK. I updated my iPhone to 1.1.4 then used ZiPhone to jailbreak it.

    After it was jailbroken, everything was going fine. I installed OpenSSH and used WinSCP to get at the file system, then changed some of the .png files to set up my old theme. It was working fine, but then for some reason, it started doing wierd stuff.

    When I start it up now, it pops up with a message saying that I can move stuff around on the home screen by pressing and holding an icon. I hit dismiss and if I try to touch anything, I get the little "working" circle and it refreshes my springboard and re-pops up the message I mentioned.

    I figured I'd just do a restore, but my computer doesn't recognize the phone when I plug it in. (Strangly, it did the reverse noises for plugging stuff in. If I plugged it in, it made the sound for unplugging an item, and vice versa.)

    I tried holding down home and power at the same time, then holding home once it shuts down to enter restore mode, but it ignores it and boots into the buggy springboard I mentioned above.

    It still connects to my router fine and I can SSH, but I'm not sure that the battery is charging, so I'm leaving it turned off for now.

    Any ideas on what to do to restore it?

  2. #2
    Why don't you connect it to your pc and then run ziphone -R? and see if it can come back into the recovery mode? if not, then also try ziphone -d command.

  3. #3
    iPhone? More like MyPhone aemreunal's Avatar
    Join Date
    Jul 2007
    Location
    Istanbul
    Posts
    118
    Thanks
    3
    Thanked 7 Times in 7 Posts

    I suggest you don't use ZiPhone at all, the only thing it's good for is to **** up you iPhone like it did to me

    People, the only thing ZiPhone is good for is to make your iPhone unusable, at least for some features, so DON'T USE ZIPHONE! Use iNdependence, iJailBreak but NOT ZiPhone, he stole some of it from Geohot anyway.

  4. #4
    Livin the iPhone Life
    Join Date
    Dec 2007
    Location
    Boston, MA
    Posts
    1,033
    Thanks
    16
    Thanked 143 Times in 138 Posts

    i used iplus and thought it was great. i never encountered the "iphone needs repair" message when i jailbroke mine although many others have. either way, they're coming out with iplus 2.0 VERY soon to fix that error...see hackthatphone.com for instructions

  5. #5
    I had to restore my phone 3 times before I got everything to work...I restored, setup as a new phone, and jailbroke it now everything works

  6. #6
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,307
    Thanks
    12
    Thanked 562 Times in 483 Posts

    Quote Originally Posted by Sindern View Post
    When I start it up now, it pops up with a message saying that I can move stuff around on the home screen by pressing and holding an icon. I hit dismiss and if I try to touch anything, I get the little "working" circle and it refreshes my springboard and re-pops up the message I mentioned.
    You or some automated process tried to change the root password. Under 1.1.3/1.1.4, this will cause the Springboard to continuously restart.
    Get "iPod & iTunes for Dummies", it'll change your life.

  7. The Following User Says Thank You to Eurisko For This Useful Post:

    Sindern (2008-03-10)

  8. #7
    i too used ziphone and now have some whacky errors on my phone- i.e. a prompt to enter a voicemail password when one was never set! this comes up everytime i enter a different program-very annoying! restoring has done nothing so far. can i restore it and try another jailbreaking program? are any as easy as ziphone???

  9. #8
    Quote Originally Posted by Eurisko View Post
    You or some automated process tried to change the root password. Under 1.1.3/1.1.4, this will cause the Springboard to continuously restart.
    I did change the SSH password since it says that you should. >_<

    Now that I've changed it and the springboard is continuously restarting, how do I restore my phone?

    Quote Originally Posted by GRK View Post
    Why don't you connect it to your pc and then run ziphone -R? and see if it can come back into the recovery mode? if not, then also try ziphone -d command.
    If I try to run ZiPhone as a recovery, it times out looking for the iPhone.
    Last edited by Sindern; 2008-03-10 at 10:07 PM. Reason: Automerged Doublepost

  10. #9
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Quote Originally Posted by aemreunal View Post
    I suggest you don't use ZiPhone at all, the only thing it's good for is to **** up you iPhone like it did to me

    People, the only thing ZiPhone is good for is to make your iPhone unusable, at least for some features, so DON'T USE ZIPHONE! Use iNdependence, iJailBreak but NOT ZiPhone, he stole some of it from Geohot anyway.
    Umm... Zibri did not STEAL anything from Geohot. If you took the time to read his blog from the first release of ziphone 1.0 you will see he gives full credit to him and even asked for his HELP to finalize the code. Additionally, I have used ziphone on more than 50 iphones and have never gotten a single call back about instability or error messages. If you start from a clean restore and set up the phone as NEW instead of restoring from a back-up image (like it's recommended) then you should have ZERO issues.

  11. #10
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,307
    Thanks
    12
    Thanked 562 Times in 483 Posts

    Quote Originally Posted by Sindern View Post
    I did change the SSH password since it says that you should. >_<

    Now that I've changed it and the springboard is continuously restarting, how do I restore my phone?
    Actually the installer specifically says not to change the password for 1.1.3 and above. You can try either SSHing in to your phone and changing the passwd back to alpine. If that doesn't work, I've include the original master.password file below. Place it in your /etc folder.
    Attached Files Attached Files
    Get "iPod & iTunes for Dummies", it'll change your life.

  12. #11
    I set the password back to alpine and put in the default master.password and it's still giving the same error.

    And I remember the "dont change the password" message, but I was doing this all very late at night and didn't know how to get SSH to work, so I found a guide and followed it, and somewhere in the guide it said to run passwd and put in a new password for security and forgot about the original message completely.

    There has to be some way to get it back to normal or at least restore it. What if I were to go in and delete all the SSH files so that it doesn't load it at all? If SSH wasn't loading it would theoretically not have the error, right?

    I haven't done this yet because once I delete them, I can't really get back into the phone.

  13. #12
    can someone help me pleasE, I tired ziphone on my 1.1.4 iphone and I ended up with my wifi not working and when I use iphone browser, I cant find anything on the root and when I try to locate something Iphone browser says your phone might not had been hacked correctly. So can someone help me, hack a 1.1.4 iphone or suggest any other programs that can hack it.

  14. #13
    lol the same thing has been happening to me. I had to restore earlier, and when I remodded my iphone, I always get a pop up saying this accessory is not useable with the Iphone, and then it will NEVER turn off. As soon as I turn off, it turns back on!

  15. #14
    so can someone aleast help me with the wifi problem

  16. #15
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Quote Originally Posted by acasado View Post
    so can someone aleast help me with the wifi problem
    Did you restore or upgrade to 1.1.4? If you upgraded then try restoring... this has always been a sure fix for me.

    One last thing... after you restore always choose to set up your phone as NEW, not from back-up.

  17. #16
    i restored and I set up as new but still doesnt work and my computer uses the router and it works fine

    i did both but wifi still doesnt work and I dont think it's the router because my laptop uses wifi from the router and the internet works fine
    Last edited by acasado; 2008-03-11 at 06:33 AM. Reason: Automerged Doublepost

  18. #17
    So, does anyone know if deleting all the SSH files will make it boot? I just need to get it into a state where it is recognized and can be restored.

    Can I delete a file that would keep it from booting and have it go into restore mode maybe?

    Finally, after what seems like hours of googling, I ran accross this obscure comment:

    anyone who has the backed-up /etc/passwd and /etc/master.passwd, i could really use those… and since i’m on linux w/o hfs support compiled in, i can’t mount the .dmg and extract them.
    I think I need the original /etc/passwd and /etc/master.passwd to replace the old ones with. Before, I tried just replacing master.passwd.

    Could someone supply me with those files?

    http://forums.macrumors.com/showthread.php?t=442389

    (another reference saying that the /etc/passwd file needs replacing.
    Last edited by Sindern; 2008-03-11 at 09:56 AM. Reason: Automerged Doublepost

  19. #18
    same problem.

    Changed passwords by terminal, and non stoping rebooting now.
    Im waiting to get home to try fix this.

    Because i cant use SSH here.

  20. #19
    Livin the iPhone Life
    Join Date
    Dec 2007
    Location
    Boston, MA
    Posts
    1,033
    Thanks
    16
    Thanked 143 Times in 138 Posts

    deleted post
    Last edited by jtesnani; 2008-03-24 at 10:19 PM. Reason: useless info

  21. #20
    Quote Originally Posted by Eurisko View Post
    Actually the installer specifically says not to change the password for 1.1.3 and above. You can try either SSHing in to your phone and changing the passwd back to alpine. If that doesn't work, I've include the original master.password file below. Place it in your /etc folder.
    Hi Eurisko,
    I used the master pwd file in the zip you provided but now am unable to use "alpine" as root password and don't know how to get in using WinSCP. I also realized that the encrypted version of "alpine" is /smx7MYTQIi2M but in your file the root user has du1zkgMdLMySU - and i don't know what this stands for. Am stuck badly so will be very grateful if you can remember what this password was. Thanks so much

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •