Page 1 of 2 12 LastLast
Results 1 to 20 of 22

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Successful Ziphoned 1.1.4 to 2.0 Upgrade

  1. #1
    Default Successful Ziphoned 1.1.4 to 2.0 Upgrade
    I was a little apprehensive about upgrading due to the fact that I had originally unlocked with Ziphone, but it turned out not to be a big deal. I had read conflicting information about Ziphoned 1.1.4 phones... Some state you need to start over with WinPWN (I'm on Windows) while others claim that you don't need to do anything special and yet other people will report that you're just plain screwed.

    Well here's how I did it... Use this information at your own risk (as did I).

    What I had:

    Iphone 1.1.4 with Tmobile T-Zones Hack
    Originally Unlocked / Jailbroken with Ziphone 3.0
    Bootloader 3.9

    What I have now:

    Iphone 2.0 with Tmobile T-Zones Hack
    Bootloader 4.6

    I didn't use WinPWN as all the other guides have stated, instead I:

    1) Installed BootNeuter 1.0 via Installer.app

    2) Launched BootNeuter and changed "Neuter" to "On" and Bootloader to "4.6" -- required a phone reboot (make sure you turn OFF autolock!).

    3) Updated iTunes to 7.7

    4) Downloaded the custom 2.0 firmware image located here: http://www.iphone-releases.com/iPhon...ases.com).ipsw (Look for "iPhone 2.0 pwnage on windows" thread, it has a direct download to the firmware, not a torrent)

    5) Used Ziphone 3.0 to put the iPhone into DFU mode

    6)
    Opened iTunes and held "Shift" key while clicking the restore button, then selected the 2.0 firmware image.

    It took about 10-15 minutes but everything went well without error. On the first reboot BootNeuter 2.0 ran at startup and unlocked the phone. After that I used Cydia to install OpenSSH and the Tmobile Tzones Hack.

    I didn't see any errors during any of this... Everything in 2.0 appears to be working fine.
    Last edited by mooselander; 2008-07-22 at 07:27 PM.

  2. The Following 2 Users Say Thank You to mooselander For This Useful Post:

    imvyme82 (2008-07-27), Rakeshpatel (2008-07-22)

  3. #2
    Works for me as well. Here's what I did differently.

    1. Did not install BootNeuter.
    2. Used ziphone 2.6 and put it on RECOVER instead of DFU

    I believe BootNeuter is not needed because this particular custom ispw contains BootNeuter. Once iTunes was complete with its thing, BootNeuter automatically fired up and did its thing.

    I told iTunes to do a restore and after which Mail doesn't work. But I've encountered this before in the past. Just do the following if you have the same problems.

    1. ssh to iPhone
    2. chown -R mobile:mobile /private/var/mobile

    Mail app should work after that.

    Yahoo push mail is still not working though.. It has never worked since day 1 for me. Have tried all the remedies out there (google it) but none of them worked.

    When I tested it (sending from GMail to Yahoo Mail and vice versa from desktop), I could hear a chime after a few seconds, but the Mail icon on the springboard is still not showing anything After a few minutes it shows as there's mail, but it was for the GMail account.

    So, sad to say initial test is showing Yahoo push mail is not working.

    Before I forget, I tried 2 other ipsw files and they did not work. iTunes error out with 1403 unknown error. This one worked.
    Last edited by hamproof; 2008-07-22 at 05:14 AM.

  4. The Following User Says Thank You to hamproof For This Useful Post:

    imvyme82 (2008-07-27)

  5. #3
    Quote Originally Posted by hamproof View Post
    Works for me as well. Here's what I did differently.

    1. Did not install BootNeuter.
    2. Used ziphone 2.6 and put it on RECOVER instead of DFU

    I believe BootNeuter is not needed because this particular custom ispw contains BootNeuter. Once iTunes was complete with its thing, BootNeuter automatically fired up and did its thing.
    .
    Right, thanks for confirming this. I was wondering if it was necessary to BootNeuter beforehand, especially after I saw that this image runs BootNeuter 2.0 on the first reboot. I ran across much complaining about Ziphone and it's bootloader downgrade and how that might/could/would be a problem. This is why I "prepped" it with BootNeuter 1.0 beforehand, although now I don't believe that step is necessary either.

    Out of curiosity, did BootNeuter 2.0 leave your bootloader at 3.9 or did it auto upgrade it to 4.6?
    Last edited by mooselander; 2008-07-22 at 06:25 PM.

  6. The Following User Says Thank You to mooselander For This Useful Post:

    imvyme82 (2008-07-27)

  7. #4
    Hmmm, your explanations are quite detailed and they keep on tempting me to try one of them. However, and since I'm a bit of a newbie, I'd rather wait some more time till more automated programs unlock firmware 2.0.

  8. The Following User Says Thank You to lente For This Useful Post:

    imvyme82 (2008-07-27)

  9. #5
    Not sure what's the BL is now. On 1.1.4 I was using Installer and had "bbinfo" installed which would tell me. But now with 2.0, I am running Cydia and I don't see the package there.

    Checking General on iPhone I see it as 04.05.04_G but that's the baseband. I believe you are asking about the bootloader. Where can I see that w/o installing 3rd party app?
    Last edited by hamproof; 2008-07-22 at 03:11 PM.

  10. The Following User Says Thank You to hamproof For This Useful Post:

    imvyme82 (2008-07-27)

  11. #6
    You can add Bootneuter 1.0 to installer app by adding iappcat.com/r/4717 to installer, and go to kaseptea repo

  12. The Following User Says Thank You to dbest1i For This Useful Post:

    imvyme82 (2008-07-27)

  13. #7
    Thumbs up Success Upgrade to v2.0
    Thanks to the Dve Team for developing the v2.0 programs. Tried, install and now the iphone is up & running. Wonderful guys and many thanks.

  14. The Following User Says Thank You to sylphy1.5 For This Useful Post:

    imvyme82 (2008-07-27)

  15. #8
    Quote Originally Posted by hamproof View Post
    Not sure what's the BL is now. On 1.1.4 I was using Installer and had "bbinfo" installed which would tell me. But now with 2.0, I am running Cydia and I don't see the package there.

    Checking General on iPhone I see it as 04.05.04_G but that's the baseband. I believe you are asking about the bootloader. Where can I see that w/o installing 3rd party app?
    Hmm... I'm not sure how you'd check the bootloader after the upgrade. Bootneuter 2.0 is removed after it flashes and obviously 1.0 can't be installed (through Installer.app) anymore.

    Bootneuter would have informed you as to what it was doing while it flashed, but after the fact it'll take a 3rd party app (to my knowledge one hasn't been ported yet).

    I was just curious if 2.0 required the 4.6 bootloader, not a big deal.

    Quote Originally Posted by lente View Post
    Hmmm, your explanations are quite detailed and they keep on tempting me to try one of them. However, and since I'm a bit of a newbie, I'd rather wait some more time till more automated programs unlock firmware 2.0.
    It ended up being a straightforward and hassle free method to upgrade my phone. If you're apprehensive about doing so it's probably smart to wait, you don't want to get yourself into a bad position; one where you're attempting a weird combination of things to unbrick your phone.

    I'm certainly not saying that this is the best way to upgrade. It just happened to work fine for me, without a hitch or any of the bizarre error messages I've read about.

    On a side note: I used Amarok (a Linux music library app, which worked beautifully on 1.1.4) after the 2.0 upgrade to sync some music over wirelessly (I despise iTunes). It completely corrupted at least the iPhone music database and I had to restore the phone again (using the same method) -- the restore worked perfectly the second time as well...

    Lesson learned... don't touch Amarok until the Linux devs realize there's an issue, probably by corrupting a few 2.0 phones themselves
    Last edited by mooselander; 2008-07-22 at 06:41 PM. Reason: Automerged Doublepost

  16. The Following User Says Thank You to mooselander For This Useful Post:

    imvyme82 (2008-07-27)

  17. #9
    ok got it working but youtube won't work on edge, but works on wifi..

  18. The Following User Says Thank You to dbest1i For This Useful Post:

    imvyme82 (2008-07-27)

  19. #10
    works great!!!! thanks

  20. The Following User Says Thank You to gbarielmoreno For This Useful Post:

    imvyme82 (2008-07-27)

  21. #11
    What's Jailbreak?
    Join Date
    Jul 2008
    Location
    philadelphia pa
    Posts
    10
    Thanks
    47
    Thanked 0 Times in 0 Posts

    is it alot of apps in cydia for 2.0

  22. #12
    is anyone else able to get there youtube to work over edge, mine works over wifi but not edge

  23. The Following User Says Thank You to dbest1i For This Useful Post:

    imvyme82 (2008-07-27)

  24. #13
    Same here...I hope someone knows how to fix this without having to downgrade then upgrade again cause thats the biggest hassle..
    If you can't do it on one wheel, try harder!

  25. The Following User Says Thank You to kurrupt_1 For This Useful Post:

    imvyme82 (2008-07-27)

  26. #14
    dont just say "It took about 10-15 minutes but everything went well without error. On the first reboot BootNeuter 2.0 ran at startup and unlocked the phone. After that I used Cydia to install OpenSSH and the Tmobile Tzones Hack.
    I didn't see any errors during any of this... Everything in 2.0 appears to be working fine."

    can you tell more in detail because I have already done Bootneuter 4.6 and i dunno what to do now.. lol

    explain me the CYDIA part in detail pelase

  27. The Following User Says Thank You to sameer1977 For This Useful Post:

    imvyme82 (2008-07-27)

  28. #15
    Quote Originally Posted by sameer1977 View Post
    can you tell more in detail because I have already done Bootneuter 4.6 and i dunno what to do now.. lol

    explain me the CYDIA part in detail pelase
    Cydia is used after 2.0 has been jailbroken to install third party apps on your phone, it has nothing to do with the jailbreak/unlock process and is embedded in the linked custom firmware above.

    What you chose to install after you've jailbroken is up to you.

    You may find details about Cydia by searching this site or using Google. I would strongly suggest not proceeding further until you have a general understanding of what these apps are and what they will do to your phone when executed.

    Good luck.
    Last edited by mooselander; 2008-07-25 at 07:34 PM.

  29. The Following User Says Thank You to mooselander For This Useful Post:

    imvyme82 (2008-07-27)

  30. #16
    opps.. i already installed CYDIA in my thing and start using it.. lol i am screwed i think

  31. #17
    Green Apple
    Join Date
    Dec 2007
    Location
    Jarrow, UK
    Posts
    73
    Thanks
    9
    Thanked 2 Times in 2 Posts

    i've tried this method and others but always get the same problem. Once in DFU mode and then try to restore with custom ipsw I get a 1016 fault code from iTunes.anybody got any ideas?

  32. #18
    Default No probs here
    I was very aprehensive to upgrade from 1.14 to 2.0 but finally did it yesterday using pawage - easy in the end!!!!!

    No regrets here!!!!!!!!!!!!!!!!



    Thanks Guys for the support

  33. #19
    I have 1.1.3 unlocked w/t-mobile.I used Ziphone gui v2.5c. What do i need to do to upgrade from 1.1.3 to 2.0? Are most of the 3rd party apps working on 2.0? I use customize 2.0,USirius,Swirly MMS,Maps,You Tube, etc.. almost every day so i dont want to lose anything and dont know all of the benefits of having 2.0 over what i have. Pls chime in! Thank You.

  34. #20
    Default Upgrade from 1.1.4 to 2.0
    Guys i had upgraded up iphone frm 1.1.2 to 1.1.4 using ziphone...
    so u guys tel me how do i upgrade my phone to 2.0 using ziphone?

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •