Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Winterboard causes phone to get stuck in endless reboot

  1. #1
    Default Winterboard causes phone to get stuck in endless reboot
    Hello,

    Recently jailbroke my iphone 3g with 2.0.1. I installed the modified image, updated all requested things from Cydia. Then did a search for winterboard and installed it. I have a button saying "restart springboard" which I tap and it remains there loading endlessly. A reboot causes the phone to get stuck at the apple. I have repeated this twice. Any suggestions?

    Thanks!

  2. #2
    No it doesnt, you just hard reboot when it was in the spinning wheel, You need to wait

  3. #3
    I waited 10 minutes, could it potentially take longer than that?

  4. #4
    zaius55,

    Have you discovered a workaround for the reboot issue? My phone is exhibiting the same behavior. It was working fine until I attempted to install Winterboard; now it's showing the boot logo for about 10 minutes and then rebooting itself endlessly. I used QuickPwn last night to jailbreak; did you use the same tool? I'm hoping I can reload the jailbreak to reset springboard.

  5. #5
    Well I have been able to get a stable jailbroken 3g 2.0.1 phone with winterboard, here is what I ended up doing...

    1.) Rebuilt my custom image with winpwn NOT including installer app.

    2.) Installed sshd before I installed winterboard (Not sure if this is a dependency, can't see why, but it helped).

    3.) Did not RESTORE from backup all my programs, but reinstalled them on the phone, essentially creating a new phone in itunes.

    Only to find 2.0.1 lacks some critical features (apparently) in the non-jailbroken 2.0.2

    Let me know if you have questions.

  6. #6
    Thanks for the info. How did you restore the iPhone back to a state where it's not constantly rebooting? I can't even get the phone to move past the Pineapple logo right now; I'm going to try to redo the QuickPwn to see if that will fix it, otherwise attempt an iTunes restore if I can get that far. Did you need to boot into the iPhone safe mode first before following the steps above?

    Thanks.

  7. #7
    I connected to itunes and got into DFU mode. It then will prompt to restore to defaults (it will fetch an unmodified image I believe if none exists). Where I got stuck before is to understand the difference between DFU mode and restore mode, they are NOT the same. DFU mode will present you with a black screen, while restore will show some icons.

    Keeping in mind it may restore you to 2.0.2 with this method, which may not be jailbreakable? I'm unclear on this, there might be another way to get the stock image back. You could winpwn itunes, and then use itunes to restore the stock 2.0.1 image I believe.
    Last edited by zaius55; 2008-08-20 at 01:04 AM. Reason: Automerged Doublepost

  8. #8
    Thanks for following up. Running QuickPwn a second time didn't make a difference, so I wiped my iPhone and updated to 2.0.2 through iTunes. Thankfully I had backed up my phone earlier that day, so almost all of my stuff is back on the phone. The only weird thing is that iTunes uninstalled several apps, such as Palringo, even though they had been installed when the backup was created. I'm happy I have a working phone again; I'll wait for QuickPwn to support 2.0.2 before I try again.

    Thanks for all of your help. I really appreciate it.

  9. #9
    No problem. There is a quickpwn beta that I used last night and so far so problems.

    My experiences with this.

    Use the quickpwn beta on a FRESH 2.0.2 phone (I didn't even sync it, I just set it up as a new phone). All the apps and data were still restored properly.

    One BIG thing I found in terms of stability that I can't believe I didn't find earlier was turning off autolock and autobrightness. That seemed to have an unbelievable effect on stability and I haven't had a lockup since (battery life is of course impacted, but hopefully this will get fixed).

    Go get em!

  10. #10
    this happened to me when I installed summerboard in mi 1st gen 1.1.4fw iPhone
    I found several tips online, even youtube videos but nothing worked.
    I ended up restoring.
    http://i26.tinypic.com/68hhyh.jpg

  11. #11
    iPhone? More like MyPhone Bigperm26's Avatar
    Join Date
    Jul 2008
    Location
    Chicago, IL
    Posts
    176
    Thanks
    27
    Thanked 13 Times in 13 Posts

    Winterboard themes were giving me the endless reboot problem as well with a 2.0.2 firmware! I winpwned with 2.5 and went to Cydia to dl some things. I had to restore 5 times last week!! Got up again (this time I "wiped the data in winpwn, not sure if it helped), but I'm afraid to dl too much through Cydia.

    Always when it says restart springboard, I know I'm in for it! Waited 20 minutes and nothing! What a pain!

  12. #12
    Lightbulb Here's what I did
    I jail-broke my 3GS using GeoHot's Blackra1n a few weeks ago and installed Winterboard without a hitch. But some unrelated software issues required me to restore my iPhone using iTunes yesterday. No problem. I restored, and used Blackra1n to jail-break it again. But this time, when I tried reinstalling Winterboard my iPhone hung up on the boot screen. Nothing I did seemed to work so I restored it again, jailbroke it again, reinstalled Winterboard. Nada.

    I was pretty sure Apple hadn't somehow figured out how to spike my iPhone so it couldn't use themes, so I back-tracked and decided to replicate everything I did the first time and see if I was doing something to cause Winterboard to screw the pooch.

    As they say, third time's the charm. The only thing I did differently the first time was I installed MobileTerminal and OpenSSH before I installed Winterboard because I wanted to change the default password ASAP. Following those steps (and changing the password in the process) I was able to successfully install Winterboard after I'd installed the two other packages. Reading through this thread I discovered Zaius55 had to do something similar with his 3G. Don't ask me why it works, but it works.

    When Jail-broke iPhone's are outlawed only outlaws will have Jail-broke iPhones.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •