Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: Itunes freezes when I connect Iphone, please help

  1. #1
    Default Itunes freezes when I connect Iphone, please help
    Every time I connect my Iphone Itune's freezes and I have to use ctrl, alt, delete to end it. This makes it not possible to load any music onto my Iphone. My Iphone is running firmware 1.02 which I have loaded Ibrickr on and have unlocked. I unlocked it to work with at&t (i know stupid) So i didn't have to pay for a data plan I didn't need at all. Ive tried everything I have reinstalled it. Cleaned my registry, I even did a system restore 2 weeks back before Itunes started giving me problems. Nothing worked. When I put the Iphone in restore mode it Itune's doesn't freeze, but thats useless. Any advice is appreciated. Thanks.

  2. #2
    Retired Moderator jedinight's Avatar
    Join Date
    Jul 2007
    c.s. texas
    Thanked 113 Times in 89 Posts

    have you tried running apple sofware update .and update newest itunes,,just dont sync ringtones,and no 1.1.1

  3. #3
    iPhoneaholic ReVan's Avatar
    Join Date
    Oct 2007
    Thanked 526 Times in 109 Posts

    # Uninstall iTunes
    # Swap the data cable into a empty USB port ( do not plug your iPhone in)
    # Reboot
    # Install iTunes 1st and run iTunes
    # Plug-in your iPhone to the data cable.

    P.S. To clean the WinXP Reg I reckon you use Registry Mechanic 7 (do this if you like, after uninstall iTunes and then reboot your PC)

    Hope this help!

  4. #4
    thanks il try that.

    Unfortunatly that didn't work, any other ideas?
    Last edited by mikesfacts2; 2007-10-10 at 08:32 AM. Reason: Automerged Doublepost

  5. #5
    you can uninstall and itunes you have and remove any stuff from registry (regedit) and then install a older version, say 7.3.2, then connec iphone

  6. #6
    Actually, I'm having the exact same problem. It's very frustrating.

  7. #7
    haha you guys try to disable your firewall yet? like Zonealarm maybe? trust me i'm 99% sure that it'll take care of your problem. GL

  8. #8
    I have had a similar problem and one thing you should check which resolved the problem for me was I found that Logitech has an application called "SetPoint" (installed if you use Logitech Mouse/Keyboard) which if running seems to conflict with iTunes in some way and freezes my iTunes when I plug in my iPhone, when I shut the "SetPoint" application down in the system tool bar and then restart iTunes and plug in my iPhone everything works fine. Hope this helps others

  9. #9
    Angry mine freezes too
    please someone help. this sucks ***. i want to sync my songs, especially my calendars.

  10. #10
    ...moved to the {Ctrl}+{Alt}+{Del} forum....

  11. #11
    Quote Originally Posted by anonamer View Post
    haha you guys try to disable your firewall yet? like Zonealarm maybe? trust me i'm 99% sure that it'll take care of your problem. GL
    it doesnt have anything to do with my firewall, im suree of that...

  12. #12
    I'm having the same problem and I have tried all the above methods. It did it on the older itunes then I thought maybe going to 8.x what fix it, nothing. Jailbroken or not jailbroken, it still does it.

    well i hope this helps out, but here are some things i did and after completing itunes worked fine:

    added the mipatch replacement for 3.0 (it goes by another name but replaces mipatch for 3.0 fw)

    reset sync history

    deleted all but one backup

    btw all this was done with the iphone unplugged
    Last edited by brahby; 2009-06-21 at 07:10 PM. Reason: Automerged Doublepost

  13. #13
    i had sam problem too man. i got around it by uninstalling itunes turning my computer all the way off and on. the reinstall itunes and it worked for me. let me know if that helps

    also try moving your usb to the first usb slot when i had it on the right side of my laptop usb it wouldnt work tried three times but i moved to to the left side front and wahlah it worked
    Last edited by Mikemax; 2009-06-24 at 05:03 AM. Reason: Automerged Doublepost

  14. #14
    Default Same here
    I tried all sorts of things; uninstalled and re-installed itunes, removed all backups, removed podcasts, .. nothing helps. This is my first and last buy from Apple - stay away from these junk makers!

    - rib

  15. #15
    I've admittedly had this issue myself, but just unplugging my network cable, doing what I need to do via iTunes and then plugging it back in works as a temporary solution.

    Eh, my PC's overdue for a format anyway. I'd be kidding myself if I reckon I can hold off until W7 retail.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts