Results 1 to 14 of 14

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: HELP - Camera Stopped Working After modding

  1. #1
    Default HELP - Camera Stopped Working After modding *UPDATED!
    someone help me wth this one.

    just noticed that my camera on the iphone does not work anymore. i dont use it often, so i just noticed. i have done lots of software modding as well as changing the backcover to all black. i know i have not damaged the camera itself though, since its on the main assembly on the phone, which i didnt even touch when i changed the backcover.

    if i click camera, the black background umbrella comes up normally, but when it dissapears, its all black. no image. the folder button on the bottom left corner is active, pressing it takes me to camera roll images. However, the "take image" buttom on the bottom center is dead, cannot click it. if i tilt the phone, it changes position normally, but it does not respond to touch. shouldnt it turn blue when you click it, dont remember.....

    im starting to think i have accidently deleted some png file in the camera folder or something, but what?? ohh yeah, if i go to camera roll, the "take image" in the bottom center is as dead as it was in camera mode.

    im thinking file missing, or permission invalid, help???
    (once i accidently deleted info.png, in the weather.app folder. i misstook it for icon.png that i was going to change, what happend was that the I, as in add locations dissapeard weirdly, took me forever to figure out what it was)
    Last edited by bonefish; 2007-09-12 at 02:45 AM.

  2. #2
    My iPhone is a Part of Me lifesmymachine's Avatar
    Join Date
    Aug 2007
    Location
    Los Angeles
    Posts
    529
    Thanks
    3
    Thanked 51 Times in 41 Posts

    try re-adding the entire MobileSlideShow.app folder and winscp ing or chmodding the permissions as you would with a new program

    you can find the original here: http://www.modmyi.com/forums/downloa...do=file&id=105

    if that doesn't work, you may have to restore

    hopefully its just a software thing and nothing happened when you modded the back case

  3. #3
    thanks, i was looking for those stock files actually. howver, didnt work. replced them all and still the same problem. also tried to restore the phone, that doestn work either. just opened up my phone again and had a look inside, the camera is almost hidden on the main board of the phone. its far away from any area that i worked on while modding the cover. i cant have damaged it.
    Last edited by bonefish; 2007-09-04 at 04:43 AM.

  4. #4
    My iPhone is a Part of Me lifesmymachine's Avatar
    Join Date
    Aug 2007
    Location
    Los Angeles
    Posts
    529
    Thanks
    3
    Thanked 51 Times in 41 Posts

    A restore didn't help??

    I havn't opened up my phone myself, but I have heard about people damaging them (mainly in the unlock process.. which I don't think you did). Did you use those anti-static wrist things? It's a good idea to not mix static electricity and sensitive computer parts. Perhaps a trip back to the apple store is your best bet. Even though opening it up voids your warranty, they may be able to help you out.

    And you are completely sure you didn't cover up the camera lens or paint it or anything right?

    Good luck man! I don't have any other guesses.

  5. #5
    yeah, a restore didnt help.

    but i have not even touched that part where the camera is, and even if i did, the camera is solid, no loose parts at all there. here is what i am thinking, if i painted on it, the pictures would come out black. but i am not able to take any images at all.its more like the button is locked or something
    Last edited by bonefish; 2007-09-04 at 09:40 AM.

  6. #6
    Retired Moderator
    Join Date
    Jul 2007
    Location
    City of Brotherly Love
    Posts
    1,834
    Thanks
    104
    Thanked 321 Times in 176 Posts

    That is a strange one, you might have to call up apple on it. Silly question but was it dropped at all?

  7. #7
    My iPhone is a Part of Me lifesmymachine's Avatar
    Join Date
    Aug 2007
    Location
    Los Angeles
    Posts
    529
    Thanks
    3
    Thanked 51 Times in 41 Posts

    Let us know if you figure it out and what apple says
    "The glory is not in never falling, but in rising every time you fall."

  8. #8
    called apple and they said it has happened before, something about the lens assembly. Just sent it in for service, hopefully they dont say anything about hte black back cover that i have. ill update this thread as soon as i have got the phone back, might be interesting for other people about warranty issues after back replacement.

  9. #9
    DO NOT, I REPEAT, DO NOT return the iPhone to Apple with the black back. They will send it to you untouched and void your warranty for violation of the hardware agreement you agreed to when you activated it. I don't mean to be a jerk, but if you can replace the backing to the silver one, you should definitely do so.....

    Thanks,
    Sniper70

  10. #10
    Quote Originally Posted by sniper1970 View Post
    DO NOT, I REPEAT, DO NOT return the iPhone to Apple with the black back. They will send it to you untouched and void your warranty for violation of the hardware agreement you agreed to when you activated it. I don't mean to be a jerk, but if you can replace the backing to the silver one, you should definitely do so.....

    Thanks,
    Sniper70
    ... seriously

  11. #11
    @Sniper1970,

    when you sent in your iphone for repair with the black back, what did they tell you when it came back. Didnt they repair it at all for you?? i know that the warranty might be void, but atleast they could have repaired ir for you for a charge.

    hope they treat me better

    UPDATE:
    just heard from apple they are indeed sending it back without beeing repaired. Guess they didnt like that black case as much as i did. Guess i cant have that camera fixed, its not the whole world, i have a EOS 5D that takes better images that the iphone anyways.

    Anyone with some other idea why my camera does not work? it behaves exactly like the app is not chmodded 0755 properly. had my weather.app behave like that also before. just opened up weather.app then lock, then back to main screen. changed CHmod to 0755 and weahter.app worked. camera is acting the same way, but chmodding it does not help, neitehr does restore

    any suggestions?

    just ordered a new camera from ifixit.com, found it used for $50 bucks. not that bad. I can send it back to them for a refund if it still does not work, but i have a few days now to figure out if it might be software related.

    any thought?

    Also, is there a way to do a factory reset on the iphone? restore certinly restores, but some files are kept, including perhaps the fiules that i need replaced.
    Last edited by bonefish; 2007-09-12 at 08:57 PM. Reason: Automerged Doublepost

  12. #12
    can u update plzz dude cause i have the same prob

  13. #13
    Default don't tell them its moddrd
    I have the same problem and I have a recently unlocked iPhone for tmobile but I'm still paying for AT&T and as soon as I accidentally gave my tmobile number and they said any software mods automatically void all warranties so I'm basically screwed. The tech couldn't tell me anything. Hoping to find a way to fix it so i dont have to carry a camera around for evryday pictures

  14. #14
    I found this thread on IphoneAtlas.com

    -you can ssh into your iPhone and issue a command.
    -Navigate to var/mobile/Media and issue this command.
    -chown -R mobile DCIM
    -
    -No need for restoring or backups or anything.

    I was very wary about restoring my iphone cause i didn't want to lose all my apps. I found this though and tried it before restoring or resetting anything. it worked Great.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •