Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: WinSCP problems. Need help.

  1. #1
    iPhone? More like MyPhone
    Join Date
    Nov 2007
    In the clouds.
    Thanked 16 Times in 11 Posts

    Default WinSCP problems. Need help.
    Hi guys, I'm wondering if anyone with a bit of experience here might be able to help me I'm having a problem connecting to my iPhone and I have narrowed the problem down to the phone and my router.

    To start, I have had SSH working perfectly on my iPhone on another wireless network other than my own, slight problems at first but soon got them sorted.

    Right now the problem I am having is this:

    My router is a Belkin Wireless G+ MIMO router, I can connect my iPhone to it and use safari/installer/email just perfect, no problems.

    However, if I try to connect to the iPhone with WinSCP it does not work.

    I have tried pinging the iPhones IP from other computers on my network and I get no response at all.

    If I ping the routers IP from the phone I get responses, if I ping any other computer on my network from the phone I get responses, but if I ping the phone, nothing.

    I have tried both static and dynamic IP addresses. Tried some different settings on my router, disabling NAT, tried changing firewall settings on the computers running WinSCP, nothing seems to work. SO I have figured that under these network conditions, the phone for some reason is not responding to pinging or incoming connections.

    Can anybody make any suggestions on further tests/possible solutions?

    Unfortunately I'm running Vista x64 so SCP is the only way possible for me to manage modifying the filesystem, iPhone browser doesn't work, iPhoneList doesnt work so this is my only option. Thanks.

    P.S. Vista is not the problem here .... for once..I borrowed an XP laptop that worked on the other network and that didn't work here either.

  2. #2
    This might be off topic, but I have tried a lot of the same things to fix my Belkin router for the Xbox 360.
    I couldn't connect to a lot of peoples games and a friend told me to try some of the things you said, and I did.. but they didn't fix it at all.

    I have the Belkin N router.. so maybe it has something to do with belkins router?

    On the other hand.. I have never tried using WinSCP.. sorry.
    Proud MMi Retired Moderator.

  3. #3
    i have a belkin g router and also had this problem with many other programs and i tried just turning off the security on the router and it worked from there. try that and see what happens

  4. #4
    Green Apple Nehal3m's Avatar
    Join Date
    Feb 2010
    Thanked 3 Times in 3 Posts

    Do you have afc2add? You'll need that to SSH.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts