Results 1 to 17 of 17

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Latest iPhoneBrowser and 2.0???

  1. #1
    Default Latest iPhoneBrowser and 2.0???
    Ok I've been hearing mixed things of iPhoneBrowser, I know it IS an alternative to SSHing into your iPod Touch/iPhone, and I'm just wondering, does it work with 2.0 software or does there have to be a certain aspect of an iPod/iPhone that is only available when jailbroken in which iPhoneBrowser will work???

    If anyone can TEST or give me an answer, that'd be sick! Thanks!

    -PolishDemon

  2. #2
    iPhoneBrowser depends on the afc2 service being created on your phone for global access to the filesystem. Also, only a jailbroken phone has the system partition modified so you can change files.

    So, without jailbreak, most operations with iPhoneBrowser will not work.

    With a stock iPhone <2.0, you can basically access camera photos, and the various database/files for the built-in applications.

    I have not yet upgraded to 2.0 to test iPhoneBrowser.
    Starlight Computer Wizardry
    Pocket-sized Development
    Follow me on twitter: @NetMage

  3. #3
    Hey, thanks for the reply!!! I'm just about to go pickup my iphone 3G in a couple of hours, when my mommy gets home, yes that's right, mommy, and then will add on some stuff, waiting for a jailbreak tho!

  4. #4
    If you get a chance, try running iPhoneBrowser 1.60 and see what if it works and what it can see.

    You can download it from the test thread in the OS Apps forum here
    Starlight Computer Wizardry
    Pocket-sized Development
    Follow me on twitter: @NetMage

  5. #5
    Default iPhoneBrowser
    Been lurking around for awhile and decided to finally join this great community ... But enough of that, on to what I am really here to discuss:

    I downloaded iPhoneBrowser 1.60 and ran the .exe. It almost immediately recongnized my 16GB iPhone 3G without any issues. That is until you try to explore and you get this error:



    I'm sure it has to do with the fact that iPhoneBrowser has not been ported for 2.0, but if anyone has any ideas, that'd be great.

  6. #6
    I believe the error is because you are running Vista. I don't have a Vista system to test on, so I can't debug too well.

    I think it is because Vista has changed some of the Windows common directories that I am attempting to use.
    Starlight Computer Wizardry
    Pocket-sized Development
    Follow me on twitter: @NetMage

  7. #7
    What's Jailbreak?
    Join Date
    Feb 2008
    Posts
    19
    Thanks
    7
    Thanked 2 Times in 1 Post
    I'm using iPhoneBrowser 1.6.0.0 with Vistas with no problems generally - occasionally after periods of no activity it will display that error message, but it is usually after 5 minutes or so of doing nothing... Could be the phone going into sleep?

  8. #8

  9. #9
    iphone pc suite uses the same principles as iphonebrowser so i couldn't imagine it bricking your ipod if iphonebrowser worked ill test it on my iphone but i can confirm iphonebrowser works shows all files and allows for read/write access.

    couldnt install whatever it wants me to install got a failed to install whatever then the program closes not sure but on the phoen in the background it says 2.0 at the top as if it detected what firmware i was on so i would think they've added support for 2.0 as i got no error 2.0 not supported messages
    Last edited by robbpell; 2008-07-27 at 08:44 PM.

  10. #10
    Green Apple MCN's Avatar
    Join Date
    Jul 2008
    Location
    Honolulu, Hawaii
    Posts
    47
    Thanks
    7
    Thanked 3 Times in 3 Posts

    I am using a Pwned 2.0 on 1st gen Iphone and when I use IphoneBrowser6 it recognizes the phone as jail broken. But when I try to explore the folders it gives me this.....




    I click continue anyway it tries to load the folder then says it can't...
    Attached Thumbnails Attached Thumbnails -browser-error.jpg  

  11. #11
    I used 1.5.2 to access my iPhone (1st gen, 2.0, jailbroken) and was able to copy files, etc (I actually wanted to update my icons from the Aqwoh summerboard theme). I was able to update some of the icons, exited, tested to make sure it worked, etc. All was fine. But then I updated the Cydia stuff, installed BossPrefs, and NOW it works, but won't see the Application Directory off of the root. Is this to be expected? What did I mess up?

  12. #12
    Hmmm - I've seen some other reports of this.

    It seems like the new Cydia is creating some type of symlink for /Applications that is breaking the afc2 service.

    I'll have to test when I upgrade someday...
    Starlight Computer Wizardry
    Pocket-sized Development
    Follow me on twitter: @NetMage

  13. #13
    check it var/mobile/apps
    the last folder apps_ may be named something different as there is already an application folder so just check the folders in mobile for the calculator.app calender.app etc.

  14. #14
    I'm almost positive it is only a problem with iPhoneBrowser not recognizing the @ symbol in the name of the applications folder (I noticed it was named like this when browsing on my iphone using icommander, but icommander can only browse and change permissions).
    I'm able to add roms, delete files, view images, etc.; basically anything except access those 2 or 3 folders with the @ sign in their name. Does anyone know an application that doesn't have this error?

  15. #15
    The directories do not have an @ sign in their name. icommander is marking them to indicate to the user that they are not actual directories, but rather symlinks to directories.

    Unfortunately the inability to follow a symlink transparently appears to be a change Apple made to the afc service in version 2.0.
    Starlight Computer Wizardry
    Pocket-sized Development
    Follow me on twitter: @NetMage

  16. #16
    Exclamation Found the directory
    My iPod Touch is jailbroken in 2.0.2 with QuickPwn and I too couldn't see the Applications folder.
    I searched and it's actually located at:
    /private/var/stash/Applications.NjblRE
    I'm not sure but it seems like the .NjblRE could change from unit to unit. But the directory structure should be the same.
    Btw I'm using iPhoneBrowser 1.7.0.0 (it's beta).
    All the .app folders are there.
    I just copied a couple programs there, restarted the iPod and there they are. working just fine.

    Peace!

  17. #17
    Yeah, the new version of Cydia is moving /Applications when it is first started.

    Not sure how I feel about that... especially since it uses a soft link.

    Anyway, I am working on a version of iPhoneBrowser that handles this.
    Starlight Computer Wizardry
    Pocket-sized Development
    Follow me on twitter: @NetMage

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •