Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: WinSCP "No Space Left On Device"...

  1. #1
    Default WinSCP "No Space Left On Device"...
    All of a sudden, in WinSCP, I'm getting a "No Space Left On Device" error whenever I try to copy any file to my iPhone, in any directory. It's worked great up to this point.

    Also, my seems to be screwed as well. If I try to install something (anything), it gets almost to the end then goes black, then quits to the springboard. I reinstalled and downgraded to an earier version, and now with every install it fails and says, "Error during install script execution!"

    Is there something specific that I might have installed that would have hosed these things...?



  2. #2
    well it seems to me like all of these could be linked back to the lack of space. What you didnt mention, although I could assume is that you DO have space, but its just saying you dont? Sync it back to itunes and check if you are truely out of space. If you are not, then try deleting something and putting it back. If that fails, then its probably something more. If a restore doesnt work, not sure what else can help you besides looking through the file structure and seeing if there is anything abnormal.

  3. #3
    after creating the symbolic link using erica's utilities
    I still got the no space error:
    Linking ~/Applications to Widgets
    ln: creating symbolic link `/Widgets': No space left on device
    I user in the comments suggested moving apollo. I just uninsatlled it and ran the system link using erica's utilities and it worked.

    then I tried reinstalling apollo and I get the same error. any ideas why?

  4. #4
    i've getting a error like yours then i trying copy * .m4r files to library/ringtones (there are standart ringtones too)
    i think the summary size of all files in that dir can be maximum 12503 kbytes
    anybody have something like this?
    ps: fw is 111, jailbroken using CARNAVAL (by brasuco), unlocked w/anysim1.1

  5. #5
    I think i read somewhere that the max space available for apps is 300mb. Im not sure if this is true.

  6. #6
    same here, quits when installing anything and winSCP - no space on device. I have 1gb free on the phone.

    what apps do you have installed?? or have tried to install? this started happening to me when i tried to install cameraPro. it quit during install and since then its been doing this.

    I only have 28 megs worth of apps installed
    Last edited by tanakiye; 2007-12-31 at 10:01 PM. Reason: Automerged Doublepost

  7. #7
    yeh I have the same error with the space
    thing. It says delete some files ur amost out of space...yet I have 6 gigs left ><; anyone know why this is??

  8. #8
    I have a iPod Touch and hit this same issue. After installing a bunch of stuff I had a 100% full /dev/disk0s1 partition.

    I found the simplest way to solve this for me was to simple move the /Applications folder to a spot on the second partition that has tons of free space.

    This is what I did.

    cd /
    mkdir /private/var/Applications (this is where I want stuff to end up)
    cp -Rf /Applications/* /private/var/Applications/ (make a copy of everything in the Applications folder)
    mv /Applications /Applications.old (get the /Applications dir out of the way)
    ln -s /private/var/Applications /Applications (Make a static link to the new Applications directory location from / )

    after verifying this worked I removed the /Applications.old folder.

    ls -la /Applications
    lrwxr-xr-x 1 root admin 24 Jan 11 20:08 /Applications -> private/var/Applications

    df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/disk0s1 300M 259M 39M 88% /
    devfs 15K 15K 0 100% /dev
    /dev/disk0s2 15G 110M 15G 1% /private/var

    Hope this helps... I now can install as many apps as I want and not have to worry much about running out of space.


  9. The Following User Says Thank You to Tibsfox For This Useful Post:

    iPhoneClub (2008-07-25)

  10. #9
    This sure has become a wide spread problem. Anyone moving your apps folder remember you must also check your fstab for noexec. If you can free up about 6mb of space, you can install bosstool and it will help you move apps, ringtones, and wallpaper.
    Please do not send me messages here as I never check them. If you need to contact me, send me an email. My contact info is easy to find from inside Cydia.

  11. #10
    Tibsfox, thanks a lot for that information mate!! Now I managed to upload the Space Monkey game over without these stupid limitations. I think PWNAGE TOOL 2.0 allows to set more then 500 mb to the partition, I just didn't know what this was at the time =)

    Over 10,000 iPhone and iPod Touch Wallpapers
    Over 350 iPhone and iPod Touch Themes
    iPhone and iPod Touch news from all around the world.

  12. #11
    Join Date
    May 2008
    Dewsbury, UK
    Thanked 16 Times in 12 Posts

    Yep, this is going to be great for me especially, I am a Application mad person Lol.

    "Everybody has common sense, but most just don't use it, then you wonder why?" - Neo-Tech

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts