Hear my story please,

I installed ants on my unlocked (working fine) 1.0.2 but after installing so many ants appeared that my iphone had a froze swirl cycle. I restored it but was forced to upgrade to 1.1.1 (i didn;t know better but i heard 1.1.1 is jailbroken and unlockable). So i restore to 1.1.1. After using uber's guide to jailbreaking which worked, i tried to use the anysim 1.1.1 but failed. I think this is because my 1.1.1 is not virgin.

So i use latest ver of ibrickr to restore to 1.0.2 and activated it. Now i used 1.0.2 anysim but unlock failed. Maybe this has something to do with the baseband or wtever i've been hearing about.

Can anyone help me at this stage? i just need the phone function and i don't care if its 1.1.1 or 1.0.2. I think the latest 1.1.2 as the latest update just complicates the whole situation as well.

I run winxp btw.