Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: -sh-3.2# How do i get out?

  1. #1
    Default -sh-3.2# How do i get out?
    Whenever I log into terminal, or putty whatever my screen always comes up with the -sh-3.2# instead of just #. I try typing in exit or ls or anything but my session ends before i get past 3 characters. Any help would be greatly appreciated

  2. #2
    Owner / Founder - ModMyi
    aka cash7c3
    Cody Overcash's Avatar
    Join Date
    May 2007
    Location
    Denver, CO
    Posts
    11,920
    Thanks
    339
    Thanked 15,254 Times in 649 Posts

    means you are running dropbear ssh instead of open ssh

  3. #3
    this happens even on the term-vt100 application

  4. #4

  5. #5
    i can ssh into the phone using winscp but i'd like to also be able to use putty to mod file permissions but i can't seem to remember how i got into this mode

    OK looks like i solved my own problem...I replaced the 'sh' binary from the 'bin' folder from another iphone...worked like a charm.....pat on the back to me
    Last edited by thomas_tucker; 2007-10-20 at 05:50 AM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •