Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: setting permissions!!!!NEED HELP PLEASE

  1. #1
    Default setting permissions!!!!NEED HELP PLEASE
    i am trying to install the new sendsong app for version 1.1.1 on my iphone and i was told that in order to do that i needed to set my permission to 0755

    i dont no where to go to change this
    please help me get to the place i need to go to change this

    thanks

  2. #2
    The easiest way I found is to open Finder (on the iPhone) and find the file.
    Click Modify and set the permissions like this:
    XXX
    X0X
    X0X

    X=in use, dark blue
    0=not in use, light blue

  3. #3
    Default Changing permission
    To chng the permission u need to go in finder .

    Ok ,
    But Still m not able to change it Exactly to 755 !
    After Clicking the SMSD.app i get to see 3 buttons of
    Read Write and Exec
    I dont know which 1 shld be selected and which shld be not !

    plz help !

  4. #4
    My iPhone is a Part of Me
    Join Date
    Oct 2007
    Location
    Colorado
    Posts
    569
    Thanks
    10
    Thanked 53 Times in 41 Posts

    read write and execute for owner
    read and excute for the other two.

    edit: or alternativly you can install terminal and type chmod 755 {/location/filename}

  5. #5
    You can also download Squid:

    http://www.modmyi.com/forums/sho...ighlight=squid

    This thread actually explains it very well with that application. And post number 9 on the first page shows what permission 0755 looks like with mobilefinder.app.
    2.2 pwned!!

  6. #6
    how can I retain the file permissions when I transfer the .app to my computer? I am then zipping the app and putting it on my installer source but the file permissions do not stay. Can anyone help?

  7. #7
    Quote Originally Posted by LimitedEditioniPhone_com View Post
    how can I retain the file permissions when I transfer the .app to my computer? I am then zipping the app and putting it on my installer source but the file permissions do not stay. Can anyone help?
    Are you transferring to a Windows PC? I think you would need to tar on the iPhone, then untar in a Unix environment (Cygwin) and then use Cygwin info-zip. Or reset permissions in Cygwin and then use Cygwin Info-Zip.

    Unix permissions in zip files are a InfoZip extension to the zip format that Windows zip programs don't support.

    Using a Mac, you could probably transfer with SSH to preserve permissions, then zip with Mac InfoZip.

  8. #8
    Hi everyboby. Would you please give me the source of Squid (.pxl)? I can not install it from iBickr. Thanks.

  9. #9
    am i able to get someone to re-save my file under linux to get the correct (755) permissions? Facebook.zip

    Just that i need this for my Installer Repository and as yet i haven't installed Linux to be able to zip with permissions intact.
    Last edited by nudge2232; 2008-01-11 at 03:05 PM.

  10. #10
    Green Apple
    Join Date
    Sep 2007
    Location
    Yonkers, New York, United States
    Posts
    41
    Thanks
    17
    Thanked 0 Times in 0 Posts

    Default Sux
    I want the listen app. I have to change the permissions on it. I had this issue with the one button dialing program but got Squid off of ibrikr and worked it out. I unintalled Squid and need it for Listen but Ibrikr's done. I found the Squid PXL... how can I load it manually... if that's even possible?

    I cant get past the root/password thing on SCP.

    Would attempt Mobilefinder but again, ibrikr's done

    Dont have installer on my phone to get these apps from there

    What else can I do?

    As an update... I had 1.0.2. I got instsller on my phone and came to realize that listen doesnt work for this version. I took the plunge and udated to 1.1.1 and installed installer. I'm all good now
    Last edited by pillzny; 2008-01-11 at 07:54 PM. Reason: Automerged Doublepost

  11. #11
    I am having the same issue..
    I have succeded in using pkzip to unix/DOS zip 2 ringtones and a wallpaper and put them into my repo and out to the iphone through installer (these retain permission) they are all maintained in root.

    I have a .webclip I am trying to retian permissions (in mobile) and it did for a few minuets and then it goes to 644 permissions?? The icon then just disapears it is there but invisable and unusable.

    The webclip is called irates and my installer4 repo is in my signiture please help me with a solution so that I may continue forward to develop more stuff....

    I am on a windows PC
    check out my website for touchscreen computers http://touchswipe.com

  12. #12
    i tried doing what you all said i mobile finder but when u look below at permissions it says 493

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •