Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: ipl2iph - BBC download script

  1. #1
    Default ipl2iph - BBC download script
    ipl2iph ... making the unmissable ... portable

    first release for UK only by default, but proxy can be added.

  2. The Following User Says Thank You to fl3tch For This Useful Post:

    toothpick (2008-09-02)

  3. #2
    Looks good.. Wish i could try it out.
    Last edited by addertay; 2008-08-25 at 04:35 PM.

  4. #3
    I have been waiting ages for this. The it arrives and it works flawlessly.
    Top work and thanks for sharing.

    Peace Toothpick

    This works flawlessly!
    I have been playing aroound with Paul Battley's wonderful script on the pc for a while now but the ultimate "holy grail" was being able to download bbc iplayer content directly onto the iPhone rather than the PC and then having to sync through itunes or WinScp.
    Thanks to you fl3tch and Paul for all your hard work.
    Peace Toothpick
    Last edited by toothpick; 2008-09-02 at 12:53 PM. Reason: Automerged Doublepost

  5. #4
    Thats really amazing. gonna try it tonight.

  6. #5
    Ran the script in terminal and said yes to all the questions.

    Last item of "About to launch iplayer-dl by Paul Battley ..... etc came on
    Then an error of "/usr/bin/ipl2iph: line 145: sudo: command not found

    Then returns me back to my root directory.

    Tried this on 2 iphoned both do exactly the same thing
    Last edited by tigermad; 2008-09-27 at 03:58 PM.

  7. #6
    install sudo from cydia

  8. The Following User Says Thank You to fl3tch For This Useful Post:

    tigermad (2008-09-28)

  9. #7
    Quote Originally Posted by fl3tch View Post
    install sudo from cydia
    Cheers, that worked

    Just to let you know the directory is incorrect. It puts a video directory in this directory:

    \private\var\mobile\Applications\Documents\Air Sharing\

    But airsharings directory (on my iphone) is:

    \private\var\mobile\Applications\05994EE4-D85D-4576-9044-E9E62D723B23\Documents\Air Sharing\

    So I have to keep moving the video when it has downloaded. Unfortunately Airsharing doesnt support symlinks from this directory.
    Last edited by tigermad; 2008-09-28 at 05:52 PM.

  10. #8
    forgot air sharing had an update which changed the apps foldername to have no spaces, have updated the scripts accordingly

  11. The Following User Says Thank You to fl3tch For This Useful Post:

    tigermad (2008-09-29)

  12. #9
    trying to install the latest version but it keeps running the installation of iplayer-dl.

    anyone else getting this? or know how to get it running from here?

    EDIT....(in case anyone else gets this!)

    Got it working i think. 3 things i did:
    i ran airsharing for first time,
    and fix user permissions in bossprefs

    I had to login into root (su root - alpine if you haven't altered it) and then rerun the script.
    Last edited by cadguycad; 2008-11-30 at 04:31 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts