Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: After unlocking 1.1.4 with iliberty, my iphone won't save certain settings

  1. #1
    Default After unlocking 1.1.4 with iliberty, my iphone won't save certain settings
    Right, so I used iLiberty to unlock my otb 1.1.4 iphone. Got it connected up to t-mobile, installed the bigboss 5.99 data plan fix and I'm very happy with all that. I also installed iMapIdle to simulate push e-mail.

    However, now it won't save my modifications to my signature and, more annoyingly, it won't save my setting turning off the keyboard click. It also won't save my "sounds" settings changes to "new voicemail" , "new mail" or "sent mail." Like I can change the entries in the settings pane, then return to settings, and it keeps it that far. If I return to the home screen, however, then go back into the settings, it has rest the keyboard click to "on" and has reverted my signature to "sent from my iphone." It will change my "calendar alerts" sound setting as well as my ringtones.

    I'm thinking this could be a permissions problem on the prefs file? I just got the phone and haven't had too much time to poke at it, but I'd appreciate any help you could give.

    I tried restoring it to original software and re-jailbreaking, unlocking, and activating it. The problem survived the restore.

    Thanks for your help.
    Last edited by SkiGuy; 2008-04-02 at 12:29 AM.

  2. #2
    I have the same thing after iLiberty+. I am just in the middle of restoring the phone and will try to use iPlus this time.

    Edit:
    Finished restoring. Used iPlus to j/u/a and it works fine now. Settings are now being saved properly.
    Might be an iLiberty+ bug?

    Also when I used iLiberty+ instead of gprs icon i had a blank square, before I had G in that square. It is just another thing I noticed after iliberty.
    Last edited by maly00; 2008-04-02 at 01:11 AM.

  3. #3
    Sweet. Lemme know how it goes. Here's hoping that it's just an iLiberty+ bug

  4. #4
    SkiGuy, what additional payloads have you used with iLiberty+? I used relocating, bsd subsystem, terminal, installer, open ssh and youtube fix. I have noticed that in the Installer there was no terminal listed as installed even though it was installed. BSD Subsystem was listed in installer as installed but applications were still asking for it so I had to install it again. Definitely not happy with iLiberty+...

    Over at hackint0sh people are saying that it is because of the new version that was released yesterday. It has a bug that does this. Use previous version instead. But I am happy with the iPlus as it installs all the fixes itself.
    Last edited by maly00; 2008-04-02 at 01:25 AM.

  5. #5
    I only used relocating, installer, and youtube fix. But if iplus works, I'll definitely be doing that as soon as I get home. Thanks for assuring me that i'm not crazy.

    iplus worked perfectly. must be a bug in iliberty.
    Last edited by SkiGuy; 2008-04-02 at 07:00 AM. Reason: Automerged Doublepost

  6. #6
    Darn, I'm having the same problems but I dont want to have to reunlock my phone again and lose all my apps etc.

  7. #7
    Green Apple gpost2's Avatar
    Join Date
    Mar 2008
    Location
    Vancouver Island, B.C.
    Posts
    36
    Thanks
    3
    Thanked 6 Times in 6 Posts

    Yeah i have the same problem, and Mail opens for one second and then closes, so i went to add an account through settings to see if that would work and it didn't save. I suggest using Ziphone 3.0 that worked amazingly and fixed my problems!

    Ziphone.org

  8. #8
    Livin the iPhone Life
    Join Date
    Dec 2007
    Location
    Boston, MA
    Posts
    1,033
    Thanks
    16
    Thanked 143 Times in 138 Posts

    yes it is a bug that the newest iliberty has. you can either wait for the new version which will fix this problem or use one of the older versions. i believe someone also mentioned a command you can run via terminal but i can't find that right now...

    also @maly00: the g for gprs is a manual customization. with a stock phone, there's just an empty blue square for gprs and E for edge

  9. #9
    How long do you think it'll be before the new one comes out?

  10. #10
    According to the official web site, the new version will come out today!

    http://www.ipluspwns.com/

    Update for iLiberty+ (Mac), New Features and Payloads
    Submitted by iPlusPWNS on Wed, 04/02/2008 - 09:28.
    They say you can't get too much of a good thing. So we're going to put that to a test, with our re-vamped new iLiberty+ for Mac OSX. We're putting the final touches on the GUI today, and will have it ready for download (Changed to: April 4th, by 12PM Cupertino Time)

  11. #11
    Is that just for mac?

  12. #12
    here's the solution

    Workaround: Download 88Installer Fix and decompress it, put the decompressed file (88Installer.sh) into payload folder (under iLiberty+ installation folder), overwrite the old file.

    Manual Fix: If you don’t wanna install Installer again (with the new patched script), you may enter the following command in shell (through SSH or Term-vt100) to fix the issue manually:

    chown -R mobile:mobile /var/mobile/Library/Preferences

    --Bug and workaround are submitted by AViegas

  13. #13
    o boy o boy o boy someone plz help me do this, i don't understand how to do that. I'll be using iphonebrowser. does decompress just mean unzip? and where is the payload folder located? on iphone or pc?

    UPDATE:Finally!!!! Here ya go worked for me
    http://www.ipodtouchfans.com/forums/...ad.php?t=54152
    [ame="http://www.youtube.com/watch?v=rl8k_OIlAbw"]YouTube - Jailbreak and Setup 1.1.4 Part 6[/ame]
    Last edited by laz305; 2008-04-10 at 09:24 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •