Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Iphone Unlock service provider help (First timer)??

  1. #1
    Default Iphone Unlock service provider help (First timer)??
    Hey guys, Im totally new to this unlocking and there seems to be so many different ways to do it and i just wanna make sure i dont mess this phone up (brick or whatever its called). wondering if someone can guide me in the right direction. I had a iphone 3g (fido carrier) but it got stolen. I just picked up another Iphone 3g (Rogers Carrier), Just did a factory restore but since its locked to rogers carrier, my Fido sim card doesn't work. So i have to jail break it, unlock, then restore my old iphone backup (ie contact, games, photo,etc)??? is this in the right order??
    does it matter which firm where was installed at the time on the iphone that got stolen. Do i have to have the same firmware on this new one ?
    can someone provide me some links tutorial to what i have to do from here.

    thanks.
    Last edited by hastyle; 2011-09-19 at 10:22 PM.

  2. #2
    first thing you need to do is find out your firmware/baseband version. but really, your baseband version is key to know if you can do a software or hardware unlock. you can find this info in your settings, about. then go to the sticky in this section (unlocking) and check against that list. check your phone type vs firmware/baseband. from there you'll know right away if you can jb and or unlock.

  3. #3
    what's your baseband? and I've never heard of that carrier before!

  4. #4
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Yes you could just restore from backup, jb, and unlock. But like the previous user said, whether you can unlock or not depends on your baseband version. For an iPhone 3G the bootloader can play a role if it is the right one.

    So find out with F0recast:
    1) bootloader (5.8, 5.9?)
    2) baseband (5.13.xx, 5.15.xx?)
    3) firmware version (3.1.3, 4.2.1?)

    The examples I listed in parenthesis are not the only possibilities, just FYI. Let me know what you find.

  5. #5
    Hey Guys sorry for the late reply, I should have done some reading before even posting, i apologies, so i went to google and tried to read up and do the research, i feel like im just going around in circles with the amount of information out there for iphone jb/ unlocking and since this is an old iphone, most of the tutorials ive come accross is for an ipod touch or newer iphones.


    So i have a 3g iphone (fido is a canadian carrier)
    firmware 4.2.1 (bc148)
    running windows 7

    -capture.gif
    from what i understand, i need to JB it first with either redsnow, greenposin or snowbreeze, I read snowbreeze doesnt work as well as the other two options, all i know is that i dont want a tethered JB.

    Then i have to update my Baseband to the ipad BB 6.15 ?!?! before i can unlock it with Ultrasnow?



    Quote Originally Posted by i.Annie View Post
    Yes you could just restore from backup, jb, and unlock. But like the previous user said, whether you can unlock or not depends on your baseband version. For an iPhone 3G the bootloader can play a role if it is the right one.

    So find out with F0recast:
    1) bootloader (5.8, 5.9?)
    2) baseband (5.13.xx, 5.15.xx?)
    3) firmware version (3.1.3, 4.2.1?)

    The examples I listed in parenthesis are not the only possibilities, just FYI. Let me know what you find.
    Last edited by hastyle; 2011-09-26 at 09:30 PM.

  6. #6
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Yes with 5.9 bl you can't downgrade the baseband so in order for you to unlock you need to upgrade it. Just note it will break or mess up your GPS. So if you are willing to sacrifice that, you can proceed.

    Is 4.2.1 what you want to keep it at? iPhone 3G runs best on 3.1.3 in which you could always downgrade to it after upgrading your baseband to an unlockable state first.

    If you want to stay on 4.2.1, just use Redsn0w and select to upgrade the baseband only. When it finishes flashing the bb, run redsn0w again and select to install Cydia only. Do not try to do both of these steps at the same time, trust me on that, you'll just be wasting time

    If you want to downgrade to 3.1.3, you would use redsn0w while you are on 4.2.1 and select to upgrade the baseband only. Then you will restore the phone to 3.1.3 with a stock firmware, use TinyUmbrella to exit recovery when you get error 1015, then jailbreak as normal after.

    On 3.1.3 you can jailbreak with Redsn0w VERSION 0.9.4 (that's very important) in conjunction with a stock 3.1.2 (yes that's correct, you downgrade to 3.1.3 but use a 3.1.2 firmware version) ipsw. As outlined above, simply select only the box for installing Cydia and jb it.

    Then go to Cydia whether you're on 4.2.1 or 3.1.3 whatever, all you need now to unlock is Ultrasn0w so search it and install it.

    Good luck

  7. #7
    Wow thanks for the detailed post, 4.2.1. runs fine for me, ill keep it as. Now does it matter what version of redsnow i should be using to jb?? Thats ashame that the GPS wont work, as i use it often. Is there no way around this??

  8. #8
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Nope there's no way around GPS loss/malfunction. You might get lucky and it won't be affected (but only a small handful of people don't get affected). It's not clear if there's a trend or not, it seems purely random. So expect it to be affected.

    For 4.2.1 redsn0w I think can be the latest version on the dev team's blog

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •