Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3GS Unlock issues!

  1. #1
    Default iPhone 3GS Unlock issues!
    Hi there,

    Apologies if this post is lengthy.

    I own an iPhone 3GS (16GB) that was originally locked to the 'Orange' network. It's been running unlocked on 4.2.1 perfectly with iPad baseband for about 4-5 months now (I even had working GPS). However, yesterday I came across a problem. I noticed that I had no signal bars, yet my carrier was still displayed. I live in quite a high signal area, so this was new to me. Upon further inspection I discovered that I could not make/receive calls or SMS messages. After playing around I discovered that if I turn off all data (3G and Cellular Data) my phone displays 'No Service'. When they're turned on, I will either get a 3G or Edge Logo and 'O2-UK' displayed. Here's where the interesting part comes in. Turns out that I can use all my data fine. Even though it's reporting no bars, I still get the effects of a full 3G connection. I'm basically only able to use my data connection and nothing else.

    After ruling out my sim card by trying it in another phone, I began to search around for a solution. I am aware that upgrading to the iPad baseband is a huge risk. However when I received the phone it was my only option for an unlock. While many people have similar problems, I don't think i've seen one where only the data side of things is working.

    Whilst trying to restore my phone and repair this issue I ended up with a bricked phone, stuck in a DFU Loop. I tried almost every combination of redsn0w/Pwnage Tool/Greenpois0n/Custom Firmware possible. After hours of failed attempts, I was finally able to use redsn0w to put my phone into a pwned DFU mode, install the stock 4.3.3 firmware (with 1015 error ofcourse) and Jailbreak successfully (again, with redsn0w). I also used ultrasn0w to unlock after this however have exactly the same issue except now i'm on 4.3.3 rather than 4.2.1. Unfortunately I do not have an Orange sim to check that it's not hardware, but I find that unlikely as I look after this phone very carefully and my issue appeared out of nowhere.

    If anyone has experienced anything similar or has any suggestions, i'd be interested to hear.

    Thank you.

  2. #2
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Create a custom 4.1 firmware with Sn0wbreeze, get into pwned DFU mode with Sn0wbreeze after creating the cFW, then open iTunes, shift+restore to the 4.1 cFW. Be sure in Sn0wbreeze to 1) enter Expert mode 2) in General select "activate" if you don't have official SIM to activate with.

    Be sure you're doing this with 4.1. I don't know whether you have SHSHs saved for 4.3.3 or not, but disregarding that it's easier just to restore to custom 4.1 and go from there if you really want 4.3.3. Getting the phone back to a functional state, then you can check for SHSHs for 4.3.3 but right now, get to functional 4.1.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •