Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3G, 4,2,1, 6.15.00, constant reboot

  1. #1
    Default 3G, 4,2,1, 6.15.00, constant reboot
    Greetings all -

    I'm new to this forum, and seeking advice.

    I have a 3G 16GB running 4.2.1 w/ iPad 6.15.00. I have my SHSH for 4.1 and 4.2.1. The phone was originally jailbroken with redsnow, then unlocked with ultrasnow.

    This phone worked great for several months, then something happened where it started rebooting. I went to re-image the phone, but the same behavior exists about 90 percent of the time. I say 90 percent, because after reloading the phone through various attempts, it might give me the slide screen, but then the phone. But, when I reboot the phone, it fails to allow be back to the slide screen after several hours.

    Tools:
    TinyUmbrella 5.x, which shows both 4.1 and 4.2.1 SHSH files are local.
    iTunes 10.x
    RedSnow 0.9.6rc16
    iREB 4.x

    I have both an original (apple sourced) recovery image for 4.2.1, and I have a modified one that's activated with no features turned on.

    Try 1:
    I've pwned the phone with redsnow in DFU (no cydia, etc..) then shift-reloaded the original recovery 4.2.1 onto the phone, with tinyumbrella server running.

    I see activity in the logs of tinyumbrella show that it detects the itunes request for this phone, and appears to be serving up the needed local SHSH data to iTunes to allow for the reload of the phone.

    The result? 1015.

    I try to then run the fix via tinyumbrella, and it stops at the message "Wait for reboot". It never reboots the phone.
    I try iREB's 1015 fix, and the status messages suggest that it has fixed the phone, and actually reboots the phone, but it's the phone continues to be stuck in a reboot cycle.

    Try 2:
    Similar to the above, but with a special image that does not include firmware. I use iTunes to shift-reload the phone, with tinyumbrella running to serve the SHSH. Sometimes the results are 1015, other times the results are 1600.

    Any advice as to what I might be missing? This one has me totally puzzled.

    Thanks.

  2. #2
    what you need to do is restore to 4.1 first then upgrade to 4.2.1

    I know this works if you have a sim card

    1.restore to 4.1 in itunes you will get the 1015 error message
    2. use ireb 4.x to get the green screen
    3.use your redsn0w to "jailbreak tethered for now" using 4.1 firmware files
    4.then use redsn0w to install cydia
    5.then "UPGRADE" in itunes to your 4.2.1 stock firmware it is important that you upgrade not restore
    6.use redsn0w to "jailbreak tethered for now "using the 4.1 stock firmware" not 4.2

    at this point your iphone should be working but the screen flashes funny but that is normal

    7. jail break using 4.2.1 firmware install cydia and whatever custom options you select
    8. done
    Last edited by zoltan1600; 2011-08-12 at 10:08 PM.

  3. #3
    z-

    First, thank you for running through the steps with me.

    All of this was done with an active AT&T SIM from my other phone.

    1.restore to 4.1 in itunes you will get the 1015 error message
    DB: Assuming I should not use tiny umbrella server here, I did get the 1015 error. I used the original 4.1 apple ipsw for this step.
    2. use ireb 4.x to get the green screen
    DB: I did this, but the screen isn't green. It stays black.
    3.use your redsn0w to "jailbreak tethered for now" using 4.1 firmware files
    DB: Again, I used the original apple 4.1 ipsw here. I selected "tethered boot for now" as an option. It loaded code onto the phone, and showed a color pineapple. It reboots to the apple logo, then the color pineapple for about 3 minutes, then reboots - "Connect to iTunes" is where it leaves me.
    4.then use redsn0w to install cydia
    DB: I install cydia, and after the reboot, it cycles the apple logo, and never goes further.
    5.then "UPGRADE" in itunes to your 4.2.1 stock firmware it is important that you upgrade not restore
    DB: I don't get the upgrade option, I get the restore option here.
    .
    .
    .
    .
    .
    6.use redsn0w to "jailbreak tethered for now "using the 4.1 stock firmware" not 4.2

    at this point your iphone should be working but the screen flashes funny but that is normal

    7. jail break using 4.2.1 firmware install cydia and whatever custom options you select
    8. done

  4. #4
    I will add that I just figured this out. It was not what I was expecting.

    Just before all these problems started, I replaced the screen assemby with one from a different phone. I swapped the screen because one of the problems I was having (since I originally unlocked the phone several months ago) was that the ear speaker was no longer working - only speakerphone. After the screen swap, I could not get past the apple logo. Switching to a new screen assembly, everything is now working. It booted up on the first try, and the phone is working great now. It's running 4.1, JK, unlocked, 6.15.00 on a SIM from Belgium. All is well again.

    My question for another day - why would the screen assembly cause the phone to get stuck at the Apple logo?

  5. #5
    Quote Originally Posted by DocBoston View Post
    z-


    4.then use redsn0w to install cydia
    DB: I install cydia, and after the reboot, it cycles the apple logo, and never goes further.
    5.then "UPGRADE" in itunes to your 4.2.1 stock firmware it is important that you upgrade not restore
    DB: I don't get the upgrade option, I get the restore option here.
    e

    the reason you don't get the upgrade option is because the phone did not get unlocked and activated

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •