Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Help with No-data plan Unlock?

  1. #1
    Question Help with No-data plan Unlock?
    I'm new to the modmyi forums, and I need some help with the "Waiting for Activation" message which appears on my iPhone 3G (Modified iOS 4.2.1). After Jailbreaking it with redsn0w, this message began appearing. Although I do use AT&T, I don't have a data plan, and the SIM card was originally taken from a different phone (I think it was an LG Neon). I assume "activation" entails signing up for one, so I'm trying to avoid that option. I tried unlocking it by installing ultrasn0w, but this resulted in an endless "Searching..." in the carrier bar. After a few reboots, it finally stopped searching, and began to display the "Waiting for Activation" message again. Does anyone have any idea how to fix this? I believe AT&T still allows calls from this SIM card, since I had a working iPhone 2G (without data) before I switched to my new one.

  2. #2
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    As long as you have voice service on any sim card after ultrasn0w installed , you should be able to activate it. What is your current baseband ?

  3. #3
    Livin the iPhone Life
    Join Date
    Nov 2007
    Location
    Arkham Asylum
    Posts
    1,041
    Thanks
    12
    Thanked 104 Times in 103 Posts

    Why do you need an unlock if you're on AT&T?
    I would uninstall ultrasn0w and reboot the phone. Reset all settings and then reboot once more. The activation of the sim should clearly go through if you're on an official carrier hence why it worked on a 2g iPhone. You'll need to set up a fake apn once you get the sim activated so you wont get charged for data.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •