Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: iphone 4 questions please help.

  1. #1
    Default iphone 4 questions please help.
    Hello all, Just got myself an iphone 4 that is stuck in the itunes logo screen. I tried many things to go ahead and restore it but have failed. I have a few questions that hopefully you guys can answer. I also dont know what BB and firmware im on..explain more below.

    Any help on this matter would be greatly appreciated. Ive done some searching for about 2 hours now and have found many people complaining of my same error but none of which can be resolved. Thank you all.

    ***EDIT****: edited for new questions asked further down thank you.
    Last edited by Mr. Bling Bling; 2011-06-28 at 07:21 PM.

  2. #2
    Maybe Tiny Umbrella isn't iOS 5 compatible?

    If this is the case then all you can do is wait and hope the developer(s) update it.

  3. The Following User Says Thank You to Jahooba For This Useful Post:

    Mr. Bling Bling (2011-06-28)

  4. #3
    I can definitely help you! The 3419 error code is typically related to shsh blobs. If you have the request from cydia box checked it means that your requesting the shsh blobs from sauricks server. if you uncheck the box then it uses the shsh blobs saved locally on the computer. your best bet though when you get stuck like that is to do a clean restore. make sure you uncheck the box that says set hosts to cydia on exit. only do this though if you do not require an unlock. Are you using the new ios 5 beta version of itunes (10.5 b2) if so uninstall it and install a the newest public release of itunes also do you know what firmwares you have shsh blobs for?

  5. The Following 2 Users Say Thank You to harner818 For This Useful Post:

    Mr. Bling Bling (2011-06-28), tina.hyp. (2011-06-30)

  6. #4
    Thanks for you input when I get home, I'll be able to work on it some more and let you guys know. Thanks.

  7. #5
    Got the phone running finally. Im on 4.3iOs and running BB of 04.10.01. So far what I have been reading is that the only way to unlock/Jailbreak this phone is with the "Gevey sim" Im a 3gs guy and this is new news for me as coming to this iphone 4 is all a brand new experience.

    So I jailbreak with redsnow and leave the unlocking with the gevey sim? Just need a confirmation before I go ahead and buy one of these things. Anything I should know before installing this sim? How will my carrier be affected by this and does the gevey sim have to stay in there all the time? Thanks guys. So far, almost there!

  8. #6
    Yes, that's correct, you will have to unlock with the Gevey SIM. The only thing that will probably be helpful to know, is there are many different kinds of Gevey SIMs, real and fake, all with different features.
    Gevey Turbo - the first, requires 112 dialing every reboot.
    Gevey Pro - improved version, still requires 112 dialing every reboot, power drain issues.
    Fake Gevey Turbo - seems to work as well as the real Gevey Turbo, but much cheaper.
    Fake Gevey Pro - seems to work as well as a real Gevey Pro, but requires no sim cutting and no power drain issues, and cheaper.
    Fake Gevey Supreme Yellow - Only dial 112 once, not needed on reboots, but data connection does not return on some networks.
    Fake Gevey Supreme Red - Like the Yellow, but supposedly improved.
    Fake GeveyPass - Only dial 112 once, not needed on reboots, supposedly restores data connection, but I saw a review which recommended Gevey Supreme over this.
    Gevey Ultra - Requires jailbreaking, uses a Furiousmod app that dials 112 for you so you don't have to do it yourself.

    One thing I like about the fakes is with many of them, you don't have to notch the SIM. I don't know why that's even a selling point for me, just an OCD thing I guess.

    I think prices range from under $5 to almost $30 depending on which you get. Up until I got an iPhone 4 with 1.59.00BB, I was using an old fake Gevey Pro I bought for $6 which worked very well. I never had to do 112 for losing signal or anything other than a reboot, and always had data. In fact, the whole 112 thing is no big deal, it was easier to use the Gevey on 4.10.01 than everything it took to get a perfectly working Ultrasn0w unlock on 1.59.00!

    Your carrier will be unaffected and yes, the Gevey SIM has to stay there all the time. They always come with a replacement SIM tray which has a notch cut out for the chip.

  9. The Following User Says Thank You to GnatGoSplat For This Useful Post:

    tina.hyp. (2011-06-30)

  10. #7
    i have a question along the same lines. i had the same problem with an iPhone i bought used. i finally got it into dfu, and now iTunes is asking me to reload my backup. i don't have any. where do i go from here? thanks in advance for any help in advance.

  11. #8
    Are you trying to flash a custom firmware? If so, hold down shift (Windows) or Option (Mac) and click Restore. You'll get a file browser which will let you browse to your custom firmware to restore into the phone.

  12. The Following User Says Thank You to GnatGoSplat For This Useful Post:

    tina.hyp. (2011-07-01)

  13. #9
    ok, i tried that and it told me my firmware is not compatable. i downloaded it from blacksnow.

    also, im running blind as far as information goes. its an iphone 4, but thats all i can tell you, it locked up when i tried to charge it the same day i bought it.
    Last edited by tina.hyp.; 2011-07-01 at 05:55 AM.

  14. #10
    I'm not familiar with blacksnow. Google search seems to indicate it's for 3G/3GS?
    Be sure and get a custom firmware for iPhone 4.

  15. The Following User Says Thank You to GnatGoSplat For This Useful Post:

    tina.hyp. (2011-07-02)

  16. #11
    Quote Originally Posted by GnatGoSplat View Post
    I'm not familiar with blacksnow. Google search seems to indicate it's for 3G/3GS?
    Be sure and get a custom firmware for iPhone 4.
    sorry i miss-typed, i was reading in the dark. it was snowbreaze. blacksnow is a fix for blackrain, which i did try to use and of course it didn't work due to being to old for this phone. i am new to iphones and unsure how to proceed beyond this point. using snowbreaze i did find a custom firmware that worked for this iphone, and worked, however itunes still tells me that i can not use it due to the firmware being incombatable, and no backup. it has taken me two weeks to find the firmware itself.
    by the way you have been very helpful with finding where to find information on how to get my phone this far, and i thank you for that and any further assistance.

  17. #12
    In that case, I would probably not bother using someone else's custom firmware, but making your own using Sn0wbreeze.
    You will probably need to point it at stock firmware, which will be located here:

    On Windows XP :
    Documents and Settings\<User>\Application Data\Apple Computer\iTunes\iPhone Software Updates

    On Windows Vista/Windows 7:
    Users\<User>\AppData\Roaming\Apple Computer\iTunes\iPhone Software Updates

    If there's no stock firmware in there, you can plug in your phone and iTunes will ask if you want to install new firmware, and I think at that point you can click "Download Only". It will then download the appropriate firmware into that folder.

  18. The Following User Says Thank You to GnatGoSplat For This Useful Post:

    tina.hyp. (2011-07-08)

  19. #13
    im finding more information every day. apparently this is an iphone 4 iOS4.2 or iOS4.3 apple will kindly and download the user guide for me. i found a stock ipsw like you suggested, however i think i got the wrong one again. i will try one for the iOS 4.3 later today. thanks aagain for the help.

  20. #14
    so i did find the right on as far as i can tell. but apple is giving me an error 21. update my browser, itunes and computer os. sorry apple, im as updated as im going to get. and they dont like my wifi connection. im not about to interupt everyone else for the day so apple can get their hands on my iphone. there hase to be another way.

  21. #15
    Error 21 usually means you are trying to restore a phone with custom firmware in Recovery Mode, but what you need to be in is DFU mode.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts