Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: iPhone 2G hacktivation

  1. #1
    Default iPhone 2G hacktivation
    Hi all

    I am trying to hacktivate an iPhone 2G for a friend as i did the same to my 3Gs, but the 2G is proving to be far more tricky. The phone is currently stuck in recovery mode. I initially tried to use the redsn0w 0.7.2 guide on modmyi to unlock and jailbreak, but no luck with that, it just hangs on the 'downloading jailbreak' screen. I then tried to just hacktivate the device with geohots Blackra1n, that didn't work either.
    The specs on the phone from f0recast are as follows:
    iPhone 2G (stuck in recovery mode)
    Firmware: 3.1.3
    Baseband: 04.05.04_G
    Bootloader: 3.9
    Model: MB213

    I am running a windows PC and the easiest guide (Pwnage Tool) seems to be for Mac's only.

    The phone is still in recovery mode and any suggestions on how to proceed further would be appreciated.

    Last edited by garro101; 2011-05-25 at 10:43 PM.

  2. #2
    Retired Moderator
    Join Date
    Jun 2009
    Alhambra, CA
    Thanked 2,202 Times in 1,924 Posts

    Use Redsn0w 0.9.4 with a stock 3.1.2 ipsw. It's okay that the phone is on 3.1.3, just be sure you're using 3.1.2 for Redsn0w to proceed.

    Since it is stuck in recovery mode, all you have to do is restore it again to stock (not custom) 3.1.3, then use redsn0w as I stated above.

  3. #3
    Thanks so much for the help!

    What i ended up doing was using redsn0w 0.9.4 to allow me to restore the device to a stock 3.0 ipsw (which i couldn't do before) then i used redsn0w 0.7.4 to unlock and activate.

    The device is working perfectly and am a little scared to try this again with a 3.1.2 ipsw or later.

    Thanks again for the help

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts