Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Help! No Tmobile SIM detected, 2G 3.1.2 baseband 4.05.04_G, I've tried EVERYTHING!!

  1. #1
    Angry Help! No Tmobile SIM detected, 2G 3.1.2 baseband 4.05.04_G, I've tried EVERYTHING!!
    Help! I'm having problems getting my iphone 2g to work with my Tmobile SIM card after restore, re-jailbreak and re-unlock.

    I have been working on my phone for a couple days now, scouring the internet for information to help me. Basically a noob, but becoming a professional because I've spent so much time on this, haha! Any help on this problem would be greatly appreciated!

    Specs: iPhone 2G, current firmware 3.1.2, baseband 4.05.04_G, Windows 7, Itunes 10

    Phone had been working ok on Tmobile prepaid SIM prior to restore, etc. Cydia started crashing and phone was dragging bad, so decided to do fresh restore. Followed online instructions to do iTunes restore to 3.1.3, then jailbreak and unlock through redsn0w 0.9.4 (chose compatibility with Window XP Service Pack 3, pointed to original [not custom] 3.1.2 firmware, checked 'install Cydia' and 'Unlock'- uploaded BN 39 and BN 46). Then launched Cydia and after updating files, installed Bootneuter and made sure settings were: 4.6, Neuter ON, FakeBlank OFF, Unlock ON- flashed it and rebooted. I also made sure the Auto Lock was set to NEVER. All these steps were done without a SIM card. Inserted Tmobile SIM and saw the error "No SIM installed". Proceeded to install afc2add from Cydia and went through Diskaid to SSH into the phone, deleted the Lockdown folder (although it always seems to reappear) and rebooted phone. Still No SIM card detected...

    The funny thing is that when I put a Simple Mobile card in, it recognizes it and just says "No Service" (because of low cell service at my house). The same thing happens with an AT&T SIM card, gives me 1 bar or No Service. So because it is recognizing the Simple Mobile, the phone is def unlocked, right?

    Other things I've tried already:
    1. The entire process above, but with the Tmobile SIM in the whole time.
    2. The entire process above, with the AT&T SIM card in, and then switched to Tmobile after bootneuter.
    3. Jailbreaking through blackra1n and installed Cydia that way after restoring to 3.1.3. Also tried this method after restoring to 3.1.2. If I was able to get blackra1n to work (all the way to Geohot's face and rebooted, and then blackra1n icon on home screen), then Cydia never seemed to work. It would always crash after opening.
    4. Also tried downgrading to 3.0.1 and using redsn0w 0.8 to unlock and jailbreak.
    5. Went through redsn0w 0.9.3 to see if that made a difference.
    6. Pointed to custom 3.1.2 ipsw files (joined through HJSplit) with the redsn0w, but then got error message 1600 and couldn't continue down that path. Someone on another forum said that the custom ipsw's weren't necessary with 2G anyways, is that right?!
    7. Tried another computer with Windows XP (laptop). Tried different USB ports and different cords on each computer.
    8. Downgraded Itunes to 9.x to no avail. Reinstalled iTunes 10 and tried again.
    9. Checked "install cydia", "unlock" AND "already pwned" in redsn0w according to one online instruction guide. Also tried only "install cydia" and "unlock" according to another guide.
    10. Promised my soul to the devil and sold my first born child to some gypsies, but that didn't work either...

    I think that's about everything. Where I am right now is 3.1.2 original firmware, baseband 4.05.04_G, jailbroken through redsn0w 0.9.4 and unlocked through bootneuter 2.1, with Lockdown folder removed through diskaid after installing afc2add, and Tmobile SIM inserted with "No SIM card installed" error message. Oh, and wifi works fine.

    Is the Tmobile SIM card effed? Does anyone have any ideas of what I'm doing wrong? The 2G is supposed to be easy to unlock for Tmobile, right?! Thanks in advance for any help!!

  2. #2
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    sounds to me like the tmo sim is defective, do you have anyone that you can get one from to test and confirm?

  3. #3
    Quote Originally Posted by j3st3r View Post
    sounds to me like the tmo sim is defective, do you have anyone that you can get one from to test and confirm?
    I called TMo and talked to a rep, and they offered to give me a free SIM card if I go to one of their stores. He was very nice, but couldn't solve the problem. He had suggested changing the epc.tmobile.com in the APN settings to wap.voicestream.com, but that didn't change the "No SIM" message. Anyways, I will try and get to the store and see if it's the sim card. It was working fine before I made all the changes, is it possible that I messed up the sim card by restoring the phone?

  4. #4
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    I have personally never heard of a restore
    messing up a sim card

  5. #5
    yeah me neither. The TMo rep said the only way to "melt" a sim card is to repeatedly enter in the wrong passcode, and then it will actually fry the sim! Not sure if that's true?!

  6. #6
    Yeah that's what a tmobile representative told me but it was about a PUK code or something like that.

  7. #7
    Just curious, is 3G still enabled? Settings>general>network

    T-mobile doesnt support it.

  8. #8
    Quote Originally Posted by xerino View Post
    Just curious, is 3G still enabled? Settings>general>network

    T-mobile doesnt support it.
    Hey, thanks for responding. No, I have the 2G, so no 3G anyways...

  9. #9
    Reboot the phone.

  10. #10
    Soooo... in case anyone is interested in the outcome... I went to Tmobile and got a new SIM card, and sure enough it works now. I'm not sure how the sim card was ruined when I was jailbreaking/unlocking the phone, but something happened to it. But I'm happy now that it works again with the new SIM, yay!!

  11. #11
    How you liking the 2g on tmobile? I almost went with a 2g instead of the 3g but I like to be somewhat current.. Of course, i know I wont be getting 3g on it anyway but..

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •