Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3GS ios 4. Ultrasn0w for T-Mobile & Jailbreakme.com. No Push with T-Mobile.

  1. #1
    Default iPhone 3GS ios 4. Ultrasn0w for T-Mobile & Jailbreakme.com. No Push with T-Mobile.
    Hello all,

    I'm having a big problem getting my push to work.. this is what i did :

    Restore to 4.0.1 official using a friend's AT&T sim card to activate.
    Jailbreak with "Jailbreakme.com"
    Unlock with Ultrasn0w to use my own T-Mobile sim.

    Unlock went smooth , i have good reception everything is working.. except push notifications.

    I have tried :
    Push Doctor in Cydia.. didn't work.
    Injecting my friend's AT&T certs using nimble & inject.. didn't work
    Re-activate with AT&T simcard.. didn't work.

    HOWEVER..

    every time i pop out my T-Mobile sim card , all push messages show up at once.
    i have also tested push with airplane mode on and Wi-Fi on.. : WORKS. !

    i find this very weird.. i guess it's something with T-Mobile that blocks the push notifications..
    However i'm always on Wi-Fi even when i'm on T-Mobile.

    What can i do to get push working?

    Any help is much appreciated !

  2. #2
    I have the same specs as you, 3GS on tmobile ios 4.0.1 and my push notifications are working fine. Sometimes it skips a notification but for the most part my mail push and app push is working pretty well. I haven't installed anything such as pushdoctor I just simply used jailbreakme and ultrasn0w. Any one else having issues?

  3. #3
    Found the solution !

    For anyone having the same problem , go to Settings -> General -> Network and turn off 3G and cellular data.

  4. #4
    Quote Originally Posted by Mounir92 View Post
    Found the solution !

    For anyone having the same problem , go to Settings -> General -> Network and turn off 3G and cellular data.
    You may not have fixed the problem you have just masked it. It sounds a lot like your T-Mobile data is not working, probably because you have not set up the APN configuration for T-Mobile. What you did will disconnect all cellular data and force you to use WIFI only. If you do not have a data plan then no problem. If you do have a data plan as soon as you walk away from the WIFI network you will have no connection to the data network.

  5. #5
    I have the same problem, emails don't push.

    Has anyone found a solution to this?
    What exactly needs to be done (ie steps) for a jailbroken 3GS so that push emails work with T-Mobile?
    What are the APN settings that need to be adjusted?
    Do I need to reactivate with a AT&T sim card?

    Thanks. I've been struggling to find out why push emails aren't working.
    Last edited by ibrickyo; 2010-11-02 at 11:02 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •