Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 2.2 update help...please

  1. #1
    Default 2.2 update help...please
    Hey folks, I'm not too savvy with the whole iPhone unlock and Jailbreak issue.

    I have an iPhone 3G running OS 2.2 and was wondering if i could upgrade and unlock it. Also can you guys advise me to the risks to updating? Like if something goes bad during the update will my phone be unlockable for life or anything?

    THANKS VERY MUCH for any and all the help which may be offered.

  2. #2
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by Jahwarriah View Post
    Hey folks, I'm not too savvy with the whole iPhone unlock and Jailbreak issue.

    I have an iPhone 3G running OS 2.2 and was wondering if i could upgrade and unlock it. Also can you guys advise me to the risks to updating? Like if something goes bad during the update will my phone be unlockable for life or anything?

    THANKS VERY MUCH for any and all the help which may be offered.
    Alright there are many ways but this is what I would do:
    First download the 3.0 ipsw
    Download Redsn0w 0.8
    Do a shift key + Restore ( Itunes) and browse to the file you downloaded and let it restore.
    Once finished restore, run Redsn0w 0.8 and follow the instructions.
    Once done, you are at Baseband 04.26.08 to be unlocked with Ultrasn0w ( but don't install Ultrasn0w yet)
    Now Download snowbreeze 1.5.2 and 3.1.3 ipsw
    Build the custom firmware of 3.1.3, once finished, it will be placed on your Desktop.
    Now do a Shift key + Restore (Itunes) and browse to the custom firmware that would say snowbree....ipsw
    Once you are done , you are already jailbroken at 3.1.3.
    Now open Cydia, let it update then restart and open Cydia again and Install Ultrasn0w.
    You are now jailbroken and unlocked at OS 3.1.3 ( I don't recommend iOS 4.0 for 3G )
    Ultrasn0w is very stable at this baseband of 04.26.08.
    No doubt that there is a little more work on what I described , but it is worth it.
    Remember to click the Thanks button if you find this useful.

  3. The Following User Says Thank You to iYeow For This Useful Post:

    Jahwarriah (2010-07-04)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •