Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3GS Jailbreak/Unlock

  1. #1
    Default 3GS Jailbreak/Unlock
    Hey all,

    I made a big mistake -- upgraded to OS4 right when I was about to leave the country. Now I have a different SIM, but a phone that's neither unlocked nor jailbroken. I'm currently on a 3GS running iOS4 with baseband 5.13.4.

    I have jailbroken previously and am quite sure that I have ECID's from 3.0 upto 3.1.3 saved. My questions: Do I need to downgrade in order to jailbreak and unlock (ESPECIALLY UNLOCK; I NEED IT REAL SOON)? If so, do I need an older iTunes or something (I have 9.2) and anything else?
    If I dont need to downgrade (which would be brilliant) how do I go about jailbreaking/unlocking?

    Thanks a lot!

  2. #2
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    You have to downgrade in order to jailbreak. You have to point your hosts file to Cydia . Restore to the ipsw fw that has shsh blogs. You will encounter error 1015. You will have to get out of this recovery loop. You need tools like ireb

    Irecovery, or rslite to boot ur iPhone into emergency screen. Only then u jailbreak with ur preferred tool and then unlock with ultrasn0w
    Last edited by iYeow; 2010-07-02 at 11:09 AM. Reason: Automerged Doublepost

  3. #3
    Thanks for the reply

    I tried doing as you said, but once I run blackra1n after installing 3.1.2 (and getting the error in recovery mode), there is no network and its weird.. it shows only 1 bar, but no signal at all...

    I tried with redsn0w, and that was unsuccessful as well.. it got stuck on the "installing activation updates" screen

    Please help

  4. #4
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    How did you get out of the error when you were restoring to 3.1.2 ? If you run Blackra1n, you have to be at Emergency Screen.

  5. #5
    You were almost there with the blackra1n install. Restore to 3.1.2, ignore the error, and run blackra1n. This will take you to the home screen, then just go to the blackra1n app on the phone, and install cydia.
    Then install ultrasn0w to unlock it
    (if there's no ultrasn0w, add repo666.ultrasn0w.com)
    Last edited by babyblue_pimp; 2010-07-04 at 11:28 PM.

  6. #6
    OMG pimp Thanks! Installing ultrasn0w fixed it.. turns out I was trying to unlock it using blackra1n's sn0w, which I guess can't unlock 5.13.4 .. YAY

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •