ok guys im sorry for the noob post but im drained!!!

i've got a 8gb iphone - i bought it years back when it first came out - so yes it's old. i used the phone for about 2 months and have had it in a drawer ever since.

ok. restored/upgraded to 3.1.3 - snowbreeze firmware crapped out and had an error

rednow has an error on 3.1.3 and 3.1.2

had the worst time with blackrain until i realized it only worked with 3.1.2... man that wasted alot of time. but, blackrain worked great my little iphone is jailbroked (once agaian). only problem is that Cydia is nowhere to be found on the phone - there was never an icon to install Cydia. Now im left with a jailbroken phone that i can't figure out to unlock b/c the only **** i can to help me unlock is ultrasnow or white snow or green snow or whatever those two are, but i can't use either of them b/c i don't have cydia on the iphone and the only way i'ce found to put cydia on the phone is to jailbreak with one of these programs....

im sorry im tired.... its a never ending FAIL loop!!! LOL!! plz someone just help me out

scott g