Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Unlocking iPhone to 3.0 Software Problem

  1. #1
    Exclamation Unlocking iPhone to 3.0 Software Problem
    I have recently purchased an unlocked and jailbroken iPhone for T-mobile with the 3.0 software. Unfortunately, after a months use I went to sync the iPhone to my computer and clicked to update the phone without thinking of the consequences. After installation, the phone was returned to its original software and required an AT&T sim card, as my T-Mobile sim was not recognized due to the software update and reboot. Therefore, I was required to re-unlock the phone and now I am stuck with the 2.2.1 software. So my real question is...

    Is there any way I can update my phone's software with an AT&T sim card and then insert my T-Mobile card without having to re-unlock the phone??? Or is there another method that isn't too complicated?

    *Note* My lock button isn't currently working, but I think I'll be able to fix it soon with Electric contact cleaner. So right at the moment I cannot enter DFU (sp?) mode in the unlocking process, so if that is required than I will have to wait a few days.

    Thanks in advance!

  2. #2
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    In order to jailbreak/unlock you must have functional power and home buttons to get the phone into DFU mode. You will have to do your hardware fix first.

  3. The Following User Says Thank You to Poseidon79 For This Useful Post:

    rreulbach (2009-08-18)

  4. #3
    Default iPhone unlock
    Yeah, that's what I figured. So am I right in assuming I can use an AT&T sim card to update the software, and then after that I will have to re-unlock it?

  5. #4
    Quote Originally Posted by rreulbach View Post
    Yeah, that's what I figured. So am I right in assuming I can use an AT&T sim card to update the software, and then after that I will have to re-unlock it?
    you shouldn't need a att card to update, just to authorize (activate).

    Your gonna have to fix your lock button, restore to 3.0.1, jailbreak, then unlock.

    You won't ever need an at&t card, because when you jailbreak with redsn0w, it will hacktivate the phone.

    What i want to know is, how did your phone accidentally update to version 2.2.1, from 3.0?
    The only thing I ask in return for helping, is that you click the thanks button, Thanks!

  6. #5
    Quote Originally Posted by babyblue_pimp View Post
    you shouldn't need a att card to update, just to authorize (activate).

    Your gonna have to fix your lock button, restore to 3.0.1, jailbreak, then unlock.

    You won't ever need an at&t card, because when you jailbreak with redsn0w, it will hacktivate the phone.

    What i want to know is, how did your phone accidentally update to version 2.2.1, from 3.0?
    Well I clicked to update my phone without even thinking about it, and when the phone had installed the software and restored, the iTunes logo and USB cord image appeared on my screen, and my iTunes told me something along the lines of the SIM card being unavailable, and to insert an AT&T SIM card to sync the phone. I then used Pwnage to unlock the phone and it was unlocked to 2.2.1 after losing all of my apps and contacts.

  7. #6
    Quote Originally Posted by rreulbach View Post
    Well I clicked to update my phone without even thinking about it, and when the phone had installed the software and restored, the iTunes logo and USB cord image appeared on my screen, and my iTunes told me something along the lines of the SIM card being unavailable, and to insert an AT&T SIM card to sync the phone. I then used Pwnage to unlock the phone and it was unlocked to 2.2.1 after losing all of my apps and contacts.
    your saying you downgraded your phone to 2.2.1? You must have selected the wrong file while building your ipsw in pwnage.

    theres no way apple would ask you to update, then drop you down to 2.2.1, instead of 3.0.1.

    If you were able to unlock the phone with pwnage, without the lock button (i forgot the procedure), then you should be able to do it again, just be sure to have downloaded the proper 3.0 ipsw for your phone.

    then when you sync to itunes, it should recover your apps and contacts.

    Make sure you downloaded the right .ipsw for your phone, and you aren't using safari to download it.
    The only thing I ask in return for helping, is that you click the thanks button, Thanks!

  8. The Following User Says Thank You to babyblue_pimp For This Useful Post:

    rreulbach (2009-08-19)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •