Results 1 to 19 of 19

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Unlocking never-opened iPhone 2g—where to start?

  1. #1
    Default Unlocking never-opened iPhone 2g—where to start?
    i recently bought an iPhone 2g that was still in the box and in shrink wrap. i want to unlock it to use with T-Mobile, but am a little unclear as to where to start. It seems that i need to upgrade to FW 2.1+ first, and might need to revert to an old iTunes or something. But i can't seem to find anything very clear...especially that uses a Mac. i've found tons of stuff for upgrading to 3.0 from 2.1.1, but nothing clear for what i have. Apparently no one is using such an old iPhone with such old firmware.

    Any ideas? i'm dying to get this thing unlocked. Thanks in advance!

  2. #2
    My iPhone is a Part of Me iGuy's Avatar
    Join Date
    Feb 2008
    Location
    Hampshire, UK
    Posts
    539
    Thanks
    48
    Thanked 63 Times in 58 Posts

    You can go direct to 3.0.

    What OS X are you on? 10.5.6 had a slight problem, but 5.7 & 5.8 are fine.

    Also, what iTunes? Again this will make a difference.

  3. The Following User Says Thank You to iGuy For This Useful Post:

    volkzuki (2009-08-07)

  4. #3
    i'm on 10.5.7 right now with iTunes 8.2.1. i tried to do it (go directly to 3.0) last night using PwnageTool and a tutorial off of iClarified.com, but i kept getting an error when it tried to restore using the custom FW package that PwnageTool created.

  5. #4
    My iPhone is a Part of Me iGuy's Avatar
    Join Date
    Feb 2008
    Location
    Hampshire, UK
    Posts
    539
    Thanks
    48
    Thanked 63 Times in 58 Posts

    Try RedsnOw 0.7.2 or earlier...... 0.8 seems to have a problem.

    Here's iClarified's tutorial..... iClarified - iPhone - How to Unlock/Jailbreak Your iPhone 2G on OS 3.0 Using RedSn0w (Mac)

    ***EDIT***

    The other thing, if you only tried last night iTunes will have directed you to 3.0.1 ipsw. Not a problem in itself, but you need to use 3.0 when using RedsnOw.

    Use 3.0.1 for iTunes, but 3.0 for RedsnOw - hope that makes sense.

    ***2nd EDIT***

    The downloads from iClarified should be fine to use (3.0 ipsw & 0.7 RedsnOw) - just checked.
    Last edited by iGuy; 2009-08-07 at 07:02 PM.

  6. The Following User Says Thank You to iGuy For This Useful Post:

    volkzuki (2009-08-07)

  7. #5
    Quote Originally Posted by iGuy View Post
    Try RedsnOw 0.7.2 or earlier...... 0.8 seems to have a problem.

    Here's iClarified's tutorial..... iClarified - iPhone - How to Unlock/Jailbreak Your iPhone 2G on OS 3.0 Using RedSn0w (Mac)
    Nice. Thanks! i'll try that out. Hopefully it'll do the trick.

  8. #6
    Follow this:

    Instruction on jailbreak and unlock 3.0.1

    First, plug your phone in and let itunes upgrade your phone to 3.0.1. Then visit Dev-Team Blog to download redsn0w (jailbreak program). Also, download (from this site the 3.0 firmware. Make sure you download the proper one. There is one for the 2G, 3G and now 3GS) Then fire up redsn0w. Follow the instructions and you will have a jailbroken iphone.



    Jailbreak steps:
    1- Plug iphone in
    2- Let itunes upgrade it to 3.0.1
    3- Download the 3.0 firmware (from modmyi.com)
    4- Download the redsn0w app (from this site of Dev-Team Blog)
    5- Run redsn0w
    6- When prompted, pick the 3.0 file (not the 3.0.1, they are the same except for the sms fix which is now on your phone)
    8- Check mark the "unlock and Cydia" app.
    9- You will need the 3.9 and 4.6 bootloader files (which you can find on this site)
    10- Close your phone
    11- Put your phone in DFU and let redsn0w jailbreak your phone.
    12- Let it reboot and voilà.

  9. #7
    Quote Originally Posted by iGuy View Post
    The downloads from iClarified should be fine to use (3.0 ipsw & 0.7 RedsnOw) - just checked.
    Looks like i'll have to try this at work. The link for downloading RedsnOw is a torrent, and i can't download torrents from work.

  10. #8
    My iPhone is a Part of Me iGuy's Avatar
    Join Date
    Feb 2008
    Location
    Hampshire, UK
    Posts
    539
    Thanks
    48
    Thanked 63 Times in 58 Posts

    This site has a couple of links to download it from (Megaupload & Rapidshare) if that's any help.

    Apple Forums & iPhone Forums, Mods, Hacks, News, Themes, Downloads, and more! | ModMyi.com - Downloads - RedSn0w 0.7.2 - OS X

  11. #9
    Another big thanks iGuy! Just downloaded it. i'll have to try this a little later this afternoon.

    ***It automerged two posts. The above is before trying. The following is after***

    Ok, so i tried to unlock it using RedsnOw as per the link that iGuy suggested. The first step is to have iTunes restore it to the ipsw file that you download. However, iTunes won't even restore to that ipsw. i get the following error messages:





    The tutorial doesn't mention anything about putting it in DFU mode when having iTunes do this first restore, but my phone is still in DFU mode from last night's attempt. As soon as i connect it to my Mac, iTunes detects "an iPhone in recovery mode". Is this why i can't even get past the first step? It's the same error messages i was getting last night when i was trying to restore with the ipsw that PwnageTool built.

    Any other thoughts? i already appreciate all the help…
    Last edited by volkzuki; 2009-08-07 at 10:54 PM. Reason: Automerged Doublepost

  12. #10
    My iPhone is a Part of Me iGuy's Avatar
    Join Date
    Feb 2008
    Location
    Hampshire, UK
    Posts
    539
    Thanks
    48
    Thanked 63 Times in 58 Posts

    Hmmm. It should Restore direct from iTunes to 3.0.1 when you click on the "Restore" button.

    If it's correctly in DFU mode you should have just a black screen? And iTunes should ask if you want to restore it to factory conditions? This is what you want at the moment.

  13. #11
    Quote Originally Posted by iGuy View Post
    Hmmm. It should Restore direct from iTunes to 3.0.1 when you click on the "Restore" button.
    i just tried it this way (rather than restoring from the ipsw i downloaded) and got the same error messages.

    Quote Originally Posted by iGuy View Post
    If it's correctly in DFU mode you should have just a black screen? And iTunes should ask if you want to restore it to factory conditions? This is what you want at the moment.
    Just a black screen? Hmmm…maybe i don't have it properly in DFU mode, then. Is there a different recovery mode? Mine has the image of the dock connector with an arrow pointing to the iTunes icon. When i connect it to iTunes, it just says that it has detected an iPhone in recovery mode and it must be restored before doing anything. Then whatever i do to try to restore it, i get the same error messages. Do i need to try and get it out of this recovery mode?

  14. #12
    My iPhone is a Part of Me iGuy's Avatar
    Join Date
    Feb 2008
    Location
    Hampshire, UK
    Posts
    539
    Thanks
    48
    Thanked 63 Times in 58 Posts

    Okay, it sounds like the first half is done (iTunes has installed the new FW) so you can forget iTunes for the time being.

    Have you also downloaded 3.0 & the two BL's from the links on the iClarified tutorial?

  15. #13
    Quote Originally Posted by iGuy View Post
    Okay, it sounds like the first half is done (iTunes has installed the new FW) so you can forget iTunes for the time being.

    Have you also downloaded 3.0 & the two BL's from the links on the iClarified tutorial?
    Yes. i guess i can try to finish the guide, but it seems like the first step didn't work.

    i'll try this later this evening after i put the kids to bed.

  16. #14
    My iPhone is a Part of Me iGuy's Avatar
    Join Date
    Feb 2008
    Location
    Hampshire, UK
    Posts
    539
    Thanks
    48
    Thanked 63 Times in 58 Posts

    If you've got the iTunes logo & USB on the phone it has worked so far.

    ***EDIT***

    If you've got 3.0 ipsw and 3.9 & 4.6 Bootloaders downloaded the next step is to start RedSnOw btw.
    Last edited by iGuy; 2009-08-08 at 12:20 AM.

  17. #15
    Quote Originally Posted by iGuy View Post
    If you've got the iTunes logo & USB on the phone it has worked so far.

    ***EDIT***

    If you've got 3.0 ipsw and 3.9 & 4.6 Bootloaders downloaded the next step is to start RedSnOw btw.
    Ok, so i started RedSnOw and got as far as the step where it asks you to plug the iPhone in and turn it off. Before i plug it in, the screen is black. Then when i plug it in, the Apple logo comes up for a second followed by the iTunes logo w/ USB cable. If i hold down the power button like it says, i don't get the slide to turn off screen. Instead, it just flashes off for a second and then starts over with the Apple logo followed by the iTunes and USB.

    The Apple site suggests a bunch of steps even getting as far as creating a new user account and trying to restore from there. i made sure all my software and OS was updated, and did a clean restart on the Mac. Do you think that the problem might be with my Mac or with the iPhone?

  18. #16
    My iPhone is a Part of Me iGuy's Avatar
    Join Date
    Feb 2008
    Location
    Hampshire, UK
    Posts
    539
    Thanks
    48
    Thanked 63 Times in 58 Posts

    Make sure you turn it on before you turn it off (if that makes sense).

    When you have the iTunes logo/USB you need to turn the phone on to "emergency calls only" by using the bottom slider. Then hold down the power button until the top slider appears.

    However, if that isn't happening I'd be tempted to do a fresh "Restore" via iTunes to return to factory conditions, and then start the RedSnOw process again. My thoughts are that you say you tried using the Pwnage tool beforehand. I'm just thinking there maybe a conflict of interests here.

    Another thing I always do is turn off iTunes whilst running RedSnOw. I'm not sure if this make an iota of difference but I feel better inside.

  19. #17
    Ok, sorry for such a delay…but i finally got it to work. After many failed attempts for even the first restore from iTunes. i tried restarting the computer to no avail. Finally i repaired my permissions, restarted, and tried again. Finally it worked! iTunes restored it to 3.0.1, and RedSnOw took care of the unlocking/jailbreaking. So, now i'm good to go.

    Thanks for all the help!

  20. #18
    My iPhone is a Part of Me iGuy's Avatar
    Join Date
    Feb 2008
    Location
    Hampshire, UK
    Posts
    539
    Thanks
    48
    Thanked 63 Times in 58 Posts

    Glad it's worked out all fine for you buddy. Don't forget to come back here and help others though.

  21. #19
    i had a similar issue and it was actually my usb port.try it on a dif computer.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •