Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: help to unlock 2g iphone 3.0 os with final version

  1. #1
    Default help to unlock 2g iphone 3.0 os with final version
    hi i had updated my 2g iphone to final version of 3.0 os which locked my phone which iam unable to use as it does not recognise the carrier any more, can anybody help by providing appropriate details to downgrade and use the my pohone, again when i try to downgrade iam getting the 1604 error pls help

    regards
    ANjum

  2. #2
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    You may wanna wait a couple of days until ultrasn0w is released. This is the unlocking program used for 3.0

  3. #3
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Your phone is still unlocked but it's not activated which is why iTunes is freaking out. Wait until later this afternoon and the jailbreak for 3.0 will be released. Pay attention to the front page.

  4. #4
    so even though you have unlocked 2G phone with 2.2.1, if you upgrade to 3.0, it won't activate it thru itune and making unsuable with other carriers?
    So we have to wait for ultrasn0w to come out?

    I'm getting 3GS (with ATT) and keeping my old 2G which I was using for my primary line to use for my second line and don't want to sign up another 2year, but I would like to get 3.0 on 2G phone.

    iPhone 3GS with w/AT&T
    4.2.1
    Technician
    Smart Cellphone Repair
    www.ifixsmartphone.com
    Ask me all your hardware problem!

  5. #5
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    Quote Originally Posted by todesto View Post
    so even though you have unlocked 2G phone with 2.2.1, if you upgrade to 3.0, it won't activate it thru itune and making unsuable with other carriers?
    So we have to wait for ultrasn0w to come out?

    I'm getting 3GS (with ATT) and keeping my old 2G which I was using for my primary line to use for my second line and don't want to sign up another 2year, but I would like to get 3.0 on 2G phone.
    No, as you can read in all Dev-Team blogs and Cydia, DO NOT update until an unlock for 3.0 comes out (ultrasn0w)

  6. #6
    I have read that ultrasnow is only needed for unlocking 3G iPhones as the baseband is not being updated for the 2G iPhone anymore. However you will need the new version of Quickpwn to jailbreak and activate your 2G iPhone running 3.0.

    I have an unlocked/jailbroken 2G iPhone running 2.2.1 and I want to update to 3.0 using iTunes. It is my understanding that if I do that I will lose the jailbreak and it wont activate. I still have an official o2 sim which I think I can use to activate then switch back to my preferred sim. Can anyone confirm or deny if this will work?

  7. #7
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,207
    Thanks
    5,596
    Thanked 12,544 Times in 7,599 Posts

    Quote Originally Posted by forumbot View Post
    I have read that ultrasnow is only needed for unlocking 3G iPhones as the baseband is not being updated for the 2G iPhone anymore. However you will need the new version of Quickpwn to jailbreak and activate your 2G iPhone running 3.0.

    I have an unlocked/jailbroken 2G iPhone running 2.2.1 and I want to update to 3.0 using iTunes. It is my understanding that if I do that I will lose the jailbreak and it wont activate. I still have an official o2 sim which I think I can use to activate then switch back to my preferred sim. Can anyone confirm or deny if this will work?
    Nope, 2g is good to go. Here's a link that will help yoo

  8. The Following User Says Thank You to Bo Troxell For This Useful Post:

    forumbot (2009-06-18)

  9. #8
    Cheers, that worked perfectly since I had unlocked with Pwnagetool

  10. #9
    Default Hello
    Hello there..
    I have a iPhone 3G running firmware 2.2.1 which I believe was officially unlocked. I upgraded the firmware to version 3.0 from itunes and now my phone does not accept my SIM. Could someone advise the remedy to this ?

    Thanks a million.

  11. #10
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    Quote Originally Posted by dial647 View Post
    Hello there..
    I have a iPhone 3G running firmware 2.2.1 which I believe was officially unlocked. I upgraded the firmware to version 3.0 from itunes and now my phone does not accept my SIM. Could someone advise the remedy to this ?

    Thanks a million.
    Usually I would tell you that the search feature is your friend. But in this case your answer is only a couple of posts above you. The only way to unlock 3.0 is by waiting until tomorrow and using ultrasn0w. Keep looking at the front page for updates.

  12. #11
    Hi..thanks for the post...

    I read that you can only use ultrasn0w on a jailbroke iphone. Mine is not...It currently says, "Emergency calls only" and I cannot go pass this screen to access any phone features.

    Does ultrasn0w suit in this kind of a situation as well ?

    Thanks for your time.

  13. #12
    I(Fido in Canada) used Pwnagetool and was successful: UNLOCKED & JAILBROKEN but some functionality are missing like iTunes (does not display song available), no MMS, no Notification ( in Settings).

    So wait eager funs! wait until they (Pwnagetool developer team) find out and fixed Pwnagetool. That is all I have to say for now. Bye for now and waiting game is not over yet!

  14. #13
    Hope you dont mind me asking this guys but if someone has a locked 2g as above as a result of updating to 3.0,the advice has been to use ultrasnow to unlock it
    But how can they get ultrasnow if its only on cydia which requires a working iphone ?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •