Results 1 to 1 of 1

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3G, yellowsn0w, No Service. HELP!

  1. #1
    Default iPhone 3G, yellowsn0w, No Service. HELP!
    iPhone 3G, Black, 8GB, purchased myself on 7.12.08
    Firmware: 2.2
    Baseband: 2.28.00
    Unlock: soft unlocked via yellowsn0w
    OS: Windows Vista Home Premium

    Here's my story:

    I bought my 3G the day after launch. I got lucky. Worked fine in the United States. I eventually joined the US Air Force and moved here to the UK. I got here, soft unlocked my phone by jailbreaking with QuickPwn 2.2 and 2.2 firmware, to preserve the baseband. I canceled my AT&T contract for free with my military orders, and then purchased a pay as you go SIM from Talk Mobile. Everything worked fine... even used data without trouble.

    After a night in Cambridge, UK, I came home to call my wife and she couldn't hear like every 3rd word I was saying. This became progressively worse throughout the night to the point where my return calls were failing. Eventually I got through again, but she still could not hear me. I tested this with other friends to be sure it was my phone's fault, and indeed it is.

    Nowadays, I can barely get signal. Talk Mobile connects to Vodafone towers. Even when I do get signal, no matter how strong, I can't send text messages or make phone calls. Very rarely (1 out of 100 tries), I can get a text message to send, but that hasn't happened in almost 2 days. Last night, I did receive a text in the middle of the night, so there is some sort of activity.

    I've been wondering if perhaps it is a problem with the radio chip. Every single other feature of the phone works like a charm... bluetooth, wifi, ipod, etc... anything involving calls, texts, or data that isnt wifi is useless. I wondered if perhaps I caused some damage in a drunken stupor after a fun night on the town, but there is no physical damage on my phone that would indicate any serious impact, not to mention, everything else works great.

    Steps I have taken to try to fix the problem:
    Restored
    Re-jailbroken
    Re-unlocked
    Airplane mode on and off numerous times
    Reboot the phone multiple times
    Reset network settings
    Turn 3G on and off multiple times
    Turn data roaming on and off multiple times

    I am at a real loss here...it worked fine, and then stopped out of no where. I restored to the phone's locked form and took it to the Apple store in Cambridge, but they won't help because the phone is American and differs too much from what the "genius" said to me. It's a little difficult calling Apple in the states and sending it off, so I'd like to avoid that route if possible. Not to mention, they're bound to either update it to 2.2.1 or give me a new phone with 2.2.1 on it, thus upgrading the baseband to a version that I can no longer unlock with yellowsn0w.

    Any assistance is greatly appreciated.

    EDIT: quick update... restored, jailbroke, and unlocked again. finally got the phone to activate, pickup the vodafone network on my talk mobile sim, and decided to try to send a text. even at full signal, the text message fails. i also tried a friends actual vodafone SIM (not talkmobile prepaid like mine), and still nothing. signal connected quickly, but still no activity. i'll try another company tomorrow (most people i know have vodafone). i guess i'm totally lost now. please help me!
    Last edited by randall814; 2009-04-14 at 12:27 AM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •