Well im just about stumped on this one. Heres some info, Im unlocking an iphone that was originaly a 1.0.2 OTB (unlocked with anysim) however i was not informed of this by customer , he said he bought it used as is on ebay. And informed me that it was possibly bricked. So I updated it to 1.1.4 and ran Ziphone (2.5, and 2.5c) everything seem to work smoothly wifi youtube etc, however when i pop a sim card into it it reads the network, however theres no bars to 1 bar, and heres the real odd part if i leave it be it randomly shows 3 or 4 bars after about 25 or 30 mins of idleness. However everytime i try to make a call it says Call ended and then sometimes says call failed. I dont know what to do. Ive tried all of my demo lines both Cellular one and Att Both have unlimited everything.

Now for those of you with possible solutions heres what ive already tried.

1. Reset all settings.
2. turn my caller Id on
3. Restore about 10 or so times
4. Tried unlocking with 1.1.3 and 1.1.3 modem
5. Putting my Legit Iphone Att card in to activate
6. Erase the Bootloader and baseband, put in DFU mode then do restores in Itunes.
7. Hotswaping sims (Putting Legit Att card then swaping it with Employee Cingular Card)
8. tried unlocking with ZiPhone 2.5 2.5b and 2.5c
9. Tried Restoring then unlocking with No Sim card Present
10. Tried Restoring then unlocking with Cellular One Sim, as well as Cingular Sim
11. tried Restore, then just Activating and Jailbreaking it, then using IClarified 1.1.4 Unlock Multiple TIMES with and With out sim card


Any help is appreciated.