Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: Sim card not recognized after unlocking

  1. #1
    Default Sim card not recognized after unlocking
    A few weeks ago my iphone crashed so i restarted it and once it started it had problems activating took about 4 minutes but finally worked fine, but when i come to put more music onto it via itunes i come across this message:

    The sim card inserted in this iphone does not appear to be suppored.

    Only compatible sim cards from a supported carrier may be used to activate iphone.
    Please insert the sim card that came with your iphone or visit a supported carriers store to recieve a replacement sim card.


  2. #2
    If you are using a non-AT&T SIM card you must unlock your iPhone. If you are using an AT&T SIM card and you are still getting this message, try a restore
    Last edited by navyfootball94; 2009-03-28 at 10:08 PM.

  3. #3
    ive allready unlocked using yellowsn0w, its being working fine for about a month then i had this problem, the nphone itself is still working fine phone calls SMS etc just when i connect to itunes i encounter this.

    I am using a Orange UK sim.


  4. #4
    Oh i get it. okay I am not sure why this would happen, but then again im an iPhone n00b

  5. #5

  6. #6
    Have your iphone plugged in before running itunes. If you unplug and plug in while running itunes, this tends to happen, atleast to me so I just quit itunes and run it again,

  7. #7
    ive tried plugging in with itunes open, still no luck, also tried running yellowsn0w again and no luck!

  8. #8
    guys please help me on my iphone 3G 2.2.1 firmware of 2.30.03 it is already open but doesn't have any signal.. it says "insert sim card"
    what will i do?? please help me!!

  9. #9
    as far as i know if your iPhone is a 3G on 2.2.1 baseband 2.30. you cant software unlock it and need to use a turbo sim

  10. #10
    You can software unlock provided your 3g iphone has 5.08 bootloader. Anything higher and its down to a Rebel SIM or similar.

  11. #11
    so you can't unlock your phone if you have bootloader 5.09 and baseband 2.30.3 ... but shouldn't you still be able to use att with a valid sim and a restore? When I restore (no jailbreak) and put in my sim it's not recognizing it.. may be the same problem this poster is having ??

  12. #12
    mikeezius any luck getting your sim to recognize? if so what did you end up doing?

  13. #13
    What's Jailbreak?
    Join Date
    Nov 2007
    San DIego, Ca
    Thanked 0 Times in 0 Posts

    I am having a similar problem. I’m on T-Mobile and mistakenly updated to 2.2.1 with 02.30.03 and had to get a turbo SIM in order to unlock to use with T-mobile. Worked great for the last month, but then out of the blue my phone’s dialer would work. I couldn’t dial numbers, only call back via the text message feature, could rec and send texts, just no dialer so I restored my iphone through ITunes. Upon restoral, using the same sim and turbo SIM, is not working flashing from no signal, no sim, searching and at time shows full signal with T-Mobile, but when I try and place a call it immediately fails and reverts back to “no sim”.
    Be great if someone could help. Thanks

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts