Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: No data on unlocked 3g FW 2.2.1

  1. #1
    Green Apple
    Join Date
    Mar 2009
    Location
    Lake Worth, FL
    Posts
    33
    Thanks
    3
    Thanked 1 Time in 1 Post
    Default No data on unlocked 3g FW 2.2.1
    I'm new to the iPhone world, but I'm computer and software savvy. I've also done a lot of research, so I won't waste your time with simple things.

    I have a new 3G fw 2.2.1 baseband 2.30.03. I have a sim chip in order to use tmobile. When I recieved the phone, it had been activated by AT&T but the previous person did a hard restore to remove their data. This gave me an unactivated phone with no SIM.

    I used QckPwn to activate and jailbreak, and I now can use everything except the cell data. The carrier says TMOBILE, but I never see the "E" for the EDGE service. I have two friends who recently did the same thing on identical hardware and worked fine (although I think there's were already activated).

    I've tried setting the APN to every possible site listed in the posts. I've tried to look up the TMobile Hacks and haven't seen anything for 2.2.1. I've tried uninstalling / reinstalling this SIM, both in the iPhone and my original Blackberry to make sure the SIM and network are happy. No luck, I simply can't get cell data. Not having internet on the road is bad, but I cannot get my email which is devastating.

    Does anyone have any ideas? I wil try just about anything, i have a really expensive cell phone right now, when I'd rather have a cool iPhone running lots of apps, and absolutely need access to my email.

    Thanks.

  2. #2
    My best idea would be to sell your current iPhone and buy one you know has the older baseband so you can use Yellowsnow to unlock

    Probably not what you wanted to hear, but I'm sure it'd be a lot easier.

  3. #3
    iPhone? More like MyPhone drtybrd61's Avatar
    Join Date
    Jul 2008
    Location
    SoCal
    Posts
    103
    Thanks
    12
    Thanked 10 Times in 8 Posts

    did you try resetting network settings?
    Mafia Live Family Code: 143 035 642

  4. #4
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Do a reset network settings.. then go into settings, general, network, make sure 3G is off and data roaming is ON. I only have experience with RebelSIM and these have never failed me.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •