Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: questions re 2.2.1 and 2.30.03

  1. #1
    Default questions re 2.2.1 and 2.30.03
    Hey all-- Hope someone can help me because I'm a bit confused. I have an iPhone 3G running 2.2.1 and 2.30.03 baseband. I'd like to unlock it to use in Pakistan, India, etc., later in the year. I understand yellowsn0w doesn't work with 2.30.03, but is there a way around this? Can I download a trusted ipsw that has already been pwned? Or am I out of luck on the unlocking front until the iphone dev team can figure something out.

    By the way, I've always heard that it's illegal for a phone company to refuse to unlock a phone if you call up and ask. I'm willing to buy out the AT&T contract and get it unlocked so I can use it overseas legally but it seems AT&T is determined to make me buy a new phone in India (it's not available in Pakistan.) Why hasn't there been a class-action suit against AT&T or Apple? People sue over scratches on iPods, for heaven's sake, and this seems way more deserving of a suit than that! How does AT&T get away with refusing to unlock the iPhone when they will for other phones?

    Anyway, sorry for the rant. If anyone has any information or advice, I'd be most grateful. Thanks.

  2. #2
    You could purchase a turbo sim to unlock it. Thats your only option.

  3. #3
    Yep, the new baseband cant be changed. When you upgrade to 2.2.1 there is no turning back. The only viable solution is a working sim card. Like the one you can get from here: Unlock iPhone 3G - Instant Unlock any iPhone. Incl 2.2.1
    "Apple a day keeps the doctor away"

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •