Page 4 of 5 FirstFirst ... 2345 LastLast
Results 61 to 80 of 90

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: "different sim detected" error after Quickpwn to 2.1 and unlock at 2.0.2

  1. #61
    Try a fresh itunes restore to 2.2 and then create a custom restore.ipsw using the pwnage tool 2.2.1

  2. #62
    not sure, but what will that do for me?

  3. #63
    Previously Known as A.T MetallicaFan1991's Avatar
    Join Date
    Apr 2008
    Location
    Manchester, UK
    Posts
    1,584
    Thanks
    188
    Thanked 111 Times in 94 Posts

    I restored to 2.2 and ran quickpwn. The patched lockdown DOES NOT work on 2.2, it used to work on 2.1.
    I just get an error in iTunes, the Different Sim Card ... comes up on the iPhone even if I have the original sim in it.

    EDIT: Tried again and iPhones unlocked now
    Last edited by MetallicaFan1991; 2008-12-07 at 11:30 PM.

    MBP 15" 2.66Ghz Core 2 Duo Nvidia 9400M 9600GT 256MB OS X 10.6.4 Windows 7 June 2009
    iPhone 4 August 28th

  4. #64
    Thumbs up Good Work
    Hey thanks bro. It went sweet.
    i have a iphone 2g with 2.2 fw. jailbroken and now its unlocked.
    thanks for the post.

    Hey thanks bro. It went sweet.
    i have a iphone 2g with 2.2 fw. jailbroken and now its unlocked.
    thanks for the post.
    Last edited by an****jo; 2008-12-09 at 04:24 AM. Reason: Automerged Doublepost

  5. #65
    Running the unlock process the first time, I used a canceled ATT sim card that came with the used iPhone I bought. With that sim, after the unlock process, I could get on wifi, but not make calls or get on the 2G network, but at least did not get the sim change error message.

    I then reloaded the phone back to 2.2 original load using iTunes restore.

    I then reran the whole unlock process again, this time using my original active ATT sim, and the iPhone came up fine on ATT (I never registered through iTunes the fact that I had a new (well used but new to me) iPhone. it just worked for voice, wifi and 2G. It seems for whatever reason you need to have a valid registered active sim for the network (e.g., ATT).

    I then went to a physical T-mobile store and they let me do a test, basically swapping out the the sim card from my active ATT card to a t-mobile sim, and it came up on t-mobile with no error message.

    At this point, I did not try short messaging (my guess it would be fine), but the edge connections would not work. I could see t-mobile come up as well as my Edge notification so I was seeing the network fine. I believe this is due to just some configuration business, similar to that I had experienced in China where one thing needed to be changed in my blackberry - but I do not think this is a showstopper at all. I will address that hackery when I am in real need of the data function on a new network.

    So For now, however, I come up on ATT fully and t-mobile (minus the 2G data (I think wifi would be fine...)) without doing anything more than changing the sim cards.
    Last edited by radioman; 2008-12-10 at 02:14 AM. Reason: Additional clarification

  6. #66
    Having same problems. I updated my iphone from 1.4 to 2.2 using itunes. I got the firmware directly from itunes( Apple Website) after that I used quickpwn 2.2 tp jailbrake and unlock. But when I put a different sim card it says Different Sim Card Detected....Helppppppp....

  7. #67
    Damn... is there any way of making this work on FW 2.2??

  8. #68
    Default Got it Working
    Here is the solution to your problems, finally after trial and error:
    Steps followed:

    Got this from this site (This is for the firmware 2.1 I tweak it to fix problem with firmware 2.2)

    1. Use QUICKPWN 2.2 procedure to Jailbreak and Unlock.
    QuickPwn (Windows) Guide

    2. At this point you will still get Different Sim Card Detected Message, that is ok, continue to step 2.

    2. Now you need to remove the previous activation, for that you need to follow the below procedures.

    2.1 Install OpenSSH in you iphone using Cydia (search for OpenSSH)
    2.2 Install WinSCP for Windows (Download http://sourceforge.net/project/downl...irror=internap

    3. Use WinSCP to connect to iPhone
    Google: Windows Guide To Using WinSCP With iPhone http://limitededitioniphone.com/wind...p-with-iphone/

    4. Follow the below steps:

    4.1 Download patched lockdownd file from here
    Google it: RapidShare: http://rs309.rapidshare.com/files/13...9/Lockdown.zip

    4.2 Navigate to to /private/var/root/Library/ and copy lockdown folder to your desktop (for backup just in case - this you need to do)

    4.3 Delete that folder from phone

    4.4 Unzip downloaded lockdown patched file and upload to phone to replace the folder you just deleted

    4.6 Reboot phone

    5. Now, you will see the following message: Insert a new simcard with no code for activation (or something Similar) That is ok.

    6. Run again quickpwn 2.2 jailbrake and unlock and wala your iphone is unlock and you got rid of the message.


    Note: If the above step do not work (it should) restore your iphone to firmware 2.1 and then restore it again to 2.2. Let me know if you need help
    Last edited by xavier20; 2008-12-11 at 03:10 PM. Reason: grammar mistakes

  9. The Following User Says Thank You to xavier20 For This Useful Post:

    gman8966 (2009-01-26)

  10. #69
    Hi
    I got my iphone 3G (v2.0.2) this week and it is locked but I have Sim Card so when I put both my t-mobile card and sim then turn on the iphone I get t-mobile network but my problem is, it's giving me "different sim detected" please connect to iTunes. Please any solution??

  11. #70
    Default Hello
    Did you the fix I posted?

  12. #71
    iPhone? More like MyPhone iMack007's Avatar
    Join Date
    Jul 2008
    Location
    Internet
    Posts
    164
    Thanks
    17
    Thanked 11 Times in 9 Posts

    Quote Originally Posted by xavier20 View Post
    Did you the fix I posted?
    I just did and I must thank you very much. It now works with T-Mobile again and o2 sim card. many thanks.

    Another problem however. I tried to restore my jailbroken iPhone 3G 2.2 back to factory settings via the phone itself via the 'erase all' option under settings (first time doing it this way ) and now my 3G iphone will not reboot in over 2 hours. It seemed to erase for about an hour, but never rebooted back into the O/S. just stuck on apple logo. Any ideas? Desperate right now. was just about to sell it with standard settings now iphone 3G dead.

    Sorted! Had to put the phone I. dFU mode and restore. No problem and thanks again.
    Last edited by iMack007; 2008-12-14 at 08:04 PM.

  13. #72
    iPhone? More like MyPhone ugshotgun's Avatar
    Join Date
    Jan 2008
    Location
    Franklin Louisiana
    Posts
    239
    Thanks
    12
    Thanked 22 Times in 21 Posts

    Works like a charm on my 1st generation iphone running 2.2 jailbroken firmware.



    My Specs:

    1st Generation iPhone 8gb
    2.2 Firmware

  14. #73
    hii everyone
    pls help me
    i get to this point but then get lost pls help
    Navigate to to /private/var/root/Library/ and copy lockdown folder to your desktop (for backup just in case - this you need to do)
    what do i do exactly

  15. #74
    The info the first post worked for me on my new 16gb Iphone(2G) With T-Mobile. Thanks!

  16. #75
    I am having the same problem, Itunes says I have an unsupported SIM. I did notice that if I am not connected to the internet, that it won't say that, but I cannot still use Itunes.
    I tried changing the lockdown file. Still "unsupported sim" in itunes.
    Please help.

  17. #76
    Confirming "Different SIM Detected" issue. Using the LOCKDOWN replacement files for iPhone 2G and 3G WORKS! Both are on firmware 2.2.

    iPhone 2G Jailbreak and Unlock with QuickPwn 2.2
    iPhone 3G Jailbreak with QuickPwn 2.2 and Unlock with Yellowsn0w Method

  18. #77
    This worked perfectly for me, I did it on a friends iphone 2G with FW 2.2. Thanks!

  19. #78
    YOU DA MAN!!! you have no idea how frustrating this has been. Being able to jailbreak and not unlock. Thanks to you and YouTube for the step by step instructions I have UNLOCK! YEAH!!!

  20. #79
    All, for what it is worth, I use a MAC with the iPhone and have been totally unsuccessful in unlocking my iPhone. However, when downloading quickpwn for PC and using other people's PCs to unlock the phones, it has always worked. I chose not to fight the MAC fight on this one. This has been the case for several of the phones at this point, under 2.2, and now under 2.2.1. This is a 1st Gen 8GB. Bear in mind that the MAC process appeared to be executing through completion just great. The phone would just never come up on the foreign SIM, it would just show no signal.

    Good luck!
    Last edited by radioman; 2009-02-16 at 03:07 PM. Reason: Some more info.

  21. #80
    Thanks, I was about to go crazy.

Page 4 of 5 FirstFirst ... 2345 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •