Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Plus Symbol in front of Number?

  1. #1
    Default Plus Symbol in front of Number?
    I've jailbroken and unlocked a couple of 1.1.3 OTB iPhones, but one of my latest ones running T-Mobile has a + in front of the number while receiving calls. None of the other phones running T-Mobile have this "problem". It may be an aesthetic issue, but I'm wondering why it's doing this and how can I fix it? Basically a number shows up as "+1 (xxx) xxx-xxxx".

  2. #2
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,307
    Thanks
    12
    Thanked 562 Times in 483 Posts

    The + indicates its a National (like 800 numbers) or International phone number.
    Get "iPod & iTunes for Dummies", it'll change your life.

  3. #3
    Yeah, but it's a local call. :P

  4. #4
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,307
    Thanks
    12
    Thanked 562 Times in 483 Posts

    Quote Originally Posted by MystikEkoez View Post
    Yeah, but it's a local call. :P
    Now that's odd. Same area code?
    Get "iPod & iTunes for Dummies", it'll change your life.

  5. #5
    Yep. You're as surprised as I was.

  6. #6
    Im bring this post back. I am having the same trouble, I am jailbroken on 3G running 3.1.2 but i basically have "+1 (xxx) xxx-xxxx" when a number shows up when im SMS'g i have an app that reads messages out loud but +1 keeps it from reading the name of contact and reads the number. Is there a way to turn off the + in front of the 1 and just show "1 (xxx) xxx-xxxx"?

    Thanks

  7. #7
    Quote Originally Posted by MystikEkoez View Post
    I've jailbroken and unlocked a couple of 1.1.3 OTB iPhones, but one of my latest ones running T-Mobile has a + in front of the number while receiving calls. None of the other phones running T-Mobile have this "problem". It may be an aesthetic issue, but I'm wondering why it's doing this and how can I fix it? Basically a number shows up as "+1 (xxx) xxx-xxxx".
    Did you check under general settings-international-region format-United States? Also check the under settings-phone-international assist... You can turn it off. That may correct the problem.

    (Please hit the thanks button if this helps)
    Give me some free... Free! Which way is to... Give me some free...

  8. #8
    Quote Originally Posted by elcaptain0069 View Post
    Did you check under general settings-international-region format-United States? Also check the under settings-phone-international assist... You can turn it off. That may correct the problem.

    (Please hit the thanks button if this helps)
    Thanks for reply,
    I had already set those and no luck. international assist is off and my format in united states. Anyother ideas.

    wanted to follow up as i did more looking into it. I found that only my SMS messages are showing the + in front of the number and not when i get a call or contact list. But need to find a way to disable that in SMS
    Last edited by James840a; 2010-07-21 at 01:06 AM. Reason: Automerged Doublepost

  9. #9
    Why is this causing a problem?

  10. #10
    Quote Originally Posted by AussiePaul View Post
    Why is this causing a problem?
    the beta drivesafe.ly software im tring, is having trouble with sms app with the + sign in front of the number and cant read the contact name, only reads the number. Im tring to figure out if its the SMS app or the beta software, and noticed that when i get a call the number shows up with out the + and sms show it.

  11. #11
    All of my entries in my contact list are entered in the +XXXXXXXXXX format. I wonder if this may help?

  12. #12
    Quote Originally Posted by AussiePaul View Post
    All of my entries in my contact list are entered in the +XXXXXXXXXX format. I wonder if this may

    help?
    I don't know about receiving the + on the display but in your contact list using the + is very useful. If you input numbers with the plus and country code it takes care of the dial codes for international travelling eg +1 xxx xxx xxxx knows its a US number and will dial correctly no matter which country you are in +44 xxx xxx etc knows its a UK number and does the same thing.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •