Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Please help!!!!

  1. #1
    Angry Please help!!!!
    Hey guys I need some help real bad I have an iphone with the 2.0 version and I'm trying to downgrade it to 1.1.4 version so I can unlock with iliberty so I can use it with Tmobilecan someone please help a noobie any help is appresiated.

  2. #2
    Ok first of all you need to get ahold of a copy of the 1.1.4 firmware from (best place is the downloads section) plug your phone in, open up itunes then hold the shift key on your keyboard (alt key on mac). Then browse to the 1.1.4 firmware you have downloaded then restore the phone.

    Once restored download a copy of iliberty open the program and tick all the options that are necessary to you (jailbreak, unlock, downgrade baseband) and then run it. Should reboot your phone a few times with lots of white writing after about 5/10 mins your phone should be back up and ready to go.

    Just follow the softwares instructions exactally and you should be fine.

    If you get any problems just let me know

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •