I currently have 1.02 and I want to update it to 1.1.2 and then I would assume that I would need to unlock it after?

Can someone please assist me with the steps?

Thank you!