Results 1 to 14 of 14

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: 1.1.1 "no service" problem

  1. #1
    Default 1.1.1 "no service" problem
    Hi guys,

    have been reading up on a rather nasty problem I have & was wondering if someone on here might be able to help.

    Bought an iphone in Hong Kong over xmas as I was visiting my girlfriend & such like (much nicer than the UK I can tell you!) While I was over there, I tested that my UK Orange sim was working and registered when I put it in the phone, sure enough I could roam and make phone calls (ridiculous costs but hey!) - my friend also tried his Peoples network sim and it all worked out quite fine - the guy in the store went through a full demo of Youtube, maps and all manner of fun so it looked to be unlocked and working, ..

    Or so I thought....!

    Back in the UK, and no matter which sim I drop in (O2/Orange/T-Mobile) I keep on getting a "no service" error, and rather frustrated that for some reason it won't pick up the network (sometimes I get a network list when trying to do a carrier select, sometimes I don't).

    I don't think it's the phone per-se, as I was using it over in HK with full signal in the middle of shopping centres & everything (though the call quality wasn't as nice as my nokia, which is disturbing!), so am starting to think it's the way it's trying to register with the UK networks (Orange/O2 - they're even their partner network for cryinoutloud!).

    Strangely I do sometimes get signal for o2 when it's docked!!!though I can't actually make any calls on it - so something is going on!

    As far as I can tell it's a firmware 1.1.1 phone with modem firmware 04.01.13_G. Think it was bought in the US and shipped over (from the serial number and info from ), it's fully jailbroken though and I can install any third party apps I so wish, though at the moment its' still not picking up any SIM! (I do actually want to make phone calls too )

    I've installed openSSH and all the fun tools that come with it, have been snooping round the iPhone (via puTTY) and I can tell you that lockdownd was last modified on december 27th and is 819328 bytes, most other files were updated Sept - probably useless I know but hey, gives a little history of the phone!!

    I'd really like to use the damn thing! instead of having it as a rather expensive paperweight hoping that someone could help us out on this nasty problem. at the moment though I don't know how it was unlocked, or even what the problem is...

    I'd like to know if there's any way of telling how my phone was unlocked, and if so what are my best chances of using the thing over here, i'm very very impressed with the phone itself, apart from all this hassle and problems!

    Any help would be *Hugely* appreciated!


  2. #2
    Livin the iPhone Life redcard's Avatar
    Join Date
    Oct 2007
    Thanked 204 Times in 184 Posts

    Your post is too long and i am too drunk to make sense of it
    To live, you have to lie

  3. #3
    Well thanks for replying anyway , hopefully someone sober will show up and be able to help!

  4. #4
    Install the MobileFinder under Productivity in Installer. Run it, click on the small apple button on the upper right hand. I hope you will find What unlock App. inside the Trash bin.

    The iphone with "NO SERVICE" 1st your iphone is not unlocked. 2nd the baseband need to be virginized. 3th the most I afraid of suddenly show "NO SERVICE" because the seczone is messed up. Here is the link to fix this problem
    Before doing it, go check the IMEI # in Setting-General-About. Check the IMEI # with the Simcard in and out. Reboot everytime remove the Simcard. If the IMEI# shows 0049000xxxxx even the Simcard is out. Iphone is dead. I mean the phone function can not be fixed. If it shows 01130000705xxxx. Iphone is ok. Follow the link above to fix it.
    Last edited by deedeedee; 2008-01-15 at 02:27 AM. Reason: Automerged Doublepost

  5. #5
    Wow, thanks for the useful info! Ive just been reading up on the nasty information about seczone errors and all that, feel really bad for the guys who've lost their iPhones to the dreaded 0049 errors... thats gotta suck!... Looking into this and am still wondering what the best way to continue is,

    I'm not sure if my baseband is fried... The seczone error is (I think) normally shown up if the IMEI is corrupt (0049xxx), however both the IMEI and ICCID are valid and exactly the same as shown on the back of my iPhone... Is there a way to check if the seczone is ok or messed up? That would be a really useful test to run I think.

    I actually restored my iPhone to 1.1.1 (shift-click, load custom ipsw and restore that way) via iTunes and jailbroke it earlier on, then used anySIM 1.1.1 to unlock it (I dont think this has ever had the 1.02 anySIM which seems to have caused so many problems) ... the *really* bizzare thing is, I dropped an Orange SIM into the phone, and bang.. I had signal and Edge! I could make calls and everything... I was happy .... for about 2 minutes!

    Then I restarted the phone... "no service" came up after a few moments... what the ****!

    I'm going to re-try the jailbreak/unlock process again and see if it happens again and see what happens...

    Anyone have any ideas? This is just bizzare!


  6. #6
    Do you get a pop-up message that says "Network Lost?" My phone was working great in Bahrain, then I went to London for Xmas and I kept getting the "Network Lost" pop-up with my pay as u go Vodafone SIM, even after I came back and put my normal SIM in, I kept getting the pop-up, ANYWAY, then someone suggested I go to Settings--Carrier-- and select automatic, and hey it worked !

    I don't mean to insult u by suggesting such an easy method but it worked for me.
    If I help you out, help me out by clicking the button

  7. #7
    Hey, its no problem! at the moment I'd accept any advice to get the bloody thing working!

    I've played with the carrier selection settings sooo bloody much! - unfortunately it makes no difference! sometimes I get a 'loading...' followed by nothing, other times I can see a few networks (Voda/o2 etc) but can't connect to them ("no service"), it's just wrong!... (Glad it works for someone though ). My Nokia's and Blackberry are all showing full signal so I don't think it's a signal reception issue

    Btw, I've since tried a full restore via iTunes and a 1.1.1 ipsw, jailbroke, and unlocked via anySIM 1.1, still no dice.. damn thing just doesn't want to play ball! Though I still have my IMEI and modem firmware, which is at least a little reassuring!

    I've heard a few people on forums say it's a hardware issue, others say they receive this intermittently, others still say they can make 999/911 calls even though they have "no service"! so I'm perplexed and think there may be a number of reasons for this, I'm hoping its a software issue in my case, perhaps the unlock isn't as resilient as we thought originally (though total kudos to the guys who did this! at least it gives us a fighting chance!)

    I'd like to ask has anyone still received this without using the anySIM unlock? I think it's one of the most popular, but if there's an issue we need to be aware of we need to flag it up and maybe find out why it's happening, also does anyone know of a way to monitor any logs in the unix environment, I don't mind getting dirty and snooping around! I just dont want to do something rash and end up with a brick! - it's a nice paperweight for now though

    Still going to keep on trying, though to be honest I'm thinking of going back to Nokia's, at least I can make a damn call that's what mobiles are there for I think!!


  8. #8
    guys i got the same signal issue problem i tried aver trick in the book but sadly youuuuk back to the same point where i started 'no service' or 'error' while i trying to load manual network.

  9. #9
    Hi guys,

    Ok, I've managed to find something very interesting... I reset and jailbroke my phone, but did not activate or use anySIM 1.1, so essentially it's still carrier locked...

    (By the way, you can reproduce this on 1.1.1 by SSHing to your phone, and navigating to: /Library/Logs/CrashReporter/Baseband. Open up the dial pad on your iphone and enter *#5005*78283# followed by call, then follow the prompts. check the logs that are generated)

    by looking through the baseband log for the phone when inserting an unactivated o2 sim I've observed the following:

    o2 SIM (new sim, not activated - part of the 4 free sims deal).

    10273 sim: This is a new SIM
    10334 evt: Sending event kNewSim (117)
    10357 evt: Sending event kSimStatusChanged (138)
    10357 evt: Sending internal notification kEventSimReady (12) params............
    10359 reg: GsmRegistrationModel: Operation kIdle -> kWaitForAutoReg
    10359 send[reg]: at+creg=2
    10368 evt: Sending event kRegistrationStatusNotification (11)
    10368 evt: Sending internal notification kEventSimInitComplete (13) params............
    10368 evt: Sending internal notification kEventSimRefresh (16) params.............
    10369 sim: Home PLMN is 23410 MCC 234 MNC 10

    I think this is right as 234 is the MCC for UK, and 10 is the MNC for Cellnet/02
    (MCC - Mobile Country Code, MNC - Mobile Network Code)

    10579 reg: GsmRegistrationModel: Operation kWaitForAutoReg -> kIdle
    10588 evt: Sending event kSelectNetworkResult (18)
    10589 recv[call]: OK
    but later on...
    117550 evt: Sending internal notification kEventCallInactive (1) params............
    117551 recv[call]: NO CARRIER
    BUT...after that...

    126727 reg: Signal strength is -103
    126727 evt: Sending event kSignalStrengthNotification (15)
    126732 recv[reg]: +CREG: 2

    126733 evt: Sending event kServiceProviderNameNotification (13)
    126733 evt: Sending event kRegistrationStatusNotification (11)
    126733 evt: Sending event kDataAttachStatusNotification (110)
    126733 evt: Sending event kRegistrationStatusNotification (11)
    126734 recv[call]: +XCALLSTAT: 1,6

    126735 clm: Clearing DTMF queue
    126735 evt: Sending internal notification kEventCallInactive (1) params............
    126735 recv[call]: NO CARRIER
    126845 recv[call]: +CEER: "CC setup error",288,"MM no service"

    One item of note is fsignalStrength=-103 - this is a reading in dB i think, maybe a reading for the network signal strength at my location (this changes if I put an Orange sim in, goes to 113). Anyone shed any light on this?

    I know it's not as much use doing it so far for an unactivated o2 sim, but my next step is an Orange contract sim, THEN i'm looking at running anySIM 1.1 and seeing what I get then.

    At least now we may possibly have a way of getting into the baseband logs and seeing if it's actually hardware of software that's causing the fault... you can generate a dump log of the baseband by typing *#5005*78283# (Thanks to iphone-elite dev team for their damn fine google code pages!). If the signal strength measurement is accurate it might give us a better idea of where the "no service" error comes from


  10. The Following User Says Thank You to KStar For This Useful Post:

    Johnny Crash (2008-01-24)

  11. #10
    Thank you for looking in to it!

    I also have this problem and tried everything i know off and whats here on the forum; did many restoring to 111 & 102 downgr & virginized BBand etc. also upgraded to 113 and via 111 back to 112 but nada..
    So today i opened/removed the backpanel to look for traces of an electrical shortcut: no sign of spots/burning owse. To be sure i isolated the backpanel and put it back together; not very surprising: still the same..

    Maybe a little 'off topic' for this thread but: Did anyone remember if she/he ever dropped the phone, because i did remember later that it dropped through a hole in mij back-pocket on the ground (I.m.h.o. it seemed not to be that serious)
    Few hours later i wanted to make a call and the nc showed up..

    Because a number of people did actually solve it by opening/isolating backpanel, it is a bad idea to put your phone in trouser-pockets. It could easily cause troubles when sitting down, or even better, sit on it.. (like, of course happened to me also;-)

    And one other thing: when it all started it refused to call at once, but when i would turn it off, or when removing/inserting sim, it would sometimes have network for a couple of minutes. After i started down/upgr-show, i never saw a signal again. So I was wondering: can there be any chance that this 'no service'-state of the phone might influence the running proces of anySIM when unlocking? Did anyone ever saw a signal after first restore?

    I also don't exclude a software fault/bug, because ihave seen that there are (sometimes cripped) files, wich stay on your phone, no matter if i had performed my up&dgr-show.
    What i remember it was a pref of Kb(2) applic, nested in the keyboard.plist. Also have seen 3 cases in wich springboard didnt scroll (with more than 16 apps) in 1.1.1 & 1.1.2 Restore/upd did not solve it. With this phones i could easily solve it, bij replacing the

    And last; did you ever checked an app called baseband-info (check the name to be sure)? its in installer somewhere ( It displayys al kinds of info about inserted sim.

    Well, my 'quick reply' got a little out of hand, but if there is only one word that might help someone finding a possible solution, i'll be happy!


    Johnny Crash
    Last edited by Johnny Crash; 2008-01-23 at 11:04 PM.

  12. #11
    Default Solved
    Few days after opening the phone, i did a baseb dwngrade, ran anysim and then it came out that the isolation DID solve my problem.. Hasn't been away for days now!

    Didn't know that you had to run this again, but clearly you have to this when you did a restore/unlock while having this 'no service' (hardware) problem..


    Johnny Crash

  13. #12
    BUMMER; i'm back to 'no service' again after having no single drop for more than a week..
    Its driving me nuts; i ran all virginizing/restoring methods I could find and also opened it another couple of times.

    If ANYONE has come over this problem, PLEASE let me know!!!

    Tia, cheers,

    Johnny Crash

  14. #13
    As a general note, you do not ever want to run anysim multiple times. You do *not* rerun anysim after a restore. It's a one time deal. If you upgrade baseband then you can run it again, but in your case you are going to bork your phone if you keep restoring and running it. The phone will not be carrier locked after a restore if you unlocked it prior to a restore.
    Please do not send me messages here as I never check them. If you need to contact me, send me an email. My contact info is easy to find from inside Cydia.

  15. The Following User Says Thank You to BigBoss For This Useful Post:

    Johnny Crash (2008-02-03)

  16. #14
    Hello, thank you for your effort!! I know that anysim is a 1 time operation, and i never used it twice on the same baseband. But every time i saw a new possible solution, i did a retore/virginize; did that for about 4 times now... (and yes, i red the manuals thouroughly and did it a proper way)

    Because of your status i surely will take advantage of your note about the 'borking', Boss!

    The no service came out of the bleu; worked for months on 1.1.2, did no restore owse, and it just dropped..
    Now it sometimes (rarely) shows up and goes, also when its moveless in the dockstation.. displays correct SIM data including my tel-nr..

    Could it still be a hardware problem?

    T.i.a, cheers,

    Johnny Crash
    Last edited by Johnny Crash; 2008-02-03 at 10:06 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts