The dev team have updated there blog and have posted about the pwnage tool 2.0. They have stated it that this tool will not UNLOCK THE IPHONE 3G's YET. They are still working on the baseband for the new iphone 3g.

iphone Dev Team:

"So, currently (when released) PwnageTool 2.0 will support:-

iPhone (1st Gen) with 2.0 - Activated, Unlocked & Jailbroken, (with support for third party applications).

iPod Touch with 2.0 - Activated & Jailbroken, (with support for third party applications).

iPhone (3G) with 2.0 - Activated, Jailbroken (with support for third party applications)."

Also quoted:

"We’ve made some progress on the baseband unlock of the 3G device, but at this point PwnageTool will not support 3G unlocking or BootNeuter on the 3G device. It is, of course supported on the first generation device with 2.0. We’ll push out an update with 3G support if and when it is completed."

Lucky for the 2nd gen users they can fully use there iphone.

Also Posted here

iPhone World

Hmmm.....