Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Headache causing Iphone 4gb unlocking problems

  1. #1
    Default Headache causing Iphone 4gb unlocking problems
    Ok, so a little background. I acquired a 4gb iPhone a while back with the intention of jailbreaking/unlocking to give to my mom as a Christmas present. However, the phone had been updated with 1.1.2 firmware, and obviously needed a different approach than what I was used to (that being starting with 1.0 or 1.02 phones and upgrading to 1.1.1 and using the no computer jailbreak/unlock)

    As a result of reading the various guides on MMI and other places, the jist was basically to downgrade to 1.1.1 and unlock from there. However, I've been at this for 8 hours and ran into many problems, and at the current rate I'm not going to be able to give this to my mother for christmas (no biggie, but it'd be nice)

    Anyhow, so after downgrading to 1.1.1, I got the usual 1015 error and rebooted the phone with iBrickr. From there, I jail broke/activated the phone with jailbreakme.com and then installed the BSD sub-system, openssh, and anysim via the installer. After running anySim, I get a quick error which goes away too fast, which is then overlapped with "Anysim cannot unlock this phone. Please restart this phone after exiting anySim"

    The error right before that, I think said something about a "secpack" this must be baseband related.

    Anyhow, so I check a few guides on here. One of them says to downgrade to 1.1.1, jailbreak it, oktoprep it and go back to 1.1.2 and then use anysim 1.1.2u to unlock it, and that gave me the same exact error, no luck.

    Another guide claimed to do all of that, but use anysim BEFORE going to 1.1.2. So I did that, same error.

    ANOTHER guide claimed that its possible if the phone had anySim attempted on it before at 1.02, it would need to be downgraded to that and revirginized, and have the baseband also downgraded to 3.X.

    So I immediately put the phone in DFU mode and attempted to Shift-click restore it to 1.0.2, and got ALL kinds of errors. Either it refused to do it, or attempted the restore and threw an error at the last minute, or just got bricked, nothing worked. So I noticed that iBrickr also had support to through the phone into 1.02, I did it through there, and though it launches iTunes for the restore utility, it somehow worked this time. From there, I attempted to downgrade the baseband and revirginize (after activating) using iDemocracy, none of them work and through either a port number error, permissions error, etc. I attempt to upgrade at this point back to 1.1.1 and it fails every single time. I try upgrading back to 1.1.2 and that works fine! So then I attempt to downgrade back to 1.0.2, and even with iBrickr, I get all sorts of failure and tons of errors. Probably on my fifth or sixth try at this point, I finally revert the phone back to 1.0.2. From there I manage to successfully install AppTapp onto the phone, and from there I used the phone to install BSD subsystem and openSSH. After having those install, the baseband downgrader in iDemocracy seems to do a lot of stuff, but has an error at one point towards the end of the script and seems to get so close, but never really changes the baseband. And I just have to restart the phone. Virginizer never works. So I found some sources via Shai's apps (http://ride4.org/shai.xml) and find some packages through installer for baseband downgrading and virginizing on both 1.02 and 1.1.1. Both of these packages failed to install completely while running on 1.02, and later when I upgraded to 1.1.1.

    I started all over and managed to 1.1.1 and attempted anySim again, only to get the same error (cannot unlock on this phone) I don't know why, I've unlocked 3 other iPhones easily before, but I'm stuck at square one on this phone! I've googled endless and now am exhausted from having wasted my Christmas eve on this nonsense. CAN ANYONE elaborate on my situation at all please? maybe as to what I'm doing wrong? Much MUCH thanks in advance.

    ALSO MY SERIAL # IS 5k7471jjvr0

    Is there any known issue with this serial number?
    Last edited by munjal; 2007-12-25 at 07:16 PM.

  2. #2
    IF it is a 1.0.2 phone originally then that is where you must start. Downgrade to 1.0.2 - if the phone is currently 1.1.2 then its a 2 step process - downgrade to 1.1.1 first. get it back to DFU mode then downgrade to 1.0.2. Once it is at 1.0.2 do the whole Jailbreak / Activate / unlock there. I have had to do that a few times on some phones. Once you have the 'phone activated and unlocked THEN do the upgrade to 1.1.1 and then the upgrade to 1.1.2 - I have found the best way is using a MAC and Independence (It has it's own help file built in).
    For a step by Step I found http://iphone.unlock.no to be very good - BUT Please don't skip any steps and think you know what you are doing.
    Just take it slow and be sure you do it right.

  3. The Following User Says Thank You to xserve2 For This Useful Post:

    munjal (2007-12-25)

  4. #3
    I had the same problem with my iPhone, it wouldn't even let me downgrade to 1.0.2 from 1.1.1 when I had errors unlocking! I had the same error with the error "Cannot unlock on this phone. Please restart" from AnySim. I have found an easier method and I am developing a guide, which I will post within a few hours. Hope my guide helps you =).

  5. The Following User Says Thank You to D-TP For This Useful Post:

    munjal (2007-12-25)

  6. #4
    thanks so much you guys! I still have time before presents are opened, will re-attempt now!

    Ok, So I attempted to try Xserve2's method of going to 1.0.2 and using anysim 1.02. I got the error "Firmware already patched, please restart phone"


    ....so now what? Do you happen to have that guide up D-TP ?>

    Ok, so using the tutorials on iunlock.no, I have been on firmware 1.0.2 and have attempted all the virginze and baseband downgrade scripts, I constantly get the "main execution script failed error" and all the other guides cover what I have already attempted....I don't get it, I just don't know where to go from here on out. I think I'll restore to 1.1.2 for now and try to start all over.

    04.02.13_G Is 1.1.2
    I've noticed that even on 1.0.2, this is the baseband I have. So now I am going to update to 1.1.2 and attempt to downgrade my baseband from there, it's clear that this latest baseband is the headache for all my unlocking problems. If anyone can reccommended easy and good BB downgrading software for PCs, it would really help (I get random weird errors in Idemocracy)

    Ok everyone, I've been killing myself on this for the past 30 hours, only to eventually get the guts to SSH in and downgrade teh baseband manually. After many errors and screwing around and googling, I found out that my Iphone 4GB has the 4.6 boot loader and cannot be unlocked. Man, I got screwed (phone was not refurbished by the way, so I dont know how but I guess they made 4GB OTB 1.1.2) and now I will sell the phone off. I guess I could wait for teh new firmware update that everyone claims will fix the problem, but I can buy another one then in the mean time.
    Last edited by munjal; 2007-12-26 at 02:39 AM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •