Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Jailbreak a native and original 1.1.2 with O2

  1. #1
    Default Jailbreak a native and original 1.1.2 with O2
    Hi guys!

    I'm wondering if there is a guide on how to jailbreak so that i can upload installer.app on my iPhone which I bought in UK and legally opened a contract with O2. I just wanna jailbreak it to download installer.app so that i can use more programs, is it possible and is there a guide for it?

    thx!

  2. #2
    Hi, I tried to downgrade before being able to jailbrake my iphone 1.1.2 , working with O2, and I followed the steps introduced on this site, but it stays in O2 and there is nothing possible probably. How can I proceed further now to do the following steps (downgrading, jailbraking and unlocking) to let my iphone work on a mobistar (belgian) network? If I put my belgian simcard, it doesn't recognize it, or do I let the UK sim card in it?Thanks

  3. #3
    Heres my experience of jailbreaking an o2 phone with legit o2 activated iphone contract:

    Findings from jailbreaking a UK o2 activated 1.1.2 iphone, cheers to wrboyce for the support!

    My setup: Windows XP, ITunes 7.5

    What I used:
    ibrickr
    http://cre.ations.net/creation/ibrickr

    conceited jailbreak package
    http://conceitedsoftware.com/iphone/site/112jb.html

    o2 edge/visual voicemail fix from here:
    http://code.google.com/p/iphone-elit.../o2ukJailbreak

    1.1.1 and 1.1.2 iphone firmware restore files (google for them)

    1. In itunes connected phone and held shift & clicked restore - selected 1.1.1 firmware file. Flashed and finished with error 1015. Phone displayed connect to itunes picture.
    2. Got the phone to boot into 1.1.1 with ibrickr using this method:
    * Run iphoneinterface in a Command Prompt window.
    * You should see an "r_recovery" prompt.
    * Enter "setenv auto-boot true", "saveenv", and "fsboot" (each on their one line).
    * Wait for iPhone to reboot -- may take a minute.
    3. My SIM was locked and couldn't activate - removed SIM and PIN unlocked it in another phone. Popped it back in.
    4. Activated phone in itunes. Phone is now on home screen in 1.1.1 Note: No GSM connection at this stage.
    5. Visited jailbreakme.com in safari and attempted to install Installer.app. Didn't work the first time so I had to switch phone off and back on again and retry. Worked this time. Should display progress when its working, before I rebooted it just quit back to home and nothing happened.
    6. Installer now on home screen. Installed OktoPrep (in tweaks)
    7. Ran ITunes shift-clicked *UPDATE* and choose 1.1.2 firmware. Waited. Itunes activates phone.
    8. Running conceited jailbreak - windows.bat. Flashing firmware and installing ssh. Takes a while!
    9. Hrmm looks like it didn't work on home screen and no installer. Turning phone off and on. It worked! Now in 1.1.2 and jailbroken VV and EDGE are broken however.
    10. Used putty to ssh into iphone. Ran the following to get o2 edge and visual voicemail working:
    rm /var/root/Library/Preferences/com.apple.carrier.plist

    cp /System/Library/Frameworks/CoreTelephony.framework/Support/O2_UK.plist /var/root/Library/Preferences/com.apple.carrier.plist

    rm -f /var/root/Library/Preferences/SystemConfiguration/preferences.plist

    ******************

    Phone is fully functional in 1.1.2 with visual voicemail confirmed working and GPRS/EDGE work no problem

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •