Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: Problem unlocking sim!

  1. #1
    Angry Problem unlocking sim!
    Hello everybody!

    Maybe somebody out there can give me a step-to-step tut on how to fix my iphone problem.

    Let me give you a breakdown of the problem:
    I bought an iphone (unlocked and jail broken and running fw v1..1.1). I accidentally (foolish me) upgraded to version 1.1.2 and my sim became locked! I managed to restore it first back to 1.1.1 and ran anysim (i was able to activate it with iNdependence and also with iDemocracy) but sim still remain locked (i am in europe but the phone was bought and sent to me from home and still have the at&a card which was used to activate and unlock.) i tried tried iphonefree sim, same problem. Then i downgraded to 1.0.2, activated and ran anysim again. Same problem, saying it cant be unlocked! I tried also iphone freesim, no success.

    I did a new restore, to 1.1.1. and back to 1.0.2 (so far i have left it on 1.0.2 and have not tried to activate it again). I am not quite sure if the unlocking is not working because the simcard (at&&) have been used to unlocked it before or because i accidentally left the simcard in the phone when i ran anysim and iphone freesim. Or i ave to revirginized it again? Everything worked fien except the sim unlock.

    Another thing is that when i am on fw v1.0.2, the WLAN detects other wireless network in my neighborhood but not mine. Even when i tried to use the open network, it comes back with an error that it cannot connect. But the WLAN work in 1.1.1.

    Please i need somebody to help me and give a step-by step instructions.

    Thanks in advance

  2. #2
    Livin the iPhone Life redcard's Avatar
    Join Date
    Oct 2007
    Thanked 204 Times in 184 Posts

    Follow this guide here.

    So, basically, you need to do this -

    1. RESTORE iPhone to 1.1.2 (to get the new baseband installed)
    2. RESTORE iPhone to 1.0.2 (will not downgrade the baseband, requires DFU!)
    3. Jailbreak, activate, install and run anySIM 1.2(.1u) – after running it you should be able to make calls on 1.0.2!
    4. RESTORE iPhone to 1.1.1
    5. Use the method (see links in the 1.1.1 section!) to jailbreak and activate 1.1.1.
    6. Use to install OktoPrep (from the Tweaks 1.1.1 menu) (IMPORTANT)
    7. UPGRADE (not RESTORE) to 1.1.2.
    8. Install a patched lockdownd to activate your iPhone (see below).

  3. The Following User Says Thank You to redcard For This Useful Post:

    Nextasy (2007-11-20)

  4. #3
    Thanks for the help. After a 3 days searching and trying i finally got it working by following the tut


Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts