Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Replaced logic board - now get the 'approved SIM needed' message

  1. #1
    Default Replaced logic board - now get the 'approved SIM needed' message
    A few weeks ago I dropped my iPhone into some water. Previously it had been running 1.0.2 and unlocked/jailbreaked via iNdependence 1.2.1. I sent the phone into iResQ, and they replaced the logic board. Try as I might, and despite iNdependence 1.2.5 saying the phone is activated, I can't get my T-Mobile SIM card to work. I can still get into the phone, and Wifi works. I've read all sorts of stuff about revirginizing and baseboard this and that, but I'm a little confused. I'm not sure what happened to my 'new' logic board before I got it, which probably doesn't help. I'd like to just start over as if the phone was brand new. Any ideas? Or if that is not what is needed, what would you recommend? Thanks.

    Nate

  2. #2
    sounds like you just need to unlock the new logic board

  3. #3
    Well I thought that's what I was doing by using iNdependence. Or is that something different?

  4. #4
    Retired Moderator DoerrFan's Avatar
    Join Date
    Jul 2007
    Location
    Boston
    Posts
    2,290
    Thanks
    143
    Thanked 461 Times in 229 Posts

    Quote Originally Posted by windsor_gti View Post
    Well I thought that's what I was doing by using iNdependence. Or is that something different?
    Activation is just bypassing having to activate AT&T to use some features, calls cannot be made without an AT&T activated SIM.
    Unlocking is allowing the phone to run on any carrier, such as your T-Mobile.

  5. #5
    Oh that's right, all the cyberduck and lockdownd and what not. That totally slipped my mind.

    I was looking through my bookmarks, and found this section of the website: http://modmyi.com/wiki/index.php/IPh...ck_OS_X_Part_1 Now, last time I did this it worked fine. This time, however, I'm getting an error message while using apptapp. I get 'Bootstrap failed, see console log!'. I downloaded the iTunes 7.4 DMG, and installed it, as the step 3 directions say. I got the same results though. The only thing weird that I noticed was during the install of iTunes, it didn't install the iTunes Phone Driver. If I need that can I get it from the iTunes 7.4.2 DMG?

    Edit: Looks like I can't install the Phone Driver from 7.4.2 either. Hmmmm.

    Edit 2: I also downloaded the newest version of AppTapp, 3.1, but that gave me the same error. A different thread mentioned syncing with 7.4.2, restoring in 7.4.1, running AppTapp, and resyncing with 7.4.2 to get all my info back. Guess I'll try that next.
    Last edited by windsor_gti; 2007-11-11 at 12:37 AM.

  6. #6
    i think you are trying way to hard

  7. #7
    Well it's either try hard or be stuck with my back-up phone, a Nokia 3595. So really I have no choice

  8. #8
    I got it! I used my parent's Mini, which was still at iTunes version 7.4.2. I forgot to mention that I installed iTunes 7.5 on my main Mac, which was stupid and probably the cause of my problems. After that it was a breeze to get everything going. Now I just have to read up on 1.1.1. Thanks for all the help, it really helped get me back on track.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •