Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Different SIM Detected Error

  1. #1
    Default Different SIM Detected Error
    Sorry for the repeat of the post but it seems a lot of people have the same problem as I have so I thought I'll start a clean thread trying to track the problem.

    These are the steps that I followed:

    1. I bought a 1.0.2 iphone, never messed with it.
    2. I upgraded it to 1.1.1 using iTunes when the SW came out
    3. I used the latest (as of 11/5/07) jailbreakme.com to jailbreak it which also installed the installer on the phone as well as the community sources. My phone was already unlocked via iTunes and ATT's SIM so the jailbreak didn't mess with the activation and everything continued to work fine with the addition that I can add third party apps.
    4. I added the BSD Subsystem via the installer
    5. I added the unlocking tools to the Installer sources from http://i.unlock.no which gave me the AnySIM 1.1 and OneSIM 1.1
    6. I replaced the SIM with a T-Mobile SIM card and restarted the phone. I got an error that the SIM is not valid but I was allowed to proceed.
    7. I didn't see a "NO SERVICE" text but rather 1 small bar with no provider info
    8. I ran AnySIM and it completed the process with success. However the T-Mobile card was still not recognized.
    9. I restarted the phone and I got the "Different SIM detected" message.
    10. I put the old ATT sim in the phone after and restarted the phone and that works fine, I can use all features of the iPhone.
    11. I read on another forum that restoring the device with 1.1.1 could help in my situation so I did that.
    12. I followed steps 3-5 again.
    13. I used OneSIM with my ATT SIM in the phone and it completed with success.
    14. I replaced the SIM with my T-Mobile SIM and again I didn't see a "NO SERVICE" text but rather 1 small bar with no provider info.
    15. I ran AnySIM again which completed with success but yet the T-Mobile SIM is still not recognized and I am back to step 9.

    I've tried the above several times with no luck. Then I use OneSIM and then restored it with iTunes but disconnected it before it got activated. I tried to use http://jailbreak.com again as described in many posts online starting with the activation screen but AppSnapp wouldn't do anything. I activated the phone via iTunes and the phone wasn't jailbroken, so I just left it alone and trying to compare notes with others.

    It seems that something with the AnySIM or the AppSnapp process doesn't work for all iPhones. Hopefully someone will figure out what's going on.

    Environment:
    WinXP, iTunes 7.4.3.1, iPhone version 1.1.1 (3A109a), iPhone Modem Firmware (04.01.13_G). My phone was not connected to iTunes or to my computer at all during this process.

    If anyone has had the same problem and resolved it please provide details.

    Thx

  2. #2
    Having the same problem here. Re-virginized & updated iPhone. Any clues so far?

  3. #3
    lockdownd?

  4. #4
    Yeah, lockdownd seems to have something to do with it. Apparently the phone has to be activated and used on the same SIM. Do you know how to successfully patch the file to "factory activation" under 1.1.1.?

    iTunes 7.5 also throws an error when the non-AT&T SIM is connected, will that disappear with the patched lockdownd?

    Cheers, S

  5. #5
    Dunno the answers to your question. I'm running three different SIM cards on mine. Two T-mobiles and one local carier. Never had a problem with the phone ******** about different SIM cards. I do make it a point to turn the phone off when I swap SIM cars, but that's just an old habit.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •