Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: An unknown error occurred (1604)

  1. #1
    Default An unknown error occurred (1604)
    We really need a technical support section here on ModMyI.com
    Someone please sticky this post somewhere because I was stuck on this problem for a million years and here's the solution for the (1604) error.

    Quote Originally Posted by Trent J. View Post
    I have a fix for the Unknown Error (1604)
    Let me go grab the guide I made real quick..

    This is a fix if you get a Unknown Error (1604) screen.
    • Turn off the iPhone and pull the chord from the computer
    • Uninstall iTunes 7.4
    • Re-Install iTunes
    • Restart your computer if prompted
    • Pull the SIM card out of the top of the iphone (Instructional Video)
    • Get the Yellow Triangle of Death or The Cable to iTunes screen[Hold the home and power buttons for max 30 seconds]
    • Plug in your phone and open iTunes
    • Hit Restore(It should be working by now...)
    • Re-insert your SIM card into your iPhone.
    • Re-activate your iPhone.
    • Restore your data from your latest update


    Now your done! This will have you at 1.1.1 and if you want to downgrade follow the guide found HERE

    -- Trent J. from YourCustomiPhone.com

  2. The Following User Says Thank You to x0bry7x For This Useful Post:

    BigMacManny (2008-07-22)

  3. #2
    thanks i will try it as soon as i find instalation file

  4. #3
    Default Thanks
    Dude you are a genius! I have been trying to figure this out for about 2 hours now, I know that isn't a long time but I tried 3 other forums and they were of no help. I tried your steps and it fixed the problem right away. Thanks for saving me all that time and effort (not to mention saving me from launching my touch across the house!)

  5. #4
    does this work for 2.0 firmware 1604 error? iphone first gen. used on att.
    IpodLover77 @ Hofo

  6. #5
    Quote Originally Posted by ipodlover77 View Post
    does this work for 2.0 firmware 1604 error? iphone first gen. used on att.
    i tried to uninstall itunes 8.0 and reinstall itunes 7.7 on my computer.
    and try to restore on my iphone 3G firmware 2.0.1 using winpwn custom firmware to 2.0.2 and it worked like charm.



    Thanks.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •