Page 2 of 2 FirstFirst 12
Results 21 to 33 of 33

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Fix for the reappearing "No Service" in the status bar with T-Mobile iPhone 4

  1. #21
    I did this on Thursday and it's worked so far (keep in mind it did this every hour or so before)
    Quote Originally Posted by utbigred View Post
    @at op or anyone with this knowledge. How long has this fix lasted? By lasted I mean when's the last time you dealt with the no service issue. I keep praying everyday it'll last through the day or even for 12 hours but "no service" keeps popping up at random (sometimes it doesnt appear for like 6 hours or sometimes it doesnt appear for 24 hours)

    Normally I dont mind doing the whole reset (on/off) but it's becoming a daily occurrence and it's starting to get to me.

    Been trying to look for a more permanent or a longer lasting solution but every research I've done comes to the same "oh turn off/on ur phone" "take sim card out and put back in" " reset network blah blah" and none of it has worked. Not to mention most of these "issues" were with older versions and dated back between 2008-2010. I rarely came up on searches where it was posted recently.



    When you mean off did you mean through settings->general->network and their enable 3g was on?
    Tmobiles network blows so that could be it also did you check the entire white list?
    When you open an app that is "on" on the white list you're going to get the no service
    Quote Originally Posted by utbigred View Post
    Quick update. This app is not a permanent solution. Since my last post, I had two no service messages. I'm nearly at the end of the rope and not sure what to do. I might just trade my iphone 4 in for a iphone 3g. This is getting beyond ridiculous.
    All of the apps are NOT white listed!!! Lol opening a white listed app will cause the no service to show up
    Also a reboot the settings is always recommended
    Quote Originally Posted by i.Annie View Post
    I don't know what the app is, but reading over the instructions, yes the auto3g app should be enabled. And within it you set everything to default to EDGE and assure that all apps are whitelisted for those settings.
    Last edited by Themacnazi; 2011-08-28 at 09:58 AM.

  2. #22
    Quote Originally Posted by Themacnazi View Post
    I did this on Thursday and it's worked so far (keep in mind it did this every hour or so before)


    Tmobiles network blows so that could be it also did you check the entire white list?
    When you open an app that is "on" on the white list you're going to get the no service


    All of the apps are NOT white listed!!! Lol opening a white listed app will cause the no service to show up
    Also a reboot the settings is always recommended
    Yup did everything you said. Could it just be coincidence that after reboot, it was working again?

  3. #23
    Have u tried a new sim card?
    Last edited by BenderRodriguez; 2011-08-28 at 03:59 PM.

  4. #24
    Quote Originally Posted by BenderRodriguez View Post
    While I have not read the above posts I would suggest possible a new sim card, this one could be used, old and/or worn-out
    I'm beginning to think it might be that issue but the problem is when I got the sim card I saw it being taken off the shelf and popped out of the card(? well the thing it was connected to). Is it possible that this new sim card can be defective or is it because when put with the getty, it seemed fairly loose when I popped my card out of phone hence the stability issue (possibly not cut properly)?

    As for the defective inquiry, my phone was fine for like 2 weeks straight then all of a sudden (starting sometimes last week) i started getting no service issue on a daily base.

  5. #25
    Why not just take it to apple and complain and get a free replacement?

    Or r u out of your warranty?
    I have an iPhone4 jb on AT&T running 4.3.3 and it works fine

    Quote Originally Posted by utbigred View Post
    I'm beginning to think it might be that issue but the problem is when I got the sim card I saw it being taken off the shelf and popped out of the card(? well the thing it was connected to). Is it possible that this new sim card can be defective or is it because when put with the getty, it seemed fairly loose when I popped my card out of phone hence the stability issue (possibly not cut properly)?

    As for the defective inquiry, my phone was fine for like 2 weeks straight then all of a sudden (starting sometimes last week) i started getting no service issue on a daily base.
    Have you tried cleaning out where the sim card goes in or looking for gunk in there?

  6. #26
    Quote Originally Posted by BenderRodriguez View Post
    Why not just take it to apple and complain and get a free replacement?

    Or r u out of your warranty?
    I have an iPhone4 jb on AT&T running 4.3.3 and it works fine



    Have you tried cleaning out where the sim card goes in or looking for gunk in there?
    Well I bought it from a store that sells phones and services, not exactly an apple store so im not sure i can do that? Ya I looked at the sim card and made sure it was clean or at least it looked clean.

    I tried the method again and it was weird this time. Almost instant service and internet (had trouble getting the edge symbol showing). Just seeing how long this will last.

  7. #27
    To be honest I never revolted mine I jusT thought it would be the prudent thing to do so I put it in the tutorial

    My sim is about a year old and I've heard really old sims causing problems so that might be it

  8. #28
    Quote Originally Posted by Themacnazi View Post
    To be honest I never revolted mine I jusT thought it would be the prudent thing to do so I put it in the tutorial

    My sim is about a year old and I've heard really old sims causing problems so that might be it
    Ya but I've only had this phone for almost a month =\

  9. #29
    Quote Originally Posted by utbigred View Post
    Ya but I've only had this phone for almost a month =\
    Its an apple product, all apple products are registered upon purchase if they are new no matter where u buy it at from a cell phone store to Walmart there is a 1 year warranty from the time u but it, this also applies to headphones, iPods, computers, all apple products


    EDIT*

    U should NOT need a receipt because Apple can just use the Serial Number in Settings for the purchase date

    You can also check the status of your warranty ONLINE buy entering in your Serial Number
    Last edited by BenderRodriguez; 2011-08-28 at 06:09 PM.

  10. #30
    Quote Originally Posted by BenderRodriguez View Post
    Its an apple product, all apple products are registered upon purchase if they are new no matter where u buy it at from a cell phone store to Walmart there is a 1 year warranty from the time u but it, this also applies to headphones, iPods, computers, all apple products



    EDIT*

    U should NOT need a receipt because Apple can just use the Serial Number in Settings for the purchase date

    You can also check the status of your warranty ONLINE buy entering in your Serial Number
    Thanks I appreciate the info as well as the help from everybody. Didn't mean to hijack the thread in a way but I'm not really used to this. I'm the type who just needs a phone but when the opportunity came, I got the iphone. I just never expected to have to research so much especially dealing with another provider/jailbreaking/unlocking/getty/ etc.

    One thing I like to add though is that I went back to try this method again. Weird thing is after I rebooted, both my service and internet came up very quickly. It came at a surprise but I dont want to believe too much into this method and realize it was didnt fix the problem. So until the next no service message again, I'll just wait and see before I head back to the store and possibly get another sim card...or a phone.

  11. #31
    Update: After one day, back to no service. I'm going back to the store whenever I have time to.

  12. #32
    Setup an appointment over the phone first, else they will make u setup a time to come back to in the store

  13. #33
    It appears my fix only works for me hahaha
    I apologize for any hopes I have brought up all I k ow is that after this my phone hasnt done the no service thing once and it's been almost a week

Page 2 of 2 FirstFirst 12
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •