Results 1 to 20 of 20

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Tmobile 8.0 iPhone 4 4.1

  1. #1
    Default Tmobile 8.0 iPhone 4 4.1
    Hey guys, well i was screwing around with the tmobile bundles and mms fixes and after awhile I somehow ended up having my carrier be T-Mobile 8.0. This would be good news, however, my apn editing tab has disappeared and will not show again no matter how many times I try to take out and insert my sim card. I also tried to install the TetherMe APN editor, apn editing BB, and supreme preferences 3.0 and none of them is working. Any ideas?

    EDIT: Here's the T-Mobile info
    Attached Thumbnails Attached Thumbnails -photo.png  
    Last edited by vlad9d; 2010-10-25 at 02:12 AM.

  2. #2
    Mine says 8.0, what would be the difference?

  3. #3
    Quote Originally Posted by Formula View Post
    Mine says 8.0, what would be the difference?
    Yours is probably AT&T 8.0. For tmobile, it just suppose to say carrier 8.0 (7.0 for <4.1), because Tmobile USA is not an official carrier so it uses the "unknown" carrier bundle. I guess all u can do is fix ur carrier bundles back to how it was, u might modified the wrong file by mistake

  4. #4
    I didn't modify and I'm on Tmobile. My iPhone 4 is factory unlocked.

  5. #5
    Oh I see, so I guess "carrier" only shows up for software unlocked iPhones. Does that mean that factory unlocked iPhones have a tmobile USA carrier bundle?

  6. #6
    Not sure, my internet works fine but incoming pic through mms still have the file size error. Outgoing works but I can't seem to fix the mms problem. Tmobile wont help when it isn't their phone.

  7. #7
    iPhoneaholic dotFIVE's Avatar
    Join Date
    Sep 2010
    Location
    California
    Posts
    494
    Thanks
    9
    Thanked 82 Times in 79 Posts

    Use one of the supplied carrier bundles located in the stickied thread of the T-Mobile forum. One specified for 4.1. Also, prior to this, make sure you install the CommCenter Patch. After applying these and rebooting your phone and you still cannot edit your APN in settings, then SSH into your phone (or use iFile), go to var, mobile, library, carrier.bundles and edit the carrier.plist. Add this under at the top:

    < key > AllowEDGEEditing < /key >
    < true/ >
    Remove the spaces, as without them, on this forum, the code will not show up.

    Save the newly edited file and then reboot your phone. You will now be able to edit your APN in the network settings menu.

    I'm on T-Mobile 8.0 as well with everything working, including APN editing.


    Sent from my iPhone using ModMyi

  8. #8
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    Nashville, TN
    Posts
    232
    Thanks
    7
    Thanked 14 Times in 14 Posts

    As far as I know tmobile 8.0 is what it says when you upload one of spookyET's carrier bundles. If you did that you shouldn't have to install anything other than the commcenter patch already mentioned. It may be other patches that you have downloaded that are screwing with your setup, or you may have uploaded the wrong bundle. Make sure your data works before installing the bundle, check the apn, then upload the appropriate one.

  9. #9
    What exactly is the point of this bundle? I have mms and Internet working with tmobile already, would I gain anything by getting these bundles or are they just another way to fix mms and Internet?

  10. #10
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    Nashville, TN
    Posts
    232
    Thanks
    7
    Thanked 14 Times in 14 Posts

    It just turns on mms tethering and data. If its already working you don't need it. I use it because I couldn't get mms to work on 4.0.1 no matter what I tried. The new bundle worked on 4.1 with the commcenter patch, and it's flawless. Once you get something working just stick with it

  11. #11
    i seem to be having issues installing the commpatch, i tried using both ifile and installing it from a cydia source... every time it has an error saying it was only half-installed

  12. #12
    I don't have any bundles on it. It's factory and on 4.1, guess it just is @ 8.0 by default.

  13. #13
    What's Jailbreak?
    Join Date
    Nov 2010
    Location
    Painesville, Ohio
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post
    Well, for me, all of a sudden, I lost service with T-Mobile... I spent hours to figure out what happened, no luck. My Network shows "Not Available" and the Carrier shows "Carrier 8.0". I know that before, T-Mobile was showing but don't recall in which field exactly. But the thing is that I have no service any longer while I have no issues with T-Mobile. The icon showing the bars disappears and to make it reappear, I have to turn the Plane mode on and off but still, no service anywhere.
    I have an unlocked and Jailbroken iPhone 4 running 4.1 for 1 month now, and until yesterday, I had no issues with the phone. Did I do something wrong with a Cydia application? Is it possible to mess up something with a Cydia application? Help will be very highly appreciated.

  14. #14
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    Nashville, TN
    Posts
    232
    Thanks
    7
    Thanked 14 Times in 14 Posts

    I've had the same issue but oddly it's everytime I go to a specific area. I think it happens when switching towers. Here's how I fix mine. Go to general settings, reset, and reset your network settings. After it reboots you should have service again but you'll need to remove and reinsert your sim to get mms working again if it works for you. Just did this and all is back to normal.

  15. #15
    What's Jailbreak?
    Join Date
    Nov 2010
    Location
    Painesville, Ohio
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post
    ThaNatrix, Thank you for your quick and useful response. In fact, yesterday, when I called T-Mobile, it is exactly what I had to do. But no luck as I still had the problem. Tonight, I did it again but first time, no luck either. I had to take off the sim card off and on about 2 times in a row and now, I have service and 3 bars. Do you know by any chance why it does that? I hope I won't have to do that often because my iphone is in an armor/case that is a real pain in the butt to take off and put back... But thank you for this tip as I forgot about it! Now it is working great and hopefully, it will be ok for a while.

  16. #16
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    Nashville, TN
    Posts
    232
    Thanks
    7
    Thanked 14 Times in 14 Posts

    Like I said, the best I can figure is that I'm switching tmobile towers as it only occurs in one place...a Best Buy about 25 minutes away. If I go there it screws up, if I don't its fine. If I'm right hopefully you don't live in a tweener place where you're continuously switching towers. I'm hoping 4.2 and the accompanying Ultrasn0w will perhaps help with this issue. Oh...tmobile has also recently switched their plans, so it is possible that is affecting network coverage. I've had some other friends (I maintain about 30 iphones) mention that they've sporadically lost all services (voice and data) for a while. Hopefully it will be resolved whatever it is.

  17. #17
    What's Jailbreak?
    Join Date
    Nov 2010
    Location
    Painesville, Ohio
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post
    First of all, I am glad I am talking to a professional, to someone who knows what's going on! In my case, I have not switching t-mo towers as far as I know but I live on the edge of the Lake and my reception has always been sporadic. But I usually have signal as soon as I am out of my condo and for 2 days, I had NONE wherever I go within a few miles from the Lake. Well, I am glad my issue does not come from me but from T-Mo plans I guess. I do hope as well that the new iOS and UltraSn0w will fix that problem as well. Thank you again for your great support.

  18. #18
    I have an iPhone 4 32GB on T-Mobile. I updated to 4.1 using TinyUmbrella to preserve the baseband, and I have run into the same issues you've mentioned. (Losing service and/or data randomly) I just respring until it finds service, I've read it could be due to 3G being enabled because T-Mobile only supports EDGE, so annoying. So I've left my 3G off, it's only been a couple days, but it hasn't happened to me since...

  19. #19
    Quote Originally Posted by iFlo View Post
    Well, for me, all of a sudden, I lost service with T-Mobile... I spent hours to figure out what happened, no luck. My Network shows "Not Available" and the Carrier shows "Carrier 8.0". I know that before, T-Mobile was showing but don't recall in which field exactly. But the thing is that I have no service any longer while I have no issues with T-Mobile. The icon showing the bars disappears and to make it reappear, I have to turn the Plane mode on and off but still, no service anywhere.
    I have an unlocked and Jailbroken iPhone 4 running 4.1 for 1 month now, and until yesterday, I had no issues with the phone. Did I do something wrong with a Cydia application? Is it possible to mess up something with a Cydia application? Help will be very highly appreciated.

    I'm having the same problem. I tried resetting my network settings and removing and inserting my SIM card, but my phone keeps saying "Searching..." instead of T-Mobile.

  20. #20
    Just remove the SIM card, remove the UNLOCK (ultrasn0w) and then install ultrasn0w again. I have this problem daily and reverse back to 3GS for now.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •