Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: No cellular data tab to fix MMS

  1. #1
    Default No cellular data tab to fix MMS
    Hey guys i have a jailbroken and unlocked iphone 4 on 4.0.2. My cellular data tab isnt there so i cant edit it to add the mms apn settings. How can i get it to show up??

  2. #2
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,207
    Thanks
    5,599
    Thanked 12,544 Times in 7,599 Posts


  3. #3
    Quote Originally Posted by Ivel View Post
    Hey guys i have a jailbroken and unlocked iphone 4 on 4.0.2. My cellular data tab isnt there so i cant edit it to add the mms apn settings. How can i get it to show up??
    Pop your sim out and put it in again. Cellular data tab will show. have fun!

  4. #4
    doesnt work

    What im looking for is the button that lets you Edit the information, cause I need to add APN settings to enable MMS
    Last edited by Ivel; 2010-10-18 at 10:39 PM. Reason: Automerged Doublepost

  5. #5
    Did you install the APN editing from the BigBoss repo? Make sure you read the instructions first, to make sure it covers for your device.

  6. #6
    I just did it, and it doesn't work Cellular Data tab is still not showing up

  7. #7
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    seattle
    Posts
    113
    Thanks
    2
    Thanked 8 Times in 8 Posts

    Quote Originally Posted by Ivel View Post
    I just did it, and it doesn't work Cellular Data tab is still not showing up
    you can use (supreme Preferences 3.0)

  8. #8
    or get TetherMe and TetherMe APN Editing combo.
    This will show yuo the cellular data tab, even on 4.1

  9. #9
    Tether me costs money! How can I get Supreme Preferences?

    Supreme preferences worked!!! Thanks!
    Last edited by Ivel; 2010-10-19 at 10:41 PM. Reason: Automerged Doublepost

  10. #10
    Nevermind. It opens cellular data editing but when i send a mms its just doesnt send. It show that symbol as if i have no servicr

    Hey guys so I have the cellular data tab now and I put the info for MMS, but its still not sending. Why????
    Last edited by Ivel; 2010-10-21 at 01:44 AM. Reason: Automerged Doublepost

  11. #11
    iPhone? More like MyPhone Rinnycoop121's Avatar
    Join Date
    May 2008
    Location
    Texas
    Posts
    278
    Thanks
    26
    Thanked 24 Times in 18 Posts

    can't post the repo here on Modmyi. but do a search on google.com and look for Supreme Preferences iPhone Repo,

    You will need to go into Cydia and add the Repo into your sources.

    Upon installing Supreme Preferences, you will get the option to add Cellular Data Editing, and it will show up.

    After installing Supreme Preferences you need to goto Winterboard to Enable the use of it.


    Use Extreme Caution when using this app, do not use it for anything else but enabling Cellular Data Editing, If you mess with any other settings you will most definitely Screw up your phone Big Time


    here are some instruction and a few screen shots on how to use supreme preferences.

    After Downloading and installing Supreme Preferences from Cydia

    Open Winterboard







    once opened press the Select Theme Tab







    In the list you will see Supreme Preferences 3.0 Press it to enable it the Check Mark will show up telling you it is enabled.







    Once enabled Press the Home Button, your phone will do a quick Restart/Respiring.

    when the phone come back on go to your settings







    In the settings menu you will now see the option for Extreme Preferences Press it







    Next Press Applications.







    Next Press Phone







    Now you will see an a tab marked Cellular Data Editing ON/OFF Switch, it should be off at this time, turn it on.












    Now go all the way back to the settings Main Menu, and go to General> Network> Cellular Data Network>



















    And now you should be able to edit everything to your liking.









    After editing everything you need to, go back to Winterboard and disable Supreme Preferences (For Safety)








    hit the home button and your phone will restart/respiring again.

    once you are the main screen again go back to Settings and confirm Supreme Preferences is no longer showing in your setting menu.








    and you should be done, Do not uninstall Supreme Preferences because if you are on 4.1 every so often you need to go back into Cellular Data Network and change some thing and sometimes it disappears out or the setting menu so you may need to Re-Enable Supreme Preferences again.

    Again a warning do not mess with any other settings, you will screw up your iPhone, Use the app for nothing else but enabling Cellular Data Network Tab.



    P.S. if you need any help PM me.......
    Last edited by Rinnycoop121; 2010-11-01 at 05:43 PM.
    .................................................. .................................................. ...Don't forget the hit the Thanks Button

  12. The Following User Says Thank You to Rinnycoop121 For This Useful Post:

    brooksbiggis (2011-02-22)

  13. #12
    Xsellize gives me errors when downloading. Need another option.

  14. #13
    add repo.insanely.com to sources...search for TetherMe APN Editing from insanelyi because theres one from BigBoss too...install it..now go to setting an the cellular settings tab should be there

  15. #14
    What's Jailbreak?
    Join Date
    Jul 2010
    Location
    florida
    Posts
    13
    Thanks
    1
    Thanked 1 Time in 1 Post
    I was in this same situation and what finally worked for me was installing a carrier bundle and tmobile iPCC.. And make sure you reboot anytime you change your apn

  16. #15
    Green Apple ctangg's Avatar
    Join Date
    Sep 2009
    Location
    Los Angeles, CA
    Posts
    53
    Thanks
    3
    Thanked 3 Times in 3 Posts

    SSH to your Device (or you can use iFile) and locate to

    [System/Libraray/Carrier Bundles/ (YOUR CARRIER).bundle/carrier]

    in this case TMobile_us.bundle and edit yoru carrier.plist (make sure to back it up incase you mess it up). After the line:

    <plist version="1.0">
    <dict>

    add:
    <key>APNEditabilityTypemask</key>
    <integer>5</integer>
    <key>AllowEDGEEditing</key>
    <true/>

    the following line after should be <key>CarrierName</key>

    save it, and reboot your phone and VOILA cellular data network tab should pop right up it worked for me and should work for you as well.

    EDIT///
    i did this with an iphone4 4.2.1 baseband 01.59.00

  17. The Following User Says Thank You to ctangg For This Useful Post:

    Grynek77 (2011-02-20)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •