Page 1 of 3 123 LastLast
Results 1 to 20 of 45

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iphone 4 - can not get data service working

  1. #1
    Default iphone 4 - can not get data service working
    Please help...

    I have just upgraded from 3gs fw 3.1.3 to iphone 4

    Everything was working fine. i was using tmo preferred web for months and when i switch my sim back to 3gs, everything is working so i know there is no change in my data plan.

    Trying to setup my iphone 4. it is on FW 4.0 jb with jailbreakme and unlocked with ultrasnow.

    Went into the cellular network settings and input the apns

    internet2.voicestream.com
    wap.voicestream.com
    epc.tmobile.com

    Neither of them are working.

    Please help anyone? I have been reading/searching. re inputing the settings. rebooting. reset the settings.

    no luck.

  2. #2
    every time you after rebooting your phone, take out sim wait for a few second then put it back in and see if that fix ur problem

  3. #3
    Thanks Chityuulay. i read another thread about ejecting the sim late last night.

    today i went to tmo store and got a new sim. however, i still have a similar problem when i reboot the phone, 4/5 times the phone does not see the sim.

    its really pissing me off. i finally got it working and edge is now working also.

    i still have the mms unable to receive problem, but i dont want to mess with it anymore as i would need to reboot the phone.

    better to have a partially functioning phone than a brick...

    rant: honestly, does this sh*t need to be so hard.... just want my phone to work, internet and mms... reading threads for 3 days straight and still not fixed... <end rant>.

  4. #4
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    seattle
    Posts
    113
    Thanks
    2
    Thanked 8 Times in 8 Posts

    Quote Originally Posted by ratbrain View Post
    Thanks Chityuulay. i read another thread about ejecting the sim late last night.

    today i went to tmo store and got a new sim. however, i still have a similar problem when i reboot the phone, 4/5 times the phone does not see the sim.

    its really pissing me off. i finally got it working and edge is now working also.

    i still have the mms unable to receive problem, but i dont want to mess with it anymore as i would need to reboot the phone.

    better to have a partially functioning phone than a brick...

    rant: honestly, does this sh*t need to be so hard.... just want my phone to work, internet and mms... reading threads for 3 days straight and still not fixed... <end rant>.
    what is your setting for MMS?maybe i can help you.

  5. #5
    APN: epc.tmobile.com
    MMSC: http://mms/msg/eng.t-mobile.com/mms/wapenc
    MMS Proxy: 216.155.165.50:8080
    MMS Max size: 1048576
    MMS UA Prof URL: http://www.apple.com/mms/uaprof.rdf

    i've finally updated successfully my carrier package as noted on the sticky, SSH and updated the worsel(spelling?) package, and also tried the cydia pushfix packages as well.

    nothing has worked... i can send but cant receive...

  6. #6
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    seattle
    Posts
    113
    Thanks
    2
    Thanked 8 Times in 8 Posts

    uninstall pushfix fist befor you do this.
    for iphone 4. add source in cydia: beta.leimobile.com/repo.after add this source and go this source install t-mobile 4.0 MMS fix.and reboot
    Last edited by vimm; 2010-09-28 at 08:38 PM.

  7. #7
    sorry for being a noob. how do i uninstall the pushfix?

  8. #8
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    seattle
    Posts
    113
    Thanks
    2
    Thanked 8 Times in 8 Posts

    Quote Originally Posted by ratbrain View Post
    sorry for being a noob. how do i uninstall the pushfix?
    go to cydia seach for pushfix or one you installed and select modify and select uninstall.

  9. #9
    ok. ill try it tonight...

  10. #10
    ok. unistalled the previous packages. installed the new one from leimobile.

    not working. now i cant send out either....

  11. #11
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    seattle
    Posts
    113
    Thanks
    2
    Thanked 8 Times in 8 Posts

    Quote Originally Posted by ratbrain View Post
    ok. unistalled the previous packages. installed the new one from leimobile.

    not working. now i cant send out either....
    now look at your setting.what is your setting under celucar apn and MMS apn?



    Add http://beta.leimobile.com/repo/ to your cydia sources and Install the T-Mobile 4.0 MMS fix, then reboot

    Add this to your Settings>General>Network>Cellular Data Network

    MMS
    APN: epc.tmobile.com
    Username:
    Password:
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS Proxy: 216.155.165.50:8080
    MMS Max Message Size: 1048576
    MMS UA Prof URL: http://www.apple.com/mms/uaprof.rdf
    Last edited by vimm; 2010-10-07 at 08:50 PM.

  12. #12
    yes. those were my exact settings. i've even reset them and retyped them in. still no go....

  13. #13
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    seattle
    Posts
    113
    Thanks
    2
    Thanked 8 Times in 8 Posts

    what type data plane you have with tmoible.(T-zone,webtogo or othing)?

  14. #14
    iPhone? More like MyPhone Rinnycoop121's Avatar
    Join Date
    May 2008
    Location
    Texas
    Posts
    278
    Thanks
    26
    Thanked 24 Times in 18 Posts

    Quote Originally Posted by vimm View Post
    now look at your setting.what is your setting under celucar apn and MMS apn?



    Add http://beta.leimobile.com/repo/ to your cydia sources and Install the T-Mobile 4.0 MMS fix, then reboot

    Add this to your Settings>General>Network>Cellular Data Network

    MMS
    APN: epc.tmobile.com (Depending on what plan you have)
    Username:
    Password:
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS Proxy: 216.155.165.50:8080
    MMS Max Message Size: 1048576
    MMS UA Prof URL: http://www.apple.com/mms/uaprof.rdf
    on my 3g with web2go plan i had to use wap.voicestream.com

    on my i4 with mytouch plan i used epc.tmobile.com

  15. #15
    i have preferred web . i had the same service for my 3gs which i just switched a few weeks ago to the iphone4. MMS was working , receive and send , on my 3gs just fine.

    i just cant get the damn thing to work on the iphone 4.

  16. #16
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    seattle
    Posts
    113
    Thanks
    2
    Thanked 8 Times in 8 Posts

    try this.i was have plane for t-zone and i use the same setting what you have.right now i switch plane to webtogo and i have the same problem what you have, but right now i found the problem in my setting and work just fine now.try this after you install mms fix from this souce:beta.leimobile.com/repo.make sure you add "0" at mms proxy: MMS Proxy: 216.155.165.050:8080.reboot your device after each time you change any setting.
    MMS
    APN: epc.tmobile.com
    Username:
    Password:
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS Proxy: 216.155.165.050:8080
    MMS Max Message Size: 1048576
    MMS UA Prof URL: http://www.apple.com/mms/uaprof.rdf
    Last edited by vimm; 2010-10-12 at 05:50 PM.

  17. #17
    ok.. ill give this a try tonight...

  18. #18
    ok. reset network settings. rebooted. input all the settings as above again but inputing MMS Proxy: 216.155.165.050:8080

    rebooted.

    no go. still cant send or recieve.. this really is pissing me off...

  19. #19
    im with u my mms wont work at all...i cant sent..or get
    i mess with it a lot till i got it to work to sent..but couldnt receieve
    n then another situation when i could receive but not get lol i give up until theres a really a good fix im on smartphone data plan

  20. #20
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Location
    seattle
    Posts
    113
    Thanks
    2
    Thanked 8 Times in 8 Posts

    what type data plane are you using?.becacause when i used t-zone i did not have any problem till i switch to webtogo for $10 one and i start have the problem with mms and internet setting.if you use webtogo plane read this that what i have have to do to make my working.Patch CommCenter & T-Mobile US Enable Carrier Bundles ( 1 2 3 ... Last Page) .
    Last edited by vimm; 2010-10-19 at 07:22 AM.

Page 1 of 3 123 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •