Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3g 4.0.2 won't read sim

  1. #1
    Default iPhone 3g 4.0.2 won't read sim
    Hey guys , Im running a 3g on 4.0.2 , I used redsnow to jailbreak, installed ultrasnow via cydia and when I insert my tmobile sim card it will say searching for about 2-3 minutes and then go to no service. Am I missing something here any advice is appreciated thank you

  2. #2
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Go to settings.. general.. network... Turn 3G OFF... then reboot.

  3. #3
    Tried that , I disabled 3g before installing ultrasnow.

    Do I have to enter anything for the data settings?
    When jailbreak/unlocking should my sim card be in or out of the phone? Thanks

    So I restored and updated , same with 4.0.2 , to activate I used my dads AT&T sim card , I then exited iTunes, used the newest version of redsnow with the 4.0 Ispw firmware , cydia was installed , I then installed ultrasnow , put in tmobile sim ard and rebooted the phone, still searching for 2-3 minutes and then no service. Please somebody help , I'll pay $20 through paypal if someone has my answer thanks!!
    Last edited by Vetti; 2010-08-29 at 01:28 PM. Reason: Automerged Doublepost

  4. #4
    Hello there - I have the same problem as well. I jailbreak iPhone 3g, version 4.0.2, firmware 05.13.04 using redsn0w but my T-mobile SIM Card is not recognizing. I updated Cydia but still did not work. Do I have to use "unlocking" software? I thought Cydia would take care of this. I even changed the Network to turn off the Enable 3G - still no luck. I can get connected to WiFi though. Please share your input! Thanks in advance.

  5. #5
    that happened to me today, turn airplane mode on, then off. then give it a couple minutes and it should go back to tmobile.

    i have a question, do you have the tmobile data plan? my internet has been super slow i can barely download anything from the app store, just wondering if its just mine

  6. #6
    I had to rejailbreak and unlock my 3G recently too and ever since, I can't get it to recognize my TMo SIM either. My SIM works in other phones but not the 3G. My friend's TMo SIM works in my iPhone as well as other people's AT&T SIMs. I even got a brand new SIM card from TMo...still nothing. I'm not sure what has happened.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •