Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4 Tmobile APN option missing?

  1. #1
    What's Jailbreak?
    Join Date
    Aug 2010
    Location
    Flordia
    Posts
    14
    Thanks
    1
    Thanked 1 Time in 1 Post
    Question iPhone 4 Tmobile APN option missing?
    Hi, I can finally post this, my WiFi hasn't been to friendly lately. Anyways, I want to enable MMS on my i4, unlocked with ultrasn0w, but the Cellular Data Network option is missing. The internet is working fine without configuration, but there is no option to configure my APN settings. I only have check boxes whether or not I want data roaming, 3G, or Cellular data off, etc, but no Cellular Data Network. Is there any way to fix this? I'm pretty sure I jailbroke with Jailbreakme 2.0. I have the option to insert mms into a text and whether I want FaceTime activated or not. Any help appreciated.
    ~Long time iPhone modder, first time iPhone forum user.

  2. The Following User Says Thank You to BrokeNCYDEz For This Useful Post:

    Rory23 (2011-03-01)

  3. #2
    Quote Originally Posted by BrokeNCYDEz View Post
    Hi, I can finally post this, my WiFi hasn't been to friendly lately. Anyways, I want to enable MMS on my i4, unlocked with ultrasn0w, but the Cellular Data Network option is missing. The internet is working fine without configuration, but there is no option to configure my APN settings. I only have check boxes whether or not I want data roaming, 3G, or Cellular data off, etc, but no Cellular Data Network. Is there any way to fix this? I'm pretty sure I jailbroke with Jailbreakme 2.0. I have the option to insert mms into a text and whether I want FaceTime activated or not. Any help appreciated.
    ~Long time iPhone modder, first time iPhone forum user.
    For APN to show up i boot up my phone with out SIM card in there. unlock to springboard and put in your tmobile SIM and you should see it show up.

    If that doesn't work then uninstall ultrasn0w and reboot. reinstall ultrasn0w with out a sim card and reboot. unlock to springboard and put in tmobile sim card.

  4. The Following 2 Users Say Thank You to astrax For This Useful Post:

    bluesubtonic (2010-08-18), kewty01 (2010-08-13)

  5. #3
    What's Jailbreak?
    Join Date
    Aug 2010
    Location
    Flordia
    Posts
    14
    Thanks
    1
    Thanked 1 Time in 1 Post
    I tried your methods, nothing worked. Still no Cellular Data Network option.

  6. #4
    iPhone? More like MyPhone zYxMa's Avatar
    Join Date
    Nov 2009
    Location
    EU
    Posts
    192
    Thanks
    5
    Thanked 22 Times in 18 Posts

    Quote Originally Posted by BrokeNCYDEz View Post
    I tried your methods, nothing worked. Still no Cellular Data Network option.
    Try this maybe: http://modmyi.com/forums/file-mods/7...rier-mods.html

  7. #5
    i read the post at dev team blog and it has to do with how old your sim card is as well.. take a look

    --
    Ok, I put my simcard in it (which is brand new) and the cellular data network came up, so it was a sim card issue. I took out my sim and it stayed there when I put my wifes back in, then the mms wouldn't send or receive. It would just give the red exclamation point almost immediately after hitting send (I installed the tmobile mms fix that works perfect on my phone). Her sim is older so I cut up one of my brand new ones and everything is working perfectly. So I think anyone having this issue should just update their sim card, they recommend replacing it every 3 years when I talked to tmobile on the phone. But thanks for all your help!

  8. #6
    Default EUREKA!!! I saw the wheel!
    Quote Originally Posted by astrax View Post
    For APN to show up i boot up my phone with out SIM card in there. unlock to springboard and put in your tmobile SIM and you should see it show up.

    If that doesn't work then uninstall ultrasn0w and reboot. reinstall ultrasn0w with out a sim card and reboot. unlock to springboard and put in tmobile sim card.
    You know what? I've tried everything else, from re-jailbreaking from back up, to restoring 10million(x) and nothing worked. Even the iphonedelivery repo to the betaleimobile repo. NOTHING WORKS!!! And I have no idea on how to do ssh.

    However! I did try your method to take out the sim card and reinserting it. At first I was discouraged because it didn't work. Then I kept trying it again and again. I mean...I've tried everything else literally. VOILA! Voila. I got a cellular data network tab without all those space junk repos.

    Dude, thanks. I've been at this for days.

  9. The Following User Says Thank You to bluesubtonic For This Useful Post:

    Chityuulay (2010-08-20)

  10. #7
    having such bad luck, i tried doing all this but i usually just end up losing signal or just showing one bar with no carrier logo. ughh this is so frustrating! thanks to everyone for the tips though

  11. #8
    Quote Originally Posted by KingOfPwange View Post
    having such bad luck, i tried doing all this but i usually just end up losing signal or just showing one bar with no carrier logo. ughh this is so frustrating! thanks to everyone for the tips though
    It happened to me, too: the single bar without the carrier logo. You should wait a couple minutes, and then do a hard reboot (hold down the power & home button [disregard slide off} until it shuts down, then turn it back on with the power button.

    What works for me: instead of hitting 'ok' when the phone says 'no sim card installed,' just wait until it goes away on its own.

    Hope that helps.

  12. #9
    Quote Originally Posted by bluesubtonic View Post
    You know what? I've tried everything else, from re-jailbreaking from back up, to restoring 10million(x) and nothing worked. Even the iphonedelivery repo to the betaleimobile repo. NOTHING WORKS!!! And I have no idea on how to do ssh.

    However! I did try your method to take out the sim card and reinserting it. At first I was discouraged because it didn't work. Then I kept trying it again and again. I mean...I've tried everything else literally. VOILA! Voila. I got a cellular data network tab without all those space junk repos.

    Dude, thanks. I've been at this for days.

    Thank! i tried it twice and works. u have to be in general>Network and then take out the tmobile sim card, then when screen prompt there is no sim, Don't click OK!, then put the sim back in, then THERE IT IS! GOOD LUCK ALL

  13. #10
    Quote Originally Posted by chityuulay View Post
    thank! I tried it twice and works. U have to be in general>network and then take out the tmobile sim card, then when screen prompt there is no sim, don't click ok!, then put the sim back in, then there it is! Good luck all
    omg this works i have tried everything!
    This method worked for me!

    It popped right up!
    Thank you so much

  14. #11
    Quote Originally Posted by grant1x View Post
    omg this works i have tried everything!
    This method worked for me!

    It popped right up!
    Thank you so much
    Click on Thank =D

  15. The Following 2 Users Say Thank You to Chityuulay For This Useful Post:

    grant1x (2010-08-22), opie546 (2011-05-09)

  16. #12
    Default Iphone 4 APN Settings
    this happened by mistake,
    after jailbreak, i didn't have APN tab in the menu to configure.

    i turned on my iphone, in settings -> general -> network i could only see cellular data ( on/off ), and no cellular data network available.

    i took out my sim card, waited around 20 min then put it back in.

    went back to settings -> general -> network and now i can see cellular data network tab to configure it.

    i tested this procedure on 3 iphone 4 devices running on 4.0.1, 4.0.2 and 4.1, they all worked.

    i hope this helps those facing the same problems i had.

  17. #13
    Doesn't work for me at all. I have an h2o sim. What do I do

  18. #14
    i have h2o too and ive been trying every thing and nothing yet please help!!!!

  19. #15
    iPhoneaholic dotFIVE's Avatar
    Join Date
    Sep 2010
    Location
    California
    Posts
    494
    Thanks
    9
    Thanked 82 Times in 79 Posts

    With iFile:

    var/stash/mobile/Libary/Carrier Bundle.bundle/carrier.plist

    At the top, under <dict>, add:

    <key>AllowEDGEEditing</key>
    <true/>

    Reboot.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •